problema al upgradear

Buenas lista, mi sources.list es este:

deb ftp://ftp.ubuntu-es.org/ubuntu/ warty main restricted universe multiverse
deb ftp://ftp.ubuntu-es.org/ubuntu/ warty-security main restricted
deb ftp://ftp.ubuntu-es.org/ubuntu/ warty-updates main restricted universe multiverse

deb-src ftp://ftp.ubuntu-es.org/ubuntu/ warty main restricted universe multiverse
deb-src ftp://ftp.ubuntu-es.org/ubuntu/ warty-security main restricted
deb-src ftp://ftp.ubuntu-es.org/ubuntu/ warty-updates main restricted universe multiverse

deb ftp://ftp.nerim.net/debian-marillat/ stable main
deb ftp://ftp.nerim.net/debian-marillat/ unstable main
deb ftp://ftp.nerim.net/debian-marillat/ testing main
#Juego de rol
deb http://debian.wesnoth.org/sid/ ./
deb-src http://debian.wesnoth.org/sid/ ./

deb http://ftp.es.debian.org/debian/ stable main non-free contrib

y cuando hago el upgradeo me sale esto:
logan@Valhalla:~ $ sudo apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Los siguientes paquetes se han retenido:
libavcodec1 linux-image-2.6-386 linux-restricted-modules-2.6-386 wesnoth
wesnoth-data
Se actualizarán los siguientes paquetes:
iptables mplayer-custom
2 actualizados, 0 se instalarán, 0 para eliminar y 5 no actualizados.
Se necesita descargar 346kB/2322kB de archivos.
Se liberarán 24,6kB después de desempaquetar.
¿Desea continuar? [S/n]
Des:1 ftp://ftp.ubuntu-es.org warty-security/main iptables 1.2.9-10ubuntu0.1 [346kB]
Descargados 346kB en 24s (13,9kB/s)

Preconfiguring packages ...
(Leyendo la base de datos ...
98579 ficheros y directorios instalados actualmente.)
Preparando para reemplazar iptables 1.2.9-10 (usando .../iptables_1.2.9-10ubuntu0.1_i386.deb) ...
Desempaquetando el reemplazo de iptables ...
Preparando para reemplazar mplayer-custom 1:1.0-pre5-0.6ubuntu1 (usando .../mplayer-custom_1%3a1.0-pre5-0.6ubuntu1_i386.deb) ...
Desempaquetando el reemplazo de mplayer-custom ...
Configurando iptables (1.2.9-10ubuntu0.1) ...

Configurando mplayer-custom (1.0-pre5-0.6ubuntu1) ...

Mi pregunta es: porque se retienen algunos paquetes y no se instalan?.

Gracias por leer un post algo largo.

Imagen de bull3tpr00f
+1
0
-1

Solo una cosa

#Juego de rol

deb http://debian.wesnoth.org/sid/ ./
deb-src http://debian.wesnoth.org/sid/ ./

Battle for Wesnoth esta en los repositorios de Ubuntu.

Siento no poderte ayudar más

Saludos!

________________________________________

Blog de cutOff

+1
0
-1
Imagen de Anónimo
+1
0
-1

En la web de debian tienen un manual del apt-get muy bueno que recuerdo que hablaba de como solucionar los paquetes retenidos y cosas asi. Echale un vistazo.

+1
0
-1
Imagen de bull3tpr00f
+1
0
-1

... porque me respondes a mi?? Haz un reply al compañero que necesita ayuda xDDD

________________________________________

Blog de cutOff

+1
0
-1
Imagen de Anónimo
+1
0
-1

Es posible que los paquetes que han sido retenidos dependan en un paquete no instalado, o que los repositorios que estés utilizando no estén completos, al menos para los paquetes que tienes instalados, o que tengan problemas de consistencia, aunque difícilmente sea este último el problema.
Piensa que apt-get upgrade no instala nuevos paquetes, solo actualiza los existentes, por lo que de tener alguna nueva versión de los instalados dependencias con paquetes no instalados o no accesibles te puede fallar.
Con un apt-get dist-upgrade deberías solventar los problemas al buscar la última versión de todos los paquetes instalados y sus dependencias.

Evidentemente, antes de todo esto se impone un apt-get update, para tener realmente actualizadas las bases de datos de paquetes.

Saludos.

+1
0
-1