Cuando le doy a "abrir carpeta"

Imagen de pulidotkd
0 puntos

Cuando le doy a "abrir carpeta" en cualquier programa, como por ejemplo en dropbox, o cuando le doy en chromium a mostrar carpeta de descarga, se me abre siempre el navegador que tenga por defecto, (en este caso chromium) con el indice de archivos, y yo lo que quiero es que se me abra directamente la carpeta.

Gracias y espero haberme explicado bien.

Imagen de rioport
+1
+1
-1

Xubuntu, Lubuntu o cuál.

Una mala solución es instalar el paquete libgnome2-bin:

sudo apt-get install --no-install-recommends libgnome2-bin

Eliminar el archivo xdg-open (que es el del problema):

sudo rm /usr/bin/xdg-open

Crear un enlace hacia gnome-open llamado xdg-open:

sudo ln -s /usr/bin/gnome-open /usr/bin/xdg-open

Y ya solo queda probar.

Si no funciona o se quiere restaurar el archivo xdg-open original original basta con ejecutar lo siguiente:

sudo apt-get install --reinstall xdg-utils
+1
+1
-1

-- GC --

Imagen de pulidotkd
+1
0
-1

Al insertar ya el primer comando, me sale el siguiente mensaje:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
libgnome2-bin ya está en su versión más reciente.
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
libasound2:i386 libatk1.0-0:i386 libavahi-client3:i386
libavahi-common-data:i386 libavahi-common3:i386 libcairo2:i386 libcups2:i386
libdatrie1:i386 libdbus-glib-1-2:i386 libexpat1:i386 libffi6:i386
libfontconfig1:i386 libfreetype6:i386 libgconf-2-4:i386 libgcrypt11:i386
libgdk-pixbuf2.0-0:i386 libglib2.0-0:i386 libgnome-keyring0:i386
libgnutls26:i386 libgpg-error0:i386 libgraphite2-3:i386
libgssapi-krb5-2:i386 libgtk2.0-0:i386 libharfbuzz0a:i386 libjasper1:i386
libjbig0:i386 libjpeg-turbo8:i386 libjpeg8:i386 libk5crypto3:i386
libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 libnspr4:i386
libnss3:i386 libp11-kit0:i386 libpango-1.0-0:i386 libpangocairo-1.0-0:i386
libpangoft2-1.0-0:i386 libpixman-1-0:i386 libsqlite3-0:i386 libstdc++6:i386
libtasn1-3:i386 libthai0:i386 libtiff5:i386 libudev1:i386 libx11-6:i386
libxau6:i386 libxcb-render0:i386 libxcb-shm0:i386 libxcb1:i386
libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386
libxext6:i386 libxfixes3:i386 libxi6:i386 libxinerama1:i386 libxrandr2:i386
libxrender1:i386 libxss1:i386 libxtst6:i386
Use 'apt-get autoremove' to remove them.
0 actualizados, 0 se instalarán, 0 para eliminar y 6 no actualizados.

Ésto me sale desde que instale esta distribución desde el principio, así que vendrá asi por defecto, sin yo instalar nada.

+1
0
-1

---------------------------------------------------------------------------------------

Nos podrán quitar la vida, pero jamás nos quitaran la libertad!

Imagen de rioport
+1
+1
-1

Eso es lo que te está diciendo (entre otras cosas que no tienen que ver con lo tratado en este tema).

Continua con lo demás.

+1
+1
-1

-- GC --

Imagen de pulidotkd
+1
0
-1

Nada mas crear el enlace, solucionado. Muchas Gracias

+1
0
-1

---------------------------------------------------------------------------------------

Nos podrán quitar la vida, pero jamás nos quitaran la libertad!

Imagen de pulidotkd
+1
0
-1

Otra vez el problema, pero esta vez ha sido nada más instalar el sublime-text, que ahora lo que me hace es abrirme éste programa cada vez que quiero abrir una carpeta.

+1
0
-1

---------------------------------------------------------------------------------------

Nos podrán quitar la vida, pero jamás nos quitaran la libertad!

Imagen de rioport
+1
0
-1

¿Si lo desinstalas se soluciona el problema?

¿Qué te devuelve el siguiente comando?:

file /usr/bin/xdg-open
+1
0
-1

-- GC --

Imagen de pulidotkd
+1
0
-1

Si lo desinstalo, funciona correctamente.

+1
0
-1

---------------------------------------------------------------------------------------

Nos podrán quitar la vida, pero jamás nos quitaran la libertad!