Error al actualizar software (solucionado)

Imagen de DavidSa
0 puntos

Buenas noches
Saludos y gracias por adelantado.

Vengo usando Ubuntu desde hace un año mas o menos, nunca he tenido ningún problema, hasta el otro día cuando el sistema se dispuso a actualizarse.
Me aparece el siguiente error:

" El Paquete de sistema esta roto
Compruebe si está usando repositorios de terceros.
En tal caso, desactívelos, ya que son una fuente habitual de problemas.
Posteriormente, ejecute el siguiente comando en un terminal: apt-get install -f"

Si, instale repositorios de terceros... por lo que se, los he desactivado.
Este es el resultado del comando:

david@david-VPCEB1C5E:~$ sudo apt-get install -f
[sudo] password for david:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
linux-headers-3.11.0-12 linux-headers-3.11.0-12-generic
linux-image-3.11.0-12-generic linux-image-extra-3.11.0-12-generic
printer-driver-hpijs
Use 'apt-get autoremove' to remove them.
Se instalarán los siguientes paquetes extras:
libqt5widgets5
Se actualizarán los siguientes paquetes:
libqt5widgets5
1 actualizados, 0 se instalarán, 0 para eliminar y 96 no actualizados.
2 no instalados del todo o eliminados.
Se necesita descargar 0 B/2.221 kB de archivos.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
(Leyendo la base de datos ... 284137 ficheros o directorios instalados actualmente.)
Preparando para reemplazar libqt5widgets5:i386 5.0.2+dfsg1-7ubuntu11 (usando .../libqt5widgets5_5.0.2+dfsg1-7ubuntu11.1_i386.deb) ...
Desempaquetando el reemplazo de libqt5widgets5:i386 ...
dpkg-deb (subproceso): descomprimiendo el miembro del archivo: error de lzma: los datos comprimidos están corrompidos
dpkg-deb: error: el subproceso devolvió el código de salida de error 2
dpkg: error al procesar /var/cache/apt/archives/libqt5widgets5_5.0.2+dfsg1-7ubuntu11.1_i386.deb (--unpack):
no se pudieron copiar los datos extraídos de './usr/lib/i386-linux-gnu/libQt5Widgets.so.5.0.2' a '/usr/lib/i386-linux-gnu/libQt5Widgets.so.5.0.2.dpkg-new': fin de fichero o de flujo inesperado
Se encontraron errores al procesar:
/var/cache/apt/archives/libqt5widgets5_5.0.2+dfsg1-7ubuntu11.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
david@david-VPCEB1C5E:~$

Tampoco puedo instalar software nuevo, aparece el siguiente error:

installArchives() failed: (Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 284137 files and directories currently installed.)
Preparing to replace libqt5widgets5:i386 5.0.2+dfsg1-7ubuntu11 (using .../libqt5widgets5_5.0.2+dfsg1-7ubuntu11.1_i386.deb) ...
Unpacking replacement libqt5widgets5:i386 ...
dpkg-deb (subprocess): decompressing archive member: lzma error: compressed data is corrupt
dpkg-deb: error: subprocess returned error exit status 2
dpkg: error processing /var/cache/apt/archives/libqt5widgets5_5.0.2+dfsg1-7ubuntu11.1_i386.deb (--unpack):
cannot copy extracted data for './usr/lib/i386-linux-gnu/libQt5Widgets.so.5.0.2' to '/usr/lib/i386-linux-gnu/libQt5Widgets.so.5.0.2.dpkg-new': unexpected end of file or stream
No apport report written because MaxReports is reached already
Errors were encountered while processing:
/var/cache/apt/archives/libqt5widgets5_5.0.2+dfsg1-7ubuntu11.1_i386.deb
dpkg: dependency problems prevent configuration of libqt5opengl5:i386:
libqt5opengl5:i386 depends on libqt5widgets5 (= 5.0.2+dfsg1-7ubuntu11.1); however:
Version of libqt5widgets5:i386 on system is 5.0.2+dfsg1-7ubuntu11.

dpkg: error processing libqt5opengl5:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt5printsupport5:i386:
libqt5printsupport5:i386 depends on libqt5widgets5 (= 5.0.2+dfsg1-7ubuntu11.1); however:
Version of libqt5widgets5:i386 on system is 5.0.2+dfsg1-7ubuntu11.

dpkg: error processing libqt5printsupport5:i386 (--configure):
dependency problems - leaving unconfigured

Bueno pues esto es lo que hay, y yo no se que hacer, bueno se me ocurre hacer una instalación nueva, pero aunque Home esta en una partición separada, la verdad es que no me hace gracia.
Si alguien me puede ayudar a solucionarlo mejor.
Gracias.

Imagen de .doc
+1
-1
-1

pues hacer una instalación nueva, en vez de actualizar, siempre fue la opción más recomendada... máxime si se anda 'jugando' con los ppa. Ubuntu dista mucho de ser una distro 'rolling release'.

+1
-1
-1
Imagen de Goyo
+1
0
-1

Parece que el archivo /var/cache/apt/archives/libqt5widgets5_5.0.2+dfsg1-7ubuntu11.1_i386.deb está corrupto, tal vez eliminarlo ayude a solucionarlo.

+1
0
-1
Imagen de DavidSa
+1
0
-1

Bien!! ...ha funcionado.
Despues de eliminar el archivo y ejecutar "apt-get install -f" todo a vuelto a la normalidad.
Mil Gracias, sois geniales.
;-))

+1
0
-1
Imagen de DavidSa
+1
0
-1

Como se marca como cerrado o Solucionado?

+1
0
-1