libc6 (cerrado temporalmente)

Imagen de alejmlg
0 puntos

Buenas! no se si he puesto esto en el lugar adecuado, si es asi digamenlo y retiro el mensaje de inmediato.
Tengo ubuntu 12, el pc es hp dv6.
Ya estuve googleando bastante y he leido muchas paginas con mi problema sin encontrar solucion.
Añadi a la source list dos listas de repositorios y hay comenzó el problema.
Ya use «apt-get -f install», probe con fsck.ext4, entre a synaptic para intentar reparar el paquete roto y todo sin exito, cuando intento instalar algo siempre me aparece el libc6.
¿habria alguna forma de modificar manualmente el libc6 para que no diera error?
Aun no probe a borrar archivos en var/lib/dpkg/info, ¿podria ser la solucion?

Esto es lo que me aparece:
root@nose:/home/nose# apt-cache policy libc6
libc6:
Instalados: 2.17-97
Candidato: 2.17-97
Tabla de versión:
*** 2.17-97 0
100 /var/lib/dpkg/status
2.15-0ubuntu10.5 0
500 http://es.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
500 http://security.ubuntu.com/ubuntu/ precise-security/main i386 Packages
2.15-0ubuntu10 0
500 http://es.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
root@nose:/home/nose# sudo apt-get install
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar «apt-get -f install» para corregirlo.
Los siguientes paquetes tienen dependencias incumplidas:
libc6 : Recomienda: libc6-i686
Rompe: locales (< 2.17) pero 2.13+git20120306-3 está instalado
E: Dependencias incumplidas. Pruebe de nuevo usando -f.

Un saludo a quien pueda leer esto y gracias por haberlo leido.

Atención: hasta no ser corregido por el autor, no se debe de editar este hilo, permanecerá cerrado hasta que el usuario acate las normas del foro y corriga lo que esta mal en este hilo, Muchas gracias.

Imagen de gledof
+1
0
-1

$ sudo dpkg --configure -a
$ sudo dpkg --purge libc6
Luego entra a a Origenes del software ó edita source.list y elimina o comenta (#) las lineas de los nuevos repositorios y vuelve a instalar el paquete desde los repositorios originales de tu sistema. Suerte.

+1
0
-1

Saludos·

Imagen de alejmlg
+1
0
-1

A ver, pego lo que me sale con "sudo dpkg --configure -a " en cuanto a "sudo dpkg --purge libc6" afectaria a tantas dependencias que en caso de que aceptara la orden se caragaria el sistema de archivos, ¿no?

root@nose:/home/nose# dpkg --configure -a
dpkg: problemas de dependencias impiden la configuración de libc6-dev:
libc6-dev depende de libc6 (= 2.17-97); sin embargo:
El paquete `libc6' no está configurado todavía.
dpkg: error al procesar libc6-dev (--configure):
problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libc-dev-bin:
libc-dev-bin depende de libc6 (>> 2.17); sin embargo:
El paquete `libc6' no está configurado todavía.
libc-dev-bin depende de libc6 (<< 2.18); sin embargo:
El paquete `libc6' no está configurado todavía.
dpkg: error al procesar libc-dev-bin (--configure):
problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de locales:
locales depende de libc6 (>= 2.9-0ubuntu10) | libc6.1 (>= 2.9-0ubuntu10); sin embargo:
El paquete `libc6' no está configurado todavía.
El paquete `libc6.1' no está instalado.
libc6 (2.17-97) rompe locales (<< 2.17) y es desempaquetado pero sin configurar.
La versión de `locales' que se desconfigurará es 2.13+git20120306-3.
dpkg: error al procesar locales (--configure):
problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libnih1:
libnih1 depende de libc6 (>> 2.17); sin embargo:
El paquete `libc6' no está configurado todavía.
libnih1 depende de libc6 (<< 2.18); sin embargo:
El paquete `libc6' no está configurado todavía.
dpkg: error al procesar libnih1 (--configure):
problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libnih-dbus1:
libnih-dbus1 depende de libnih1 (= 1.0.3-4.2); sin embargo:
El paquete `libnih1' no está configurado todavía.
libnih-dbus1 depende de libc6 (>= 2.2); sin embargo:
El paquete `libc6' no está configurado todavía.
dpkg: error al procesar libnih-dbus1 (--configure):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
libc6-dev
libc-dev-bin
locales
libnih1
libnih-dbus1

+1
0
-1
Imagen de gledof
+1
0
-1

Synaptic libc6-dev, si lo permite luego sigue con libc6 y continua eliminando o desactivando los repositorios agregados.
Pur ahora no se me ocurre cosa.

+1
0
-1

Saludos·

Imagen de alejmlg
+1
0
-1

Estos son los archivos que me aparecen en /var/lib/dpkg/info

/var/lib/dpkg/info/libc6-dev:i386.md5sums
/var/lib/dpkg/info/libc6:i386.conffiles
/var/lib/dpkg/info/libc6:i386.md5sums
/var/lib/dpkg/info/libc6:i386.postinst
/var/lib/dpkg/info/libc6:i386.preinst
/var/lib/dpkg/info/libc6:i386.prerm
/var/lib/dpkg/info/libc6:i386.shlibs
/var/lib/dpkg/info/libc6:i386.symbols
/var/lib/dpkg/info/libc6:i386.templates

mi duda es si puedo modificar o eliminar alguno para intentar normalizar el sistema.
o coger libc6 de algun sitio e instalarlo ahi, seguramente lo que estoy diciendo es alguna barbaridad, pero seguro que tiene que haber una solucion antes de formatear...

un saludo, ale

+1
0
-1
Imagen de alejmlg
+1
0
-1

synaptic me dice que arregle los paquetes rotos primero, el paquete roto es libc6, si elimino dicho paquete (el libc6) afecta a parte esencial del sistema y se liberara mas de 2 gigas asi que no creo que sea buena idea.

+1
0
-1
Imagen de alejmlg
+1
-1
-1

"""The biggest problem is likely going to be to find the exact version that you had installed before as a .deb, especially if you did apt-get autoclean in between.

In general to install a particular version you would do

sudo apt-get install libc6=2.13-20ubuntu5.1

then you could mark the package as held using:

echo "libc6 hold"|sudo dpkg --set-selections

so that subsequent updates don't update it automatically. Problem for you would be to find a mirror that has the old version and use that or find the .deb for the old version and use dpkg -i ... to install it manually.

Try locate libc6_2.13-20ubuntu5.1_amd64.deb to see whether you have a cached copy.

However, what are the symptoms of the failing program? It's possible there are solutions to the problem other than reverting to an older version of libc6. """

De momento sigue sin servir al ser un paquete esencial pone muchas trabas para instalarse, esto es lo que me sale:

nose@nose:~/Escritorio$ sudo apt-get install libc6_2.15-0ubuntu10.5_i386.deb
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete libc6_2.15-0ubuntu10.5_i386.deb
E: No se pudo encontrar ningún paquete con la expresión regular «libc6_2.15-0ubuntu10.5_i386.deb»
nose@nose:~/Escritorio$ sudo apt-get install libc6_2.15-0ubuntu10.5_i386
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete libc6_2.15-0ubuntu10.5_i386
E: No se pudo encontrar ningún paquete con la expresión regular «libc6_2.15-0ubuntu10.5_i386»

Pero creo que me voy aproximando:
nose@nose:~/Escritorio$ sudo apt-get install libc6-i686
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
El paquete libc6-i686 es un paquete virtual provisto por:
libc6 2.15-0ubuntu10.5 [No es la versión candidata]
libc6 2.15-0ubuntu10 [No es la versión candidata]

E: El paquete «libc6-i686» no tiene un candidato para la instalación

+1
-1
-1
Imagen de Jose Luis 1320
+1
0
-1

Además no cumple con ciertas normas del foro... favor de leer con atención: http://www.ubuntu-es.org/forum/normas.

Tu hilo ha sido temporalmente cerrado, corrìgelo y sera abierto de nuevo, Gracias.

Nota: tu hilo ya esta movido al lugar que corresponde.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro