Problemas al instalar programa desde código fuente (Polyworld)

Imagen de AIMX
0 puntos

Hola buenas

Soy novato en linux (tengo Ubuntu 12.04 LTS) y he estado intentando instalar desde el código fuente (ya que no encuentro otra forma de hacerlo) el programa Polyworld, que por lo que he leido necesita g++, Qt4 y gsl los cuales supuestamente tengo instalados. Al realizar ./configure todo va correctamente pero le pongo el comando make y me suelta el siguiente error:

aimx@aimx-G5129es:~/Escritorio/polyworld/polyworld$ sudo make
scons -f scripts/build/SConstruct
scons: Reading SConscript files ...
NameError: free variable 'qtversion' referenced before assignment in enclosing scope:
File "/home/aimx/Escritorio/polyworld/polyworld/scripts/build/SConstruct", line 256:
build()
File "/home/aimx/Escritorio/polyworld/polyworld/scripts/build/SConstruct", line 27:
envs = env_create()
File "/home/aimx/Escritorio/polyworld/polyworld/scripts/build/SConstruct", line 193:
'QtOpenGL'])
File "/home/aimx/Escritorio/polyworld/polyworld/scripts/build/scons_util.py", line 108:
env.Append( CPPPATH = expand(['/usr/share/qt$VERSION/include/']) )
File "/home/aimx/Escritorio/polyworld/polyworld/scripts/build/scons_util.py", line 99:
path)
File "/home/aimx/Escritorio/polyworld/polyworld/scripts/build/scons_util.py", line 98:
return map(lambda p: p.replace('$MODULE', module).replace('$VERSION',str(qtversion)),
make: *** [all] Error 2

Si alguien que entienda me pudiera ayudar a ver cual es el error se lo agradeceria mucho.

Gracias de antemano.

Imagen de cuentos
+1
0
-1

el problema es que si estas en ubuntu, este no usa las librerías QT, tendrías que instalar kubuntu, que trae kde que es el que utiliza librerías QT.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de cuentos
+1
+2
-1

en una búsqueda por los foros encontré este en ubuntu (ingles) solucionado para ubuntu. espero y te sirva:
http://ubuntuforums.org/showthread.php?t=2008376

+1
+2
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de AIMX
+1
0
-1

Gracias por responder tan rápido pero hay una cosa del tema inglés que no acabo de entender. Según he entendido lo soluciona en el Edit 2 que hace y dice que tiene que vincular las librerías que dice debajo pero luego pone una ruta, tengo que mover las librerias o tengo que descargarlas?

Gracias

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

ASEGURATE que tengas instaladas las librerías de Qt... tengas Ubuntu, Chubuntu, Joduntu... etcuntu... puedes instalar las librerías de Qt.

El post que pone cuentos habla de un problema con Gsl... según tu salida... no tienes problemas con gsl, sino con qt, y es un problema diferente.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de AIMX
+1
0
-1

Intente en un principio instalarlo desde el codigo fuente ocmo el resto de librerias necesarias pero no se por que no me dejaba instalarlo desde la terminal porque me daba fallo asi que me instale el Qt Core y el sdk desde el centro de software de ubuntu y segun esto ya los tengo instalado, quizas me falta algo mas de qt? es que aparecen bastantes cosas de Qt

Gracias por la ayuda

+1
0
-1