error con systemback en entorno grafico (solucionado)

Imagen de ecagigal
0 puntos

he instalado el systemback para hacer copias de seguridad, pero solo me instala en modo terminal y cuando marco con synaptic que quiero instalar la parte grafica me sale una admiracion en rojo, le doy a reparar paquetes rotos y me da este error:

E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.
E: No se pueden corregir las dependencias
E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.
E: No se pueden corregir las dependencias

He probado a solucinarlo con estos comandos en terminal:
sudo apt-get install -f
sudo dpkg --configure -a
sudo apt-get autoclean
sudo dpkg --purge --force-remove-reinstreq systemback
sudo apt-get autoremove

y nada no se soluciona

Imagen de Jose Luis 1320
+1
0
-1

que "nada no se soluciona" tal vez te ayudaría a resolver tu problema... pero no te voy a ayudar con solo "nadas".

solo te puedo decir que dependiendo de los PPAs que hayas agregado, vas rompiendo el sistema en pedacitos y van a exisitir situaciones en donde no tendrás manera de instalar un programa por toda la revoltura de dependencias que genera el usar PPAs sin precaucion alguna.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de ecagigal
+1
-1
-1

Tienes razon, te explico añadi esto:

sudo add-apt-repository ppa:nemh/systemback

necesito ayuda, muchas gracias

+1
-1
-1
Imagen de ecagigal
+1
0
-1

como te he dicho antes Jose luis, tienes razon, el problema es que estoy desesperado, y tienes razon que con un nada no se soluciona, es que estoy venga a mirar documentacion y no doy con ello.

Como te he puesto en el mensaje anterior lo unico que he puesto en los repositorios es

sudo add-apt-repository ppa:nemh/systemback

muchas gracias

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

para comprobarlo haz esto en Terminal:

ls /etc/apt/sources-list.d/

Ahí podras ver si tienes más de un archivo con la extensión .list o .list.save o semejantes, esos archivos contienen la dirección URL de los ppa que agregaste.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de ecagigal
+1
0
-1

Revisando todo recorde que al instalar el ubuntu 13.10 me habia dado este problema

W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ saucy-security/main amd64 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ saucy-security/restricted amd64 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_restricted_binary-amd64_Packages)
W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ saucy-security/main i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_main_binary-i386_Packages)
W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ saucy-security/restricted i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_restricted_binary-i386_Packages)

para corregirlo hice esto

la parte de source list creo que lo he solucionado, ahora mi source list esta asi:
# deb cdrom:[Ubuntu 13.10 _Saucy Salamander_ - Release amd64 (20131016.1)]/ saucy main restricted
# deb http://es.archive.ubuntu.com/ubuntu/ saucy main restricted
# deb http://security.ubuntu.com/ubuntu/ saucy-security main restricted
# deb http://es.archive.ubuntu.com/ubuntu/ saucy-updates main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://es.archive.ubuntu.com/ubuntu/ saucy restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ saucy main restricted
## Major bug fix updates produced after the final release of the
## distribution.
deb http://es.archive.ubuntu.com/ubuntu/ saucy-updates restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ saucy-updates main restricted
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://es.archive.ubuntu.com/ubuntu/ saucy universe
deb-src http://es.archive.ubuntu.com/ubuntu/ saucy universe
deb http://es.archive.ubuntu.com/ubuntu/ saucy-updates universe
deb-src http://es.archive.ubuntu.com/ubuntu/ saucy-updates universe
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://es.archive.ubuntu.com/ubuntu/ saucy multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ saucy multiverse
deb http://es.archive.ubuntu.com/ubuntu/ saucy-updates multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ saucy-updates multiverse
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://es.archive.ubuntu.com/ubuntu/ saucy-backports main restricted universe multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ saucy-backports main restricted universe multiverse
deb http://es.archive.ubuntu.com/ubuntu/ saucy-security main restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ saucy-security main restricted
deb http://es.archive.ubuntu.com/ubuntu/ saucy-security universe
deb-src http://es.archive.ubuntu.com/ubuntu/ saucy-security universe
deb http://es.archive.ubuntu.com/ubuntu/ saucy-security multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ saucy-security multiverse
## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu saucy partner
# deb-src http://archive.canonical.com/ubuntu saucy partner
## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu saucy main
# deb-src http://extras.ubuntu.com/ubuntu saucy main

y debido a eso no me dejaba instalarlo desmarque lo que habia marcado con #, guarde y luego use el synaptic fui a repositorios y en la pestaña de software ubuntu, debajo de donde pone descargable de internet esta marcado con visto todo ahora excepto Controladores privativos para dispositivos (restricted) y haciendo eso se me ha quitado los duplicados y puedo ya he podido instalar java y la interfaz grafica de systemback.

+1
0
-1
Imagen de ecagigal
+1
0
-1

ahora esta asi el source.list

# deb cdrom:[Ubuntu 13.10 _Saucy Salamander_ - Release amd64 (20131016.1)]/ saucy main restricted
deb-src http://archive.ubuntu.com/ubuntu saucy main #Added by software-properties
deb http://es.archive.ubuntu.com/ubuntu/ saucy main
deb-src http://es.archive.ubuntu.com/ubuntu/ saucy universe multiverse main #Added by software-properties
deb http://security.ubuntu.com/ubuntu/ saucy-security main
deb-src http://security.ubuntu.com/ubuntu/ saucy-security main #Added by software-properties
deb http://es.archive.ubuntu.com/ubuntu/ saucy-updates main
deb-src http://es.archive.ubuntu.com/ubuntu/ saucy-updates universe multiverse main #Added by software-properties

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

## Major bug fix updates produced after the final release of the
## distribution.
# deb http://es.archive.ubuntu.com/ubuntu/ saucy-updates restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://es.archive.ubuntu.com/ubuntu/ saucy universe
deb http://es.archive.ubuntu.com/ubuntu/ saucy-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://es.archive.ubuntu.com/ubuntu/ saucy multiverse
deb http://es.archive.ubuntu.com/ubuntu/ saucy-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://es.archive.ubuntu.com/ubuntu/ saucy-backports main universe multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ saucy-backports main universe multiverse #Added by software-properties

# deb http://es.archive.ubuntu.com/ubuntu/ saucy-security main restricted
deb http://es.archive.ubuntu.com/ubuntu/ saucy-security universe
deb-src http://es.archive.ubuntu.com/ubuntu/ saucy-security universe multiverse #Added by software-properties
deb http://es.archive.ubuntu.com/ubuntu/ saucy-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu saucy partner
# deb-src http://archive.canonical.com/ubuntu saucy partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu saucy main
# deb-src http://extras.ubuntu.com/ubuntu saucy main

y claro ahora mi pregunta es por que ontroladores privativos para dispositivos (restricted) si lo marco da ese problema?

+1
0
-1
Imagen de ecagigal
+1
0
-1

En respuesta a si tengo otros ppa instalados, la respuesta es si, usando synaptic en la pestaña de otro software esta marcado:

socios de canonical
Independiente
http://ppa.launchpad.net/tualatrix/ppa/ubuntu saucy main
http://ppa.launchpad.net/joe-yasi/ppa/ubuntu saucy main
http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu saucy main
http://repo.steampowered.com/steam/ precise/

y por ultimo la ppa de systemback

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

una cosa es el archivo /etc/apt/source.list y otra el directorio o carpeta /etc/apt/sources.list.d

para asegurarnos bien de que tantos PPAs tienes haces la orden que te dije anteriormente;

Presiona Ctrl + T para abrir una ventana de terminal y en ella escribes:

ls /etc/apt/sources.list.d

y ya que me diste una noción de tus PPAs, ahora te pregunto ¿que instala cada uno?, salvo de el wine

Y el de steam te recomendo que lo actualices al de saucy, solo si es posible.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de ecagigal
+1
0
-1

escribi el comando que me mandaste y salio esto:

eduardo@eduardo-System-Product-Name:~$ ls /etc/apt/sources.list.d
joe-yasi-yasi-saucy.list steam.list.save
joe-yasi-yasi-saucy.list.save tualatrix-ppa-saucy.list
nemh-systemback-saucy.list tualatrix-ppa-saucy.list.save
nemh-systemback-saucy.list.save ubuntu-wine-ppa-saucy.list
steam.list ubuntu-wine-ppa-saucy.list.save

+1
0
-1
Imagen de ecagigal
+1
0
-1

ppa de tualatrix es para instalar ubuntu tweak
ppa de jose-yasi era inicialmente para instalar wine 1.7.1 aunque tambien tiene las siguientes librerias:
bcache-tools - 0.0.1+git20131010-0+yasi1trusty (changes file) 2014-01-01 Published Trusty Admin All builds were built successfully.
bcache-tools - 0.0.1+git20131010-0+yasi1 (changes file) 2013-11-11 Published Saucy Admin All builds were built successfully.
firefox - 28.0~b1+build1-0ubuntu0~yasi3 (changes file) 2014-02-05 Published Trusty Web All builds were built successfully.
libhal1-flash - 0.2.0rc1-0~yasi2trusty (changes file) 2014-01-01 Published Trusty Libs All builds were built successfully.
libhal1-flash - 0.2.0rc1-0~yasi2 (changes file) 2013-09-06 Published Saucy Libs All builds were built successfully.
ssvnc - 1.0.29-2build1+yasi1trusty (changes file) 2014-01-01 Published Trusty Net All builds were built successfully.
ssvnc - 1.0.29-2build1+yasi1 (changes file) 2013-10-06 Published Saucy Net All builds were built successfully.
systemd-shim - 6-0ubuntu1+yasi1 (changes file) 2014-01-01 Published Trusty Admin All builds were built successfully.
systemd-shim - 6-0ubuntu0.13.10+yasi1 (changes file) 2013-12-10 Published Saucy Admin All builds were built successfully.
wine1.7 - 1.7.12-0ubuntu1~yasi1 (changes file) 17 hours ago Published Trusty Otherosfs All builds were built successfully.
wine1.7 - 1.7.9-0ubuntu1~yasi1

el ppa de steam es el oficial de steam
el de wine, obivo para que es
y la de systemback tambien obvio

espero que con eso tengas mas informacion

Aqui te dejo el link del ppa de joe-jasi : https://launchpad.net/~joe-yasi/+archive/yasi/+packages
y tambien el link de donde lo saque : http://www.itworld.com/software/371219/install-wine-171-ubuntu-1310-sauc...
Este link lo encontre por que no me acordaba del oficial, que como veras luego si me acorde

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

dejar sólo un PPA para wine, no puedes tener 2 PPA para un mismo software.

también parece que tienes 2 repositorios de steam

joe-yasi-yasi-saucy.list steam.list.save
steam.list

también deberías conservar sólo uno.

pero no los vas a eliminar desde Orgienes del software, tienes que usar ppa-purge, este te quita los paquetes que vienen de cada repositorio...

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de ecagigal
+1
0
-1

a ver hice sudo ppa-purge ppa:joe-yasi/yasi y me hizo varias operaciones
despues hice
ls /etc/apt/sources.list.d
y me salio
joe-yasi-yasi-saucy.list
joe-yasi-yasi-saucy.list.save
nemh-systemback-saucy.list
nemh-systemback-saucy.list.save
steam.list
steam.list.save
tualatrix-ppa-saucy.list
tualatrix-ppa-saucy.list.save
ubuntu-wine-ppa-saucy.list
ubuntu-wine-ppa-saucy.list.save
Como aparecian asi, yo lo que he echo use synaptic y fui a repositorios, vi que estaban desmarcados los repos de joe-yasi.
He ido a software de ubuntu marque la opcion que no tenia marcada que era controladores privativos para dispositivos (restricted)
recargo
fui al terminal otra vez
sudo apt-get update
y ya me da todo ok
No he borrado los repos de joe-yasi, apesar de que estan desmarcados y que se les hizo ppa-purge por que no se si hay que hacerlo.

+1
0
-1