Instalación STEAM; error libc6 [SOLUCIONADO]

Imagen de b0nete
0 puntos

Hola vengo con una consulta, estoy intentando instalar STEAM en crunchbang y me da un error con libc6, aqui les dejo las lineas de la terminal para que vean..

b0nete@crunchbang:/media/Kingston$ sudo dpkg -i steam_latest.deb
Seleccionando el paquete steam-launcher previamente no seleccionado.
(Leyendo la base de datos ... 99142 ficheros o directorios instalados actualmente.)
Desempaquetando steam-launcher (de steam_latest.deb) ...
dpkg: problemas de dependencias impiden la configuración de steam-launcher:
steam-launcher depende de libc6 (>= 2.15); sin embargo:
La versión de `libc6:i386' en el sistema es 2.13-38+deb7u1.

dpkg: error al procesar steam-launcher (--install):
problemas de dependencias - se deja sin configurar
Procesando disparadores para hicolor-icon-theme ...
Procesando disparadores para man-db ...
Procesando disparadores para desktop-file-utils ...
Se encontraron errores al procesar:
steam-launcher

Lo único que se me ocurrió hacer fue intentar instalar nuevamente libc6 pero obtengo este mensaje.

b0nete@crunchbang:/media/Kingston$ sudo apt-get install libc6
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
libc6 ya está en su versión más reciente.
Tal vez quiera ejecutar «apt-get -f install» para corregirlo:
Los siguientes paquetes tienen dependencias incumplidas:
steam-launcher : Depende: libc6 (>= 2.15) pero 2.13-38+deb7u1 va a ser instalado
Recomienda: jockey-common pero no es instalable
E: Dependencias incumplidas. Intente «apt-get -f install» sin paquetes (o especifique una solución).
b0nete@crunchbang:/media/Kingston$

Haber si alguien me puede dar una mano, muchas gracias!.

Imagen de elnetotaca
+1
0
-1

Lee todas y cada una de las lineas que presentas.
En una de ellas dice:
"Tal vez quiera ejecutar «apt-get -f install» para corregirlo"

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de ecagigal
+1
0
-1

a parte del apt-get -f install, que te da el propio sistema, de que repositorio estas instlando el steam?

+1
0
-1
Imagen de cuentos
+1
+2
-1

el mensaje del error, steam necesita libc6 (>= 2.15) o sea 2.15 o mayor y estas en debian stable
que tiene la versión libc6 2.13-38.
Tienes que cambiar a testing que es donde esta la versión que necesitas.
http://packages.debian.org/search?suite=jessie&searchon=names&keywords=s...
En CrunchBang no se si se pueda. Por los repositorios que tenga este derivado.

+1
+2
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de b0nete
+1
0
-1

@elnetotaca; Perdón por no aclararlo pero ya lo había hecho y lo único que hacía era desinstalar STEAM.

@ecagigal Descargué el .deb de la página oficial de STEAM y lo intenté instalar con dpkg -i.

@cuentos Exacto, por lo visto debian en sus repositorios estables tiene hasta la version 2.13; lo que hice fue buscar unos repositorios testing que tienen hasta libc6 2.17 y al hacer el update funcionó todo correctamente.
PD: Aclaro que al ser repositorios testing pueden traer problemas, hasta ahora yo no tube ninguno.

+1
0
-1
Imagen de ecagigal
+1
0
-1

si lo has solucionado perfecto y pon en el asunto soluciando, te preguntaba lo de los repositorios para saber y saber si era version estable o testing.

+1
0
-1