problema al instalar modulos php5-* SOLUCIONADO

Imagen de Miguel.fdz
0 puntos

despues de introducir sudo apt-install php5-* me sale lo siguiente:

No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
libapache2-mod-php5 : Entra en conflicto: libapache2-mod-php5filter pero 5.3.10-1ubuntu3.9 va a ser instalado
libapache2-mod-php5filter : Entra en conflicto: libapache2-mod-php5 pero 5.3.10-1ubuntu3.9 va a ser instalado
php5-mysql : Entra en conflicto: php5-mysqlnd pero 5.3.10-1ubuntu3.9 va a ser instalado
php5-mysqlnd : Entra en conflicto: php5-mysql pero 5.3.10-1ubuntu3.9 va a ser instalado
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

que puedo hacer para solucionar el problema? desinstalo php5-mysqlnd e instalo php5-mysql? y lo mismo con los dos anteriores?

Muchas gracias.

Imagen de pwned
+1
0
-1

Tipico problema de sistemas ubuntu xD. Instalalos con aptitude (instalalo si no o tienes), ejecuta:

aptitude install php5-*

Y te saldrá una serie de preguntas. Ya no recuerdo muy bien lo que te preguntaba pero más o menos viene a ser... Te decía algo como que ya tenías x paquetes, que si querías mantenerlos, ahí le pones NO. Luego ya te dirá que va a instalar los nuevos o algo así y respondias SI.

Tengo un vago recuerdo de que erá "no" a la primera pregunta y "si" a las otras dos. Pero tu leelas bien y actua con sensatez/lógica :). Y te lo instala sin problemas.

+1
0
-1
Imagen de Goyo
+1
+1
-1

que puedo hacer para solucionar el problema? desinstalo php5-mysqlnd e instalo php5-mysql?

Instala el que necesites y no instales el otro.

y lo mismo con los dos anteriores?

Lo mismo.

+1
+1
-1