Duración de la batería y calentamiento

Imagen de Eagledroid
0 puntos

Hola, buenas tardes.

Llevo poco tiempo con Ubuntu, he solucionado algunos problemas que me ha dado y cada vez me gusta más.

La cuestión es la siguiente, he notado que la batería me dura mucho menos con Ubuntu 12.04 LTS que con Windows 7 y también que el portátil se calienta más, ya que el ventilador suena más frecuentemente y más fuerte. ¿Esto es normal con Ubuntu? ¿Habría alguna manera de solucionarlo?.

Un saludo.

Gracias.

Imagen de cuentos
+1
0
-1

tienes que dar mas información, Ya que no es normal y menos el calentamiento.
Sabes que procesador, cuanta memoria ram, tarjeta gráfica tienes,
Tambien ejecuta este comando en la terminal para ver los componentes, y pones lo que te sale aquí para ver.
lspci

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Eagledroid
+1
0
-1

Tengo un hp pavilion dv7 con procesador intel® Core™ i7-2670QM CPU @ 2.20GHz × 8, memoria ram de 4GB, gráficos AMD Radeon HD 6700M Series, SO de 64 bits.

Al ejecutar el comando lspci obtengo esto:
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6730M/6770M/7690M XT]
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
0d:00.0 Network controller: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter (rev 01)
13:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
13:00.1 SD Host controller: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
19:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)

+1
0
-1
Imagen de Arnao
+1
0
-1

seguramente sea por los controladores de la gráfica, instala el driver privativo o si por el contrario prefieres seguir usando el libre instala el kernel 3.12 en adelante pues el rendimiento para el driver libre ha aumentado muchísimo, casi a nivel de los privativos

+1
0
-1
Imagen de Eagledroid
+1
0
-1

La sugerencia de cambiar al driver privativo ya me la dieron en otra ocasión y la verdad es que fue mala opción porque al hacerlo e intentar acceder a Ubuntu me salia la pantalla en negro. Asiesque mejor pruebo la segunda opción, la del Kernel. ¿Me pordrías decir como se hace?

+1
0
-1
Imagen de Arnao
+1
0
-1

hace poco salió la cuarta actualización de ubuntu 12.04 que según el siguiente artículo http://www.muylinux.com/2014/02/07/ubuntu-12-04-4-lts si tienes las actualizaciones al día ya se te habrá actualizado todo, escepto el kernel y seguirás con el 3.8 si no me equivoco. Para que se te actualice el kernel al 3.11 y tener totalmente al día tu versión de ubuntu ejecuta esto en una terminal.

sudo apt-get install --install-recommends linux-generic-lts-saucy xserver-xorg-lts-saucy libgl1-mesa-glx-lts-saucy

prueva a ver que tal va, si no notas una mejoría luego te digo como instalar manualmente el kernel 3.12

+1
0
-1
Imagen de Arnao
+1
0
-1

antes de darte indicaciones de como intalar manualmente el kernel 3.12 prueva a seguir los pasos de este tutorial despues de haber actualizado ubuntu al kernel 3.11. Yo lo hice en su día con mi portátil y funcionó de maravilla.
http://www.muylinux.com/2011/06/16/controlar-el-uso-del-ventilador-en-ub...

+1
0
-1
Imagen de Eagledroid
+1
0
-1

Al introducir ese comando me aparece esto:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
libgl1-mesa-glx-lts-saucy : Depende: libglapi-mesa-lts-saucy (= 9.2.1-1ubuntu3~precise1) pero no va a instalarse
Recomienda: libgl1-mesa-dri-lts-saucy (>= 7.2) pero no va a instalarse
wine1.4 : Depende: wine1.4-i386 (= 1.4-0ubuntu4.1)
xserver-xorg-lts-saucy : Depende: xserver-xorg-core-lts-saucy (>= 2:1.11) pero no va a instalarse
Depende: xserver-xorg-input-all-lts-saucy pero no va a instalarse o
xorg-driver-input
Depende: xserver-xorg-input-evdev-lts-saucy pero no va a instalarse
Recomienda: libgl1-mesa-dri-lts-saucy pero no va a instalarse
Recomienda: xserver-xorg-input-all-lts-saucy pero no va a instalarse
Recomienda: xserver-xorg-video-all-lts-saucy pero no va a instalarse
Recomienda: x11-xserver-utils-lts-saucy pero no va a instalarse
Entra en conflicto: libglapi-mesa:i386 (>= 0~)
Entra en conflicto: xserver-xorg-core (>= 0~)
E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.

+1
0
-1
Imagen de Arnao
+1
+1
-1

como solo nos interesa el kernel prueva a ver este comando
sudo apt-get install --install-recommends linux-generic-lts-saucy
de todos modos prueva a instalar los drivers propietarios como te indicamos más abajo

+1
+1
-1
Imagen de Eagledroid
+1
0
-1

Este comando si ha funcionado, pero se ha quedado en la versión del kernel 3.8.0-36-generic. He intentado usar el otro nuevamente pero me ha vuelto a salir el mismo error.

+1
0
-1
Imagen de Arnao
+1
0
-1

bueno habrá que instalarlo manualmente. Primero prueva a ver si se soluciona lo del driver y luego te digo como instalar el kernel

+1
0
-1
Imagen de Arnao
+1
0
-1

sigue este tutorial
http://yoyo308.com/2014/01/16/instalaractualizar-al-kernel-3-12-8-en-ubu...
ten en cuenta que solo tentrás que aplicar los comandos apropiados para la arquitectura que uses, 32 o 64 bit

y después aplica las instrucciones de éste para el control del ventilador
http://www.muylinux.com/2011/06/16/controlar-el-uso-del-ventilador-en-ub...

con eso creo que se te solucionará, por lo menos a mi me funcionó en ubuntu 13.04, que por algún problema tampoco me permitía instalar el driver privativo, instalando este kernel y aplicando lo del control del ventilador ya no tuve problemas de calentamiento, y conseguí un rendimiento excelente.

+1
0
-1
Imagen de Eagledroid
+1
0
-1

He hecho todo lo que me ha indicado, probaré unos días a ver que tal.

Tanto si funciona como si no lo pondré en el foro.

Gracias.

+1
0
-1
Imagen de cuentos
+1
0
-1

el problema es que tienes una gráfica híbrida, y no debes de tomar en cuenta que tienes una ati, o sea no instales un driver de ati a "secas".

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6730M/6770M/7690M XT]

O sea una tarjeta híbrida intel-ati, Lo que se de estos sistemas es que inician con la intel (gráfica de poco poder), y solo cuando requieres una gráfica de "poder"para x programa lanzas en este caso la ATI.
Me imagine esto cuando pusiste tu primer post, te pongo una liga donde esta como instalar esta gráfica, espero y te ayude.
http://foro.ubuntu-guia.com/Instalacion-de-tarjetas-hibridas-td3797950.html
http://foro.ubuntu-guia.com/Graficas-hibridas-td3635150.html
http://emslinux.com/instalar-controladores-ati-catalyst-11-11-en-ubuntu-...

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Arnao
+1
0
-1

este tutorial explica paso a paso como instalar los drivers propietarios, en el punto 6.2 exploca como hacerlo para gráficas híbridas
http://wiki.cchtml.com/index.php/Ubuntu_Precise_Installation_Guide

+1
0
-1
Imagen de Eagledroid
+1
0
-1

He entrado en controladores adicionales y me aparece lo siguiente: ( se lo dejo en una imagen)

https://dl.dropboxusercontent.com/u/87629291/Controlador%20ATI.png

Pone que el controlador está activado pero no se está utilizando. ¿Puede ser ese el problema? ¿Habría alguna forma de hacer que lo utilice?

+1
0
-1
Imagen de Eagledroid
+1
0
-1

He intentado instalar el driver de la tarjeta ATI como indica en el primer enlace que me ha dejado, pero mientras la instalo me da un error y me dice que tengo que borrar la versón que tengo ya. ¿Si hago eso ocurriría algo? es decir no quiero que me de un pantallazo negro ni nada de eso. Y si no ocurre nada ¿como tendría que hacerlo?

+1
0
-1
Imagen de Arnao
+1
0
-1

yo pienso que ese va a ser parte del problema, que tienes los drivers mal instalados, o se han quedado ahí a medias despues de una instalación fallida anterior. Lo primero que debes hacer es desinstalarlos siguiendo los pasos del punto 5 de esta guia:
http://wiki.cchtml.com/index.php/Ubuntu_Precise_Installation_Guide
después instalar el driver siguiendo los pasos del 1.2 y configurar tu tarjeta híbrida según el paso 6.2.2
Te recomiendo que antes te leas toda la guia pues viene todo muy bien indicado

+1
0
-1
Imagen de Eagledroid
+1
0
-1

Hola buenas tardes, conseguí desinstalar la tarjeta usando el punto 5, pero durante el seguimiento del punto 1.2, es decir la instalación, me ha vuelto a decir que sigue instalada. Y en el punto 6, cuando introducia los comandos siempre se salia algo como "comando no encontrado".

La única diferencia es que ahora me sale esto en los controladores, es decir que la ATI está desactivada. ¿O es que antes tenia dos controladores activados para esa tarjeta? Lo digo porque la imagen es de controladores adicionales.
https://dl.dropboxusercontent.com/u/87629291/Controladores%20adiciononal...

+1
0
-1
Imagen de Arnao
+1
0
-1

dale a activar a ver si así se instala el driver

+1
0
-1
Imagen de Eagledroid
+1
0
-1

Lo acabo de activar, pero me pone otra vez lo de antes: "El controlador está activado pero no se está usando actualmente".

Bufff, ¿que puedo hacer?. Esto es desesperante.

Gracias por su interés.

+1
0
-1
Imagen de Arnao
+1
0
-1

creo que tendrás que trabajar con el driver libre pues por lo que sea el el driver se instala pero no permite su funcionamiento. Desinstala el driver privativo como dice el tutorial, con eso ya tendrás trabajando el libre y ya te digo como instalar el kernel 3.12

+1
0
-1
Imagen de Eagledroid
+1
0
-1

He notado que aunque no esté haciendo nada la temperatura del portatil no deja de aumentar, comienza por ejemplo en 40-50º y continua hasta cerca de 60 y es cuando salta el ventilador, cuando esto pasa se enfria un poco y se para el ventilado, pero la temperatura no para de subir en ningún momento. ¿Como puedo solucionar esto?

¿Existe alguna otra distribución linux que sea mejor para ordenadores portátiles? Es decir que tenga mejor soporte hardware para este tipo de ordenadores.

Gracias.

+1
0
-1
Imagen de Arnao
+1
0
-1

no se, a lo mejor tienes por ahí algún proceso que hace que el procesador ande todo el rato trabajando. Para que te hagas una idea mi portatil suele mantenerse entre 60º y 70º con un uso normal (navegador, reproductor de música, libreoffice...), que es más o menos a lo que se encontraba con windows. Cuando lo dejo un rato sin ninguna aplicación trabajando me baja hasta los 58º o por ahí.

+1
0
-1