Grub No Detecta Particion Windows 7

Imagen de dsb_spain
0 puntos

Hola , Buenos Dias

Tenía instalado Window$7 y Windows 8, pero borré la particion de Windows 8 e instalé Ubuntu 13.10.

Al arrancar me detectaba la particion de ubuntu , memtest, y Windows 8 Loader.

El problema es que Windows 7 no me arrancaba entonces quité el MBR de Windows dejando el grub. Desde entonces no me reconoce la partición de Windows 7 ya que está en el /dev/sda2 y en el /dev/sda1 no hay nada.

He buscado por este foro y otros y ya he intentado hacer un update-grub , grub-install /dev/sda y grub-mkconfig && grub-install /dev/sda && update-grub pero ninguno encuentra mi partición de Windows 7

¿Podriais ayudarme?

Un saludo

Imagen de .doc
+1
0
-1

era mejor que no anduvieses 'enredando' con cosas tan críticas como los gestores de arranque. Ya hecho, de nada sirve el consejo, claro. Ayudaría a ver qué problema tienes si escribes (o copia y pega) en consola
sudo fdisk -l
y nos lo copias aquí, para ver cómo tienes las particiones.

+1
0
-1
Imagen de dsb_spain
+1
-1
-1

Hola, si os iba a poner el fdisk -l ahora.

Aquí lo teneis


Disco /dev/sda: 1000.2 GB, 1000204886016 bytes
255 cabezas, 63 sectores/pista, 121601 cilindros, 1953525168 sectores en total
Unidades = sectores de 1 * 512 = 512 bytes
Tamaño de sector (lógico / físico): 512 bytes / 4096 bytes
Tamaño E/S (mínimo/óptimo): 4096 bytes / 4096 bytes
Identificador del disco: 0x80d80198

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sda2 206848 528590847 264192000 7 HPFS/NTFS/exFAT
/dev/sda4 528590910 1953523711 712466401 f W95 Ext'd (LBA)
La partición 4 no se inició en el limite físico del sector
/dev/sda5 528590912 897230847 184319968 7 HPFS/NTFS/exFAT
/dev/sda6 897246378 1614403979 358578801 7 HPFS/NTFS/exFAT
La partición 6 no se inició en el limite físico del sector
/dev/sda7 1614405632 1616404479 999424 82 Linux swap / Solaris
/dev/sda8 1616406528 1630466047 7029760 83 Linux
/dev/sda9 1630468096 1953523711 161527808 83 Linux

Un saludo y gracias por la ayuda

+1
-1
-1
Imagen de dsb_spain
+1
-1
-1

Aqui os dejo el pantallazo, para que lo veáis mejor :

http://i57.tinypic.com/66jci9.png

un saludo y gracias de nuevo

+1
-1
-1
Imagen de dsb_spain
+1
-1
-1

Aqui os dejo tambien el log del Boot Repair : http://paste.ubuntu.com/7021864/

+1
-1
-1
Imagen de .doc
+1
0
-1

no me parece ver ninguna partición con la etiqueta de 'booteable'. Posiblemente sería la /dev/sda1, que ya no existe. Entiendo que el sistema, al iniciarse, debe saber cual es la partición desde donde debe arrancar. No se cómo se hace eso de marcar que una partición sea la booteable (vamos, que nunca lo he hecho). Quizás, con GParted...

+1
0
-1
Imagen de dsb_spain
+1
-1
-1

Hola, he visto que la partición de Windows 7 está marcada como "boot" pero aún así no me lo reconoce ni grub ni grub 2

Creo que lo mejor seria borrar las particiones de Ubuntu , regenerar el mbr de windows y volver a instalar ubuntu no ?

un saludo

+1
-1
-1
Imagen de .doc
+1
0
-1

¿seguro...? la partición booteable está marcada, en fdisk -l por un asterisco, y yo no lo veo por ninguna parte. Mira cómo lo tengo yo (bueno, yo no tengo Windows, claro)
http://s17.postimg.org/bjdjx599r/fdisl.png

+1
0
-1
Imagen de dsb_spain
+1
-1
-1

Hola, ya veo. Es decir que esa partición (la de Windows en /dev/sda2) está perdida no ?

un saludo y gracias por ayudarme

+1
-1
-1
Imagen de .doc
+1
0
-1

no, no está perdida. Lo que he dicho es que tienes que tener es una partición 'booteable', quizás esa (ya te he dicho que no he puesto esa etiqueta 'boot' nunca, espera a ver si alguien que sepa más te da alguna idea de cómo hacelo sin perderla).

+1
0
-1
Imagen de Arg0s
+1
0
-1

El post tiene ya unos cuantos días, pero por si acaso:

Parece que dsb_spain ha borrado el loader de Windows, por eso GRUB no lo detecta.

Para eso se necesita el DVD de inst. de Windows, meterse en la sección de reaparación y en las opciones avanzadas de recuperación del sistema e intentar reconstruir el Bsb desde command prompt y ejecutar > bootrec /RebuildBsb Te reconocerá, si todo va bien. todas las instalaciones de Windows en tu HD

Una vez hecho eso, reinicia, consola... # update-grub2 y entonces sí: Windows aparecerá de nuevo.

Saludos

+1
0
-1