Paquete de sistema roto

Imagen de Mediosordo
0 puntos

Hola, ayer intenté instalar el Sopcast en Ubuntu 12.10 via terminal:
$ sudo add-apt-repository ppa:lyc256/sopcast-player-ppa
$ sudo apt-get update
$ sudo apt-get install sopcast-player

Sin embargo algo falló y me salió este mensaje de error:
Se encontraron errores al procesar:
/var/cache/apt/archives/libsane_1.0.23-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Al abrir el Centro de Software de Ubuntu me dice que no puedo instalar nada hasta reparar el catálogo de paquetes y al darle a reparar me sale esto:

installArchives() failed: (Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 211915 files and directories currently installed.)
Unpacking libsane:i386 (from .../libsane_1.0.23-0ubuntu1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libsane_1.0.23-0ubuntu1_i386.deb (--unpack):
trying to overwrite shared '/lib/udev/rules.d/40-libsane.rules', which is different from other instances of package libsane:i386
No apport report written because MaxReports is reached already
Errors were encountered while processing:
/var/cache/apt/archives/libsane_1.0.23-0ubuntu1_i386.deb
Error in function:
dpkg: dependency problems prevent configuration of ia32-libs-multiarch:
ia32-libs-multiarch depends on libsane; however:
Package libsane:i386 is not installed.


dpkg: error processing ia32-libs-multiarch (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ia32-libs:
ia32-libs depends on ia32-libs-multiarch; however:
Package ia32-libs-multiarch is not configured yet.


dpkg: error processing ia32-libs (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of sp-auth:
sp-auth depends on ia32-libs; however:
Package ia32-libs is not configured yet.

dpkg: error processing sp-auth (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of sopcast-player:
sopcast-player depends on sp-auth (>= 3.0.1); however:
Package sp-auth is not configured yet.


dpkg: error processing sopcast-player (--configure):
dependency problems - leaving unconfigured

He buscado posibles soluciones en los foros, pero la solución más recurrida es la de apt-get -f install, pero a mi no me sirve ya que me da otro error:
Desempaquetando libsane:i386 (de .../libsane_1.0.23-0ubuntu1_i386.deb) ...
dpkg: error al procesar /var/cache/apt/archives/libsane_1.0.23-0ubuntu1_i386.deb (--unpack):
trying to overwrite shared '/lib/udev/rules.d/40-libsane.rules', which is different from other instances of package libsane:i386
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
Se encontraron errores al procesar:
/var/cache/apt/archives/libsane_1.0.23-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Otra posibilidad que he visto es eliminando las PPA's via ppa-purge, pero al no poder instalar via apt-get me he quedado sin opciones.

A alguien se le ocurre alguna solución para repararlo?

Muchas gracias!

Imagen de Jose Luis 1320
+1
0
-1

No tiene por que instalar nada...

En su lugar eliminas.

¿que origen tiene libsane?

lo puedes ver con :

apt-cache policy libsane:i386
+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Goyo
+1
-1
-1

Desinstala libsane:i386

+1
-1
-1
Imagen de Mediosordo
+1
0
-1

Pues esto es lo que me sale:

manuel@Mediosordo-II:~$ apt-cache policy libsane:i386
libsane:i386:
Instalados: (ninguno)
Candidato: 1.0.23-0ubuntu1
Tabla de versión:
1.0.23-0ubuntu1 0
500 http://es.archive.ubuntu.com/ubuntu/ quantal/main i386 Packages

Muchas gracias.

+1
0
-1
Imagen de Goyo
+1
0
-1

Tonto de mí, desde luego desinstalar no era la solución. A ver si esto te ayuda:
https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1186715

+1
0
-1
Imagen de Mediosordo
+1
-1
-1

Pues no me ha funcionado. Los primeros pasos han ido sin problemas..
sudo mv /var/lib/dpkg/status /var/lib/dpkg/status-bad
sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
sudo mv /var/lib/dpkg/available /var/lib/dpkg/available-bad
sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
sudo rm -rf /var/lib/dpkg/updates/*
sudo rm -rf /var/lib/apt/lists/*
sudo mkdir /var/lib/apt/lists/partial
sudo rm /var/cache/apt/*.bin
sudo apt-get clean

Con sudo apt-get autoremove ya no ha ido tan bien..

manuel@Mediosordo-II:~$ sudo apt-get autoremove
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar «apt-get -f install» para corregirlo.
Los siguientes paquetes tienen dependencias incumplidas:
ia32-libs-multiarch:i386 : Depende: libsane:i386 pero no es instalable
E: Dependencias incumplidas. Pruebe de nuevo usando -f.

Como he visto que el -f se usaba al final, he seguido con las siguientes órdenes.

El sudo apt-get update me lo ha hecho sin problema, pero bien es cierto que ayer había desactivado las ppa de Sopcast del sources.list

Luego, el sudo dpkg --configure -a me ha dado esto...

dpkg: dependency problems prevent configuration of ia32-libs-multiarch:
ia32-libs-multiarch depende de libsane; sin embargo:
El paquete `libsane:i386' no está instalado.

dpkg: error al procesar ia32-libs-multiarch (--configure):
problemas de dependencias - se deja sin configurar
dpkg: dependency problems prevent configuration of ia32-libs:
ia32-libs depende de ia32-libs-multiarch; sin embargo:
El paquete `ia32-libs-multiarch' no está configurado todavía.

dpkg: error al procesar ia32-libs (--configure):
problemas de dependencias - se deja sin configurar
dpkg: dependency problems prevent configuration of sp-auth:
sp-auth depende de ia32-libs; sin embargo:
El paquete `ia32-libs' no está configurado todavía.

dpkg: error al procesar sp-auth (--configure):
problemas de dependencias - se deja sin configurar
dpkg: dependency problems prevent configuration of sopcast-player:
sopcast-player depende de sp-auth (>= 3.0.1); sin embargo:
El paquete `sp-auth' no está configurado todavía.

dpkg: error al procesar sopcast-player (--configure):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
ia32-libs-multiarch
ia32-libs
sp-auth
sopcast-player

y finalmente el sudo apt-get install -f me ha dado esto..

manuel@Mediosordo-II:~$ sudo apt-get install -f
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
gir1.2-unique-3.0 libquazip1 libunique-3.0-0 openjdk-7-jre-lib
Use «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes extras:
libsane:i386
Paquetes sugeridos:
hpoj:i386 hplip:i386 libsane-extras:i386 sane-utils:i386
Se instalarán los siguientes paquetes NUEVOS:
libsane:i386
0 actualizados, 1 se instalarán, 0 para eliminar y 12 no actualizados.
4 no instalados del todo o eliminados.
Se necesita descargar 3.734 kB de archivos.
Se utilizarán 8.970 kB de espacio de disco adicional después de esta operación.
¿Quiere continuar [S/n]? s
Err http://es.archive.ubuntu.com/ubuntu/ quantal/main libsane i386 1.0.23-0ubuntu1
Algo raro pasó al resolver «es.archive.ubuntu.com:http» (-5 - No existe ninguna dirección asociada al nombre)
Imposible obtener http://es.archive.ubuntu.com/ubuntu/pool/main/s/sane-backends/libsane_1.0.23-0ubuntu1_i386.deb Algo raro pasó al resolver «es.archive.ubuntu.com:http» (-5 - No existe ninguna dirección asociada al nombre)
E: No se pudieron obtener algunos archivos, ¿quizás deba ejecutar «apt-get update» o deba intentarlo de nuevo con --fix-missing?

Mil perdones por la lata..

+1
-1
-1
Imagen de Goyo
+1
0
-1

Algo raro pasó al resolver «es.archive.ubuntu.com:http» (-5 - No existe ninguna dirección asociada al nombre)
Imposible obtener http://es.archive.ubuntu.com/ubuntu/pool/main/s/sane-backends/libsane_1.0.23-0ubuntu1_i386.deb Algo raro pasó al resolver «es.archive.ubuntu.com:http» (-5 - No existe ninguna dirección asociada al nombre)

Esto es otra cosa, parece que hay un problema de acceso a Internet, tal vez temporal?.

+1
0
-1
Imagen de Mediosordo
+1
0
-1

Pues sí, esta mañana se me cayó la conexión un par de veces. Y por lo que se vé, otra más mientras estaba haciendo esto. De todos modos he vuelto a repetir todos los pasos y el sudo apt-get install -f me sigue dando errores:

manuel@Mediosordo-II:~$ sudo apt-get install -f
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
gir1.2-unique-3.0 libquazip1 libunique-3.0-0 openjdk-7-jre-lib
Use «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes extras:
libsane:i386
Paquetes sugeridos:
hpoj:i386 hplip:i386 libsane-extras:i386 sane-utils:i386
Se instalarán los siguientes paquetes NUEVOS:
libsane:i386
0 actualizados, 1 se instalarán, 0 para eliminar y 14 no actualizados.
4 no instalados del todo o eliminados.
Se necesita descargar 3.734 kB de archivos.
Se utilizarán 8.970 kB de espacio de disco adicional después de esta operación.
¿Quiere continuar [S/n]? s
Des:1 http://es.archive.ubuntu.com/ubuntu/ quantal/main libsane i386 1.0.23-0ubuntu1 [3.734 kB]
Descargados 3.734 kB en 37seg. (99,5 kB/s)
(Leyendo la base de datos ... 211915 ficheros o directorios instalados actualmente.)
Desempaquetando libsane:i386 (de .../libsane_1.0.23-0ubuntu1_i386.deb) ...
dpkg: error al procesar /var/cache/apt/archives/libsane_1.0.23-0ubuntu1_i386.deb (--unpack):
trying to overwrite shared '/lib/udev/rules.d/40-libsane.rules', which is different from other instances of package libsane:i386
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
Se encontraron errores al procesar:
/var/cache/apt/archives/libsane_1.0.23-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

+1
0
-1
Imagen de Mediosordo
+1
0
-1

Alguna otra idea de como solucionar esto?

Gracias!

+1
0
-1