Hacer funcionar wifi con Realtek RTL8188CE

Imagen de dani_
0 puntos

Como siempre me he conectado mediante cable a internet no he tenido problemas, hasta que por necesidad tube que hacerlo por wifi. El caso es que di a la tecla de funcion (es un portatil) + F12 para activar el wifi, se encendio la luz y tras unos segundos se me puso una pantalla negra con una parrafada de comandos o lo que sea con las letras en blanco. el caso es que en esa pantalla no se puede escribir ni nada y tengo que reiniciar el ordenador. Probé descargando los drivers de realtek, pues es una RTL8188CE.
Abrir el Centro DE Software de Ubuntu y descargé build-essential y linux-headers-generic.

Me dirigí a la carpeta de descargas donde se encuentre el paquete descargado de realtek, boton derecho > “Extraer aquí”
Abro la consola y escribo la direcccion donde se ha descargado el archivo y entro en la carpeta donde se ha extraido:

cd /home/Nombre_Usuario/Descargas
cd Nombre_carpeta_extraida

Comienzo la compilación escribiendo en la consola lo siguiente:

make

y luego

sudo make install

En el make ya me sale un error y al instalar lo mismo. El caso es que no me funcionó.
Que puedo hacer?
La consulta se hace sobre el siguiente equipo: Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb y la tarjeta wifi la que os comenté Realtek RTL8188CE.
Ubuntu 12.04
Un saludo y muchas gracias.

Imagen de dani_
+1
0
-1

El error que me sale es el siguiente
root@ubuntu-laptop:/home/dani/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013# make
make -C /lib/modules/3.8.0-37-generic/build M=/home/dani/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013 modules
make[1]: se ingresa al directorio «/usr/src/linux-headers-3.8.0-37-generic»
CC [M] /home/dani/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.o
In file included from /home/dani/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.c:39:0:
/home/dani/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/pci.h:247:15: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rtl_pci_probe’
make[2]: *** [/home/dani/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.o] Error 1
make[1]: *** [_module_/home/dani/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013] Error 2
make[1]: se sale del directorio «/usr/src/linux-headers-3.8.0-37-generic»
make: *** [all] Error 2

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de .doc
+1
-1
-1

¿no te sería más fácil instalando, sencillamente, el paquete firmware-realtek? Debe estar en los repositorios.

+1
-1
-1
Imagen de dani_
+1
-1
-1

Lo he probado y me devuelve que no se ha podido localizar el paquete. He instalado varios y ninguno me funciona... todos esos que he instalado como los puedo desinstalar?
He intentado
sudo su
make uninstall
make clear

pero me sale que no hay ninguna regla para contruir el objetivo <>. Alto
gracias por tu ayuda!

+1
-1
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de Gabriel_M
+1
0
-1

Descarga este archivo:
http://ftp.us.debian.org/debian/pool/non-free/f/firmware-nonfree/firmwar...
Instálalo mediante gdebi ó dpkg
Luego ejecuta:

sudo su
apt-get update
apt-get install --reinstall wireless-tools
+1
0
-1
Imagen de dani_
+1
0
-1

Tras ejecutar el .deb con el gdebi en la consola que aparece en el programa me ha aparecido esto:
(Leyendo la base de datos ... 260887 ficheros o directorios instalados actualmente.)
Desempaquetando firmware-realtek (de .../firmware-realtek_0.41_all.deb) ...
dpkg: error al procesar /home/dani/Descargas/firmware-realtek_0.41_all.deb (--install):
intentando sobreescribir `/lib/firmware/RTL8192E/main.img', que está también en el paquete linux-firmware 1.79.10
dpkg-deb (subproceso): el subproceso datos fue terminado por la señal (Tubería rota)
dpkg-deb: error: el subproceso devolvió el código de salida de error 2
Se encontraron errores al procesar:
/home/dani/Descargas/firmware-realtek_0.41_all.deb

tras introducir
apt-get update
apt-get install --reinstall wireless-tools

me sigue pasando lo mismo. Lo he intentado dos veces y a lo segundos de activar el wifi con las teclas de Fn+F12 me aparece la pantalla negra con esos comandos en blanco.
¿Que mas puedo intentar?
Un saludo y gracias por vuestra ayuda!

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de Gabriel_M
+1
0
-1

sudo su
apt-get update
apt-get install --reinstall linux-firmware linux-firmware-nonfree wireless-tools
+1
0
-1
Imagen de dani_
+1
0
-1

sigue sin funcionarme compañero... Aprieto el boton y a partir de ahí a reiniciar.
Si entro en Configuración del sistema>Red El modo avión está conectado. ¿Tendrá algo que ver? Desde ese mismo sitio, si accedo a la pestaña de inalambrica tampoco puedo conectar...
Muchas gracias de verdad!!

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de Gabriel_M
+1
0
-1

Modo avión. Esta opción desactiva las funciones inalámbricas de los dispositivos para cumplir con la normativa aérea. En caso tenerlo disponible, aparacerá un icono en la pantalla advirtiéndole que se han desactivado los servicios como el plan de datos o la voz (no podrá navegar por internet ni hacer llamadas), conexiones inalámbricas (Wi-Fi o Bluetooth) así como la incapacidad de conectar el navegador GPS.

+1
0
-1
Imagen de dani_
+1
0
-1

He quitado el modo avión, y he cerrado la ventana. Para comprobar lo he vuelto a abrir y se encontraba conectado. aún asi lo he vuelto a desconectar y sin salir de la pagina accediendo a la pestaña inalambrico y intentado activar el wifi en esa pestaña pero no me dejaba. Entonces he vuelto a apretar los btones fisicos del portatil Fn+F12 y ha vuelto a pasar lo mismo...
¿Que puedo hacer?
Un saludo y gracias!!

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de dani_
+1
0
-1

he intentado esto sin solución
sudo apt-get install linux-backports-modules-cw-3.6-precise-generic

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de dani_
+1
-1
-1

He intentado instalar un.nfo de los drivers de windows mediante NDISwrapper y sigue sin funcionar...
a partir de mañana no podré tener acceso a traves del laptop a la red cableada... no se como podré probar los paquetes :s. Habia pensado en un adaptador usb de wifi pero ...
Un saludo y gracias!

+1
-1
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de .doc
+1
0
-1

es que no creo que sea un archivo.nfo el que tengas que hacer funcionar con ndiswrapper. Más bien deberías usar un archivo.sys

+1
0
-1
Imagen de dani_
+1
-1
-1

Pues ahora mismo estoy dudando pero creo q el programa me pedia un archivo .nfo ... Posiblemente podría funcionar con ambos...
Aun así al conectar el wifi me aparece esa pantalla negra...
Muchas gracias por vuestra ayuda!!
Un saludo

+1
-1
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de dani_
+1
0
-1

Sigo intentando instalar los drivers y no soy capaz de hacerlo funcionar. He probado con otros diferentes como el rtl8192ce y algunos otros y los q no me devuelven el error que mostré mas arriba, se instalan pero no funciona. A los segundos de apretar el boton del wifi sale esa pantalla negra. ¿Que mas puedo hacer? ¿Tendré que eliminar los drivers instalados antes de instalar otros?¿interferirá esto en algo?
Un saludo y gracias

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de dani_
+1
0
-1

me sigue saliendo este error al hacerle el make al driver descargado.
make -C /lib/modules/3.8.0-38-generic/build M=/home/dani/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013 modules
make[1]: se ingresa al directorio «/usr/src/linux-headers-3.8.0-38-generic»
CC [M] /home/dani/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.o
In file included from /home/dani/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.c:39:0:
/home/dani/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/pci.h:247:15: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rtl_pci_probe’
make[2]: *** [/home/dani/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.o] Error 1
make[1]: *** [_module_/home/dani/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013] Error 2
make[1]: se sale del directorio «/usr/src/linux-headers-3.8.0-38-generic»
make: *** [all] Error 2
root@ubuntu-laptop:/home/dani/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013#

Lo que hado es entrar mediante:
cd dirección_de_la_descarga
sudo su
make

y ahí me salen los errores que os he puesto arriba...
ya he intentado todo y no soy capaz.
Por cierto, he probado de nuevo con ndiswrapper y lo que me pide es un archivo inf cuando doy a Instalar controlador nuevo.
Un saludo y gracias

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de dani_
+1
0
-1

Me he percatado que al dar en el boton de Comprobar en Actualizar Software, ademas de tardar demasiado, me devuelve este error:
W:Failed to fetch http://ppa.launchpad.net/lexical/hwe-wireless/ubuntu/dists/precise/main/source/Sources 404 Not Found
, W:Failed to fetch http://ppa.launchpad.net/lexical/hwe-wireless/ubuntu/dists/precise/main/binary-amd64/Packages 404 Not Found
, W:Failed to fetch http://ppa.launchpad.net/lexical/hwe-wireless/ubuntu/dists/precise/main/binary-i386/Packages 404 Not Found

, E:Some index files failed to download. They have been ignored, or old ones used instead.
¿Podeis explicarme que significa? Como pone wireless lo he puesto aquí ya que pienso que alomejor tiene que ver con el problema original
Un saludo y gracias a todos de verdad

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de dani_
+1
0
-1

Para resolver esto he ido a Actualizar software>Configuración>Otro sofware y he deshabilitado aquellos que me daban erroes y que empezaban por PPA.
Estos dos:
http://ppa.launchpad.net/lexical/hwe-wireless/ubuntu precise main
y
http://ppa.launchpad.net/lexical/hwe-wireless/ubuntu precise main (Codigo fuente)
He seguido lo que ponian en este hilo:
http://askubuntu.com/questions/65911/how-can-i-fix-a-404-error-when-upda...
Es correcto lo que he hecho?
Un saludo

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de dani_
+1
0
-1

Tras quitar el error que me salia en las actualizaciones me he percatado de que al dar al boton de encender el wifi ya no me aparece la pantalla negra que me salia anes y que me bloqueaba el ordenador. Tras esto he intentado instalar los drivers pero ahora, tras encender el wifi, no soy capaz de encontrar ninguna red ni nada...
Un saludo y gracias

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de cortizo
+1
0
-1

Buenas, queria comentar que tengo el mismo problema que el compañero. ahora mismo estoy con cable pero el wifi no va... me conecta, me da ip y todo pero no sale a internet. Tiene la puerta de enlace, dns y todo bien. Al bajarme los drivers de la pagina de realtek y realizar el make, mismo problema. He intentado como dice un compañero instalar el firmware-realtek con dpkg-i y me da este fallo:

error al procesar el archivo firmware-realtek_0.41_all.deb (--install):
intentando sobreescribir `/lib/firmware/RTL8192E/main.img', que está también en el paquete linux-firmware 1.127
dpkg-deb: error: el subproceso copiado fue terminado por la señal (Tubería rota)
Se encontraron errores al procesar:
firmware-realtek_0.41_all.deb

Voy sufriendo este problema desde que salio la version13.10 en todas las distribuciones de ubuntu, debian y linux mint que probé, asi que acabe instalando 12.04 y ningun problema. Comentar que antes de esto tenia linux mint 15 y tampoco tenia problemas pero al actualizar a version 16, surgió el problema. Tengo otro portatil y en ese perfecto todo.

Decir que tengo instalado ubuntu gnome 14.04 x64, en un packard bell TK85. La tarjeta wifi que lleva es la Realtek 8192SE.

Espero que me podais ayudar tanto a mi como a david para que podamos soluccionar el problema.

Saludos!

+1
0
-1
Imagen de dani_
+1
0
-1

he encontrado esto y puede que funcione, yo lo estoy intentando pero todavia nada...
Probe iniciando con un usb booteable con la version 13.04 y me por lo menos me encontraba las redes. El enlace es el sguiente:
http://www.ubuntu-es.org/node/179088#.U1O_CKZ5OPI
Un saludo y ojala que te ayude.
Por cierto, a ti tambien te salia esa una pantalla negra cuando intentabas conectar el wifi?
Un saludo

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de cortizo
+1
0
-1

no, lo de la pantalla negra no me ha pasado. Voy a ver la soluccion que has encontrado.

Saludos!

+1
0
-1
Imagen de cortizo
+1
0
-1

Hola, he echo lo que has puesto del otro post y me sigue sin fucionar..... si te funciona ya me cuentas... vaya tela con esto

+1
0
-1
Imagen de dani_
+1
0
-1

Nada a mi tampoco me ha funcionado...

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de dani_
+1
0
-1

He encontrado una posible solución, pero antes de nada voy a preguntar para no armarla. La he extrado de aquí:
http://askubuntu.com/questions/379040/wifi-drivers-for-rtl8188e-does-not...
por lo que he entendido, eliminando los linux-headers antiguos se soluciona el porblema.
Bien aqui ahora mismo no tengo ni idea, pero buscando un poco he encontrado como se sabe cuanles tengo instalados con:
sudo dpkg -l | grep linux-headers
y me devuelve esto:
ii linux-headers-3.2.0-60 3.2.0-60.91 Header files related to Linux kernel version 3.2.0
ii linux-headers-3.2.0-60-generic 3.2.0-60.91 Linux kernel headers for version 3.2.0 on 64 bit x86 SMP
ii linux-headers-3.8.0-29 3.8.0-29.42~precise1 Header files related to Linux kernel version 3.8.0
ii linux-headers-3.8.0-29-generic 3.8.0-29.42~precise1 Linux kernel headers for version 3.8.0 on 64 bit x86 SMP
ii linux-headers-3.8.0-36 3.8.0-36.52~precise1 Header files related to Linux kernel version 3.8.0
ii linux-headers-3.8.0-36-generic 3.8.0-36.52~precise1 Linux kernel headers for version 3.8.0 on 64 bit x86 SMP
ii linux-headers-3.8.0-37 3.8.0-37.53~precise1 Header files related to Linux kernel version 3.8.0
ii linux-headers-3.8.0-37-generic 3.8.0-37.53~precise1 Linux kernel headers for version 3.8.0 on 64 bit x86 SMP
ii linux-headers-3.8.0-38 3.8.0-38.56~precise1 Header files related to Linux kernel version 3.8.0
ii linux-headers-3.8.0-38-generic 3.8.0-38.56~precise1 Linux kernel headers for version 3.8.0 on 64 bit x86 SMP
ii linux-headers-generic 3.2.0.60.71 Generic Linux kernel headers
ii linux-headers-generic-lts-raring 3.8.0.38.38 Generic Linux kernel headers

Mi pregunta es, cual/es debo eliminar, es necesario dejar mas de uno por si este falla y de esta manera tire del anterior?
Un saludo y gracias

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de claudiorv
+1
0
-1

Tengo un HP Pavilion 15 nuevo y tengo la misma tarjeta y un problema parecido en Ubuntu 14.04 64 bits. Ninguna solución me ha servido, en ningún foro en español, inglés o francés. He encontrado varios ingleses que dicen que en Ubuntu 14 no funciona la tarjeta bien, y que en Ubuntu 12 va perfecta. Otros que lo único que sirve son los drivers de Ubuntu 13 en cualquier otro ubuntu, como dicen aquí: http://www.ubuntu-es.org/node/179088#.U1aXjVd53IV

Sí te digo por experiencia que lo de los linux-headers antiguos no me ha funcionado. He dejado sólo el último y no he tenido éxito. Probaré pasarme a Ubuntu 12.

+1
0
-1
Imagen de dani_
+1
0
-1

Yo he probado lo del buuntu 13.04 pero tampoco me ha funcionado, aún cuando en ese ubuntu si me funcionaba el wifi, por lo menos me detectaba redes...
Seguiremos investigando y probando hasta que suene la flauta...
Un saludo y gracias!!

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de cortizo
+1
0
-1

Bueno pues yo ya deseperado por el problema del wifi y ya que he entrado en la universidad y me hace falta el wifi si o si, he cogido, me he instalado debian 7.4 y cuando ha terminado la instalacion, le he instalado por el gestor de paquetes el firmware-realtek. Wifi funcionando perfectamente. Seguiré atento a vuestros comentarios por si dais con la solucción, cuando salga la nueva version de ubuntu, la 14.10, lo volveré a probar y si va todo bien, lo instalaré.

El problema viene desde que salio ubuntu 13.10, el wifi no me funciona, con las versiones anteriores si me iba sin problemas el wifi, lo que pasa es la antigüedad de estas versiones ya y que se quedan sin soporte...

Muchas gracias por las ayudas, Saludos!!

+1
0
-1
Imagen de claudiorv
+1
0
-1

Creo que nuestros problemas son distintos, porque a mí sí que me encuentra las redes y se conecta, solo que después funciona fatal. Ante ese problema, haciendo caso a algún usuario del foro en inglés, he puesto Ubuntu 12.04 y va de maravilla, rapidísimo. No tengo exactamente vuestro problema, así que no tenéis que tomarme como solución ideal.

Ubuntu 12.04 tiene soporte hasta abril de 2017, así que seguiré con él de momento. Más adelante volveré a probar el 14, que se entiende que lo arreglarán con el tiempo.

+1
0
-1
Imagen de dani_
+1
0
-1

que os parece esta posible solución, no tengo tiempo para probarlo ahora mismo pero os la dejo aquí
http://askubuntu.com/questions/352470/how-to-compile-realtek-8188ce-wire...
Un saludo

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb

Imagen de dani_
+1
0
-1

Bueno, realmente no se si valdrá como solución. Finalmente me decidí a cambiar la tarjeta wifi del portatil por una atheros y aleluya, sin instalar nada ya tengo internet... en fin tras mucho tiempo instalando y probando cosas al final esta es la solución. Decir que a priori la realtek funcionaba bien, ya que sobre windows no tube ningún problema. Gracias a todos por vuestra ayuda.

+1
0
-1

Laptop Toshiba Satellite C855D-16D AMD Dual Core E2-1800 Acelerated Procesor AMD Radeon tm HD 7340 RAM:4gb