Desapareció el Grub al instalar la 12.4

Imagen de Ralca
12 puntos

Al instalar (desde 11.10) Ubuntu 12.4.4 LTS, vi claramente que instalaba el Grub en sda (supongo que en el MBR), pero al reiniciar no sale el menú del Grub. Tengo varias particiones (Win XP, FAT, Ubuntu y Guadalinex) tal como indico haciendo fdisk -l :
Dispositivo Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 63 102446504 51223221 7 HPFS/NTFS/exFAT
/dev/sda2 102462570 113756264 5646847+ c W95 FAT32 (LBA)
/dev/sda3 113756265 134239139 10241437+ c W95 FAT32 (LBA)
/dev/sda4 134239201 488392064 177076432 f W95 Ext'd (LBA)
/dev/sda5 134239203 213230744 39495771 83 Linux
/dev/sda6 213230808 327742064 57255628+ 83 Linux
/dev/sda7 327742128 330955064 1606468+ 82 Linux swap / Solaris
/dev/sda8 330955128 372900779 20972826 83 Linux
/dev/sda9 372900843 488392064 57745611 83 Linux

En la terminal, he hecho: "grub-install /dev/sda" y "update-grub2" que no dan errores y que parece que detecta las particiones en "generating grub.cfg..." Sin embargo, al reiniciar no aparece el menú Grub. ¿Tendría que bajarme un SuperGrub disk o bien hay otras alternativas más sencillas. Generalmente, las instalaciones que he hecho dejan el Grub2 instalado ¿porqué esta no lo hizo? ¿qué debería hacer?
Un saludo, Ramón Alcain

Imagen de teenwood32
+1
0
-1

Intenta revisar la configuración desde un live cd de la misma estructura:

Configurar GRUB

Espero y se solucione tu problema.

Un saludo.

+1
0
-1
Imagen de Ralca
+1
0
-1

Ya he revisado /boot/grub/grub.cfg (no grub.conf) que está correcto con las distintas opciones de menú (win, Linux y Guadalinex). También lo he comprobado, con el disco Rescatux y otras opciones (como el live CD), según dice la Guia Ubuntu (ver "http://www.guia-ubuntu.com/index.php?title=Recuperar_GRUB") . Todos los indicios son que, aunque el grub.cfg se configuró correctamente, hay algo en el MBR que no funciona bien o que el grub.cfg no modifica o se salta. No sé qué puede ser, pero no es cuestión del grub.cfg. Realmente, para mí es un misterio que soy incapaz de solventar y que, evidentemente, tampoco logró la instalación del 12.04.4. El resultado es que no sale un menú de las distintas particiones y no puedo elegir donde entrar, ya que siempre entra en Ubuntu que, por otra parte, es casi lo único que utilizo.
¿Hay alguna idea de lo que puede producir el problema? Muchas gracias por las respuestas y
Saludos: Ramón Alcain

+1
0
-1
Imagen de .doc
+1
0
-1

como no sea que tienes el timeout=0..., ni idea.

+1
0
-1
Imagen de Ralca
+1
0
-1

En realidad no se debería editar el grub.cfg ya que se escribe automáticamente, pero yo lo hice con gedit sin modificar nada; el "Time out" está en 10. He visto que a pocas líneas del principio hay un "set default=0" que no sé lo que significa. Yo creo que se trata de un problema técnico del ordenador que ya es muy viejo (8 años), así que lo sustituiré por mi nuevo portátil Acer, en el que Ubuntu 12.04.4 va muy bien aunque no tanto Guadalinex. Como yo también soy muy viejo (82) estos problemas técnicos me sobrepasan pero yo no podré sustituirme con nada, salvo que reencarne.

+1
0
-1
Imagen de teenwood32
+1
0
-1

Sigue está información me ha servido de mucho:

Recuperar Grub

Un saludo.

+1
0
-1