ffmpeg en 14.04 (solucionado)

Imagen de gledof
8 puntos

Hola, como a todos los que instalaron Trusty se encontraron con que los paquetes FFMPEG no estan en los repositorios.
Lo primero que hice fue descargar el paquete .deb de ffmpeg (avconv) y al tratar de instalarlo me devolvia este error:

Dependency is not satisfiable: libavcodec53(>=6:0.8.3.1-)|libavcodec-extra-53(>=6:0.8.10)

Esas librerias tampoco figuran en los repositorios, estan en su version "libavcodec54" y "libavcodec-extra-54".
Segui buscando y lo unico que encontre es este tutorial que aclara que Trusty usa ahora "libav" en vez de ffmpeg.
Con el que se puede dar a Firefox soporte para reproducir el codec H.264 Les dejo el link de la pagina:

http://www.ubuntu-guia.com/2014/04/soporte-h264-para-firefox-en-ubuntu-1...

Imagen de Gabriel_M
+1
0
-1

Ejecuta en ella:

sudo su
add-apt-repository ppa:jon-severinsson/ffmpeg
apt-get update
apt-get install ffmpeg
+1
0
-1
Imagen de gledof
+1
-1
-1

esos mismos pasos pero con otro repositorio "$ sudo add-apt-repository ppa:samrog131/ppa" y tengo el mismo error por alguna dependencia.

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ffmpeg : Depends: libavcodec54 (>= 7:1.2.5~) but it is not going to be installed or
libavcodec-extra-54 (>= 7:1.2.5~) but 6:9.11-2ubuntu2 is to be installed
Depends: libavdevice53 (>= 7:1.2.5~) but 6:9.11-2ubuntu2 is to be installed
Depends: libavfilter3 (>= 7:1.2.5~) but 6:9.11-2ubuntu2 is to be installed
Depends: libavformat54 (>= 7:1.2.5~) but 6:9.11-2ubuntu2 is to be installed
E: Unable to correct problems, you have held broken packages.

Intente desinstalar libaccodec54 desde consola y me da error por las otras dependencias, desde Synaptic hace lo mismo.

+1
-1
-1

Saludos·

Imagen de gledof
+1
0
-1

mensaje al tratar de instalar ffmpeg. Despues de agregar los repositorios y hacer el update me aparecen los paquetes:
libav-tools libavdevice53 libavcodec54 libavformat54 y libavfilter3 como para ser actualizarlos pero no puedo hacerlo ni desde Synaptic, ni desde una consola.
Intente "sudo dpkg --configure -a" por si habia algun paquete roto pero no hay ninguna salida al ejecutar el comando aunque si por Synaptic : Could not apply changes! Fix broken packages first.
Tambien intente hacer una desinstalacion forzada y reinstalar nuevamente el paquete pero como arrastran una veintena de librerias y programas no se puede hacer y no se que mas probar.

+1
0
-1

Saludos·

Imagen de Gabriel_M
+1
0
-1

.. de aqui los paqutes:
https://launchpad.net/~jon-severinsson/+archive/ffmpeg/+packages

ffmpeg-dbg_1.2.5-1~trusty1_amd64.deb (23.1 MiB)
ffmpeg-dbg_1.2.5-1~trusty1_i386.deb (43.5 MiB)
ffmpeg-doc_1.2.5-1~trusty1_all.deb (20.8 MiB)
ffmpeg-extra-dbg_1.2.5-1~trusty1_all.deb (54.3 KiB)
ffmpeg_1.2.5-1~trusty1.debian.tar.gz (51.9 KiB)
ffmpeg_1.2.5-1~trusty1.dsc (4.4 KiB)
ffmpeg_1.2.5-1~trusty1_amd64.deb (402.2 KiB)
ffmpeg_1.2.5-1~trusty1_i386.deb (399.8 KiB)
ffmpeg_1.2.5.orig.tar.bz2 (5.7 MiB)
libav-dbg_1.2.5-1~trusty1_all.deb (54.3 KiB)
libav-doc_1.2.5-1~trusty1_all.deb (54.3 KiB)
libav-extra-dbg_1.2.5-1~trusty1_all.deb (54.3 KiB)
libav-tools_1.2.5-1~trusty1_all.deb (54.5 KiB)
libavcodec-dev_1.2.5-1~trusty1_amd64.deb (2.9 MiB)
libavcodec-dev_1.2.5-1~trusty1_i386.deb (2.8 MiB)
libavcodec-extra-54_1.2.5-1~trusty1_amd64.deb (2.6 MiB)
libavcodec-extra-54_1.2.5-1~trusty1_i386.deb (2.7 MiB)
libavcodec-extra_1.2.5-1~trusty1_all.deb (54.3 KiB)
libavcodec54_1.2.5-1~trusty1_amd64.deb (2.6 MiB)
libavcodec54_1.2.5-1~trusty1_i386.deb (2.7 MiB)
libavdevice-dev_1.2.5-1~trusty1_amd64.deb (106.6 KiB)
libavdevice-dev_1.2.5-1~trusty1_i386.deb (106.4 KiB)
libavdevice-extra-53_1.2.5-1~trusty1_all.deb (54.3 KiB)
libavdevice53_1.2.5-1~trusty1_amd64.deb (83.4 KiB)
libavdevice53_1.2.5-1~trusty1_i386.deb (84.0 KiB)
libavfilter-dev_1.2.5-1~trusty1_amd64.deb (398.9 KiB)
libavfilter-dev_1.2.5-1~trusty1_i386.deb (390.1 KiB)
libavfilter-extra-3_1.2.5-1~trusty1_all.deb (54.3 KiB)
libavfilter3_1.2.5-1~trusty1_amd64.deb (321.0 KiB)
libavfilter3_1.2.5-1~trusty1_i386.deb (326.3 KiB)
libavformat-dev_1.2.5-1~trusty1_amd64.deb (748.7 KiB)
libavformat-dev_1.2.5-1~trusty1_i386.deb (753.4 KiB)
libavformat-extra-54_1.2.5-1~trusty1_all.deb (54.3 KiB)
libavformat54_1.2.5-1~trusty1_amd64.deb (616.2 KiB)
libavformat54_1.2.5-1~trusty1_i386.deb (641.3 KiB)
libavresample-dev_1.2.5-1~trusty1_amd64.deb (116.0 KiB)
libavresample-dev_1.2.5-1~trusty1_i386.deb (116.1 KiB)
libavresample1_1.2.5-1~trusty1_amd64.deb (87.8 KiB)
libavresample1_1.2.5-1~trusty1_i386.deb (90.6 KiB)
libavutil-dev_1.2.5-1~trusty1_amd64.deb (206.6 KiB)
libavutil-dev_1.2.5-1~trusty1_i386.deb (207.4 KiB)
libavutil-extra-52_1.2.5-1~trusty1_all.deb (54.3 KiB)
libavutil52_1.2.5-1~trusty1_amd64.deb (127.3 KiB)
libavutil52_1.2.5-1~trusty1_i386.deb (136.3 KiB)
libpostproc-dev_1.2.5-1~trusty1_amd64.deb (107.6 KiB)
libpostproc-dev_1.2.5-1~trusty1_i386.deb (104.4 KiB)
libpostproc-extra-52_1.2.5-1~trusty1_all.deb (54.3 KiB)
libpostproc52_1.2.5-1~trusty1_amd64.deb (88.8 KiB)
libpostproc52_1.2.5-1~trusty1_i386.deb (86.3 KiB)
libswresample-dev_1.2.5-1~trusty1_amd64.deb (114.0 KiB)
libswresample-dev_1.2.5-1~trusty1_i386.deb (114.8 KiB)
libswresample0_1.2.5-1~trusty1_amd64.deb (85.3 KiB)
libswresample0_1.2.5-1~trusty1_i386.deb (88.9 KiB)
libswscale-dev_1.2.5-1~trusty1_amd64.deb (169.5 KiB)
libswscale-dev_1.2.5-1~trusty1_i386.deb (171.7 KiB)
libswscale-extra-2_1.2.5-1~trusty1_all.deb (54.3 KiB)
libswscale2_1.2.5-1~trusty1_amd64.deb (135.3 KiB)
libswscale2_1.2.5-1~trusty1_i386.deb (140.7 KiB)

Que correspondan a tu versión de 32 o 64 bits e instalarlos con gdebi, según demanda.

+1
0
-1
Imagen de gledof
+1
0
-1

problema. Desde la ultima entrada no me preocupe mas por ffmpeg, hace un par de dias instale Darktable (editor de fotografias) y hoy me aparecieron actualizaciones pendientes y entre ellas estaba para instalar ffmpeg, ejecute el upgrade y todo bien instalado.
Me gustaria poder decir como lo solucione o al menos lo que creo que hice, pero la verdad es que nada, despues de los intento en mi ultima entrada no hice nada mas. Igualmente gracias Gabriel por la ayuda y esto quedara para mi lista de los misterios de Linux....Se aceptan teorias.

+1
0
-1

Saludos·