Problema al intentar instalar VLC

Imagen de jorgerider
0 puntos

Buenas, estoy con un problema, y es que, hace tiempo añadí los repositorios de vlc para probar la nueva versión, la instalé y el caso es que no me gustó. Lo que hice entonces fue eliminar la aplicación usando

sudo apt-get remove --purge vlc

y se eliminó, después eliminé los repositorios de vlc para volver a instalarme la versión de los repositorios de Ubuntu, primero hice un sudo apt-get update para actualizar los repos, y luego he intentado instalar, con el siguiente problema:

jorge@ASUS:~ $ sudo apt-get install vlc
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
vlc : Depende: vlc-nox (= 2.1.5~ppa1) pero 2.2.0~~git20140409+r56317+122~ubuntu14.04.1 va a ser instalado
Recomienda: vlc-plugin-notify (= 2.1.5~ppa1) pero no va a instalarse
Recomienda: vlc-plugin-pulse (= 2.1.5~ppa1) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

¿Alguien sabe cual es el problema?

Imagen de Goyo
+1
0
-1

El problema es el que tienes vcl-nox en una versión superior a la que necesitas ahora. En tu caso creo que la solución más sencilla es:
sudo apt-get install vlc vlc-nox=2.1.5~ppa1

De todas formas esa tampoco es la versión de los repositorios oficiales, es de algún otro repositorio.

+1
0
-1
Imagen de yosebilla
+1
0
-1

Veras, cuando instalaste el vlc desde un repositorio "no oficial" en realidad instalaste unas cuantas dependencias, es decir una serie "subprogramas" por ejemplo el conector vlc con pulseaudio. Todas esas dependencias son muy estrictas, quiero decir que es necesario construirlas todas a la vez para que el programa no de fallo.

Despues desinstalaste unicamente el paquete "vlc" dejando todos los demas instalados, y ahora cuando intentas instalar el vlc de los repositorios oficiales, la version "git" encuentra que ya tiene instalado la versión "ppa" y encima que no puede instalar la versión ppa de vlc. Da fallo, y lo explica, "tienes la versión ppa de vlc-nox y yo solo puedo instalar la version git. tengo miedito y me niego a hacer lo que me has mandado"

Soluciones:
Elimina dependencia no necesarias y prueba
sudo apt-get autoremove ; sudo apt-get install vlc
No te funcionara por que primero no has eliminado los repositorios experimentales, tal como indica el hecho de que intente instalar la versión git de desarrollo y no la version 2.1.2-2build2 que es la que corresponde al ultimo lanzamiento de universe. Asi que primero listamos los ppa que podemos tener activos:
cat /etc/sources.list
ls /etc/apt/sources.list.d/

Con el segundo comando listas los ppa que recuerda tu ordenador. Y los eliminas, al menos los de vlc.
sudo add-apt-repository --remove ppa:nombre a eliminar
Luego limpias, fijas y das esplendor todo en la misma linea:
sudo apt-get clean ; sudo apt-get autoremove ; sudo apt-get update ; sudo apt-get install vlc

Otras formas de hacerlo, tal vez mas elegantes, forzar version correcta, primero vemos que versiones tiene en mente el sistema:
sudo apt-cache showpkg vlc
Te muestra versiones, y reverse depends. Luego forzamos version (uso la de trusty usa la que tu tengas si no es esa):
sudo apt-get install vlc=2.1.2-2build2 vlc-plugin-notify=2.1.2-2build2 vlc-plugin-pulse=2.1.2-2build2 vlc-nox=2.1.2-2build2 libvlccore7=2.1.2-2build2 libvlc5=2.1.2-2build2 vlc-data=2.1.2-2build2

Otra forma seria forzar la distribucion, de forma que de prefencia a la oficial (apt pinning):
sudo apt-get --target-release Trusty install vlc
Otra forma forzar version, en corto
sudo apt-get -t "2.1.2*" install vlc vlc-nox libvlc5 vlc-data libvlccore7 vlc-plugin-notify vlc-plugin-pulse
Tambien puedes a golpe de raton forzar versiones en synaptic pero me parece un toston.

Como consideración final, y esta bien avisado, instalar desde repositorios ppa versiones de pruebas es algo que tiene cierto riesgo, sobre todo si no te manejas bien con los repositorios, salvo que tengas un interes por aprender o algo muy particular no es nada conveniente andar instalando ppa. Un saludo.

+1
0
-1