No funciona ratón usb

Imagen de alberpilot
0 puntos

Hola a todos

Tengo ubuntu 14.04 recién instalada. Todo me va de manera más o menos correcta excepto que, cuando conecto un ratón USB cualquiera, la lucecita roja del ratón se enciende recién conectado y se apaga a los 2 segundos aproximadamente, dejando el ratón de funcionar. Esta es la salida de lsusb que me tira


pilot@pc:~$ lsusb
Bus 002 Device 003: ID 04f2:b19b Chicony Electronics Co., Ltd
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 002: ID 0930:020f Toshiba Corp.
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Y aquí un dmesg


dmesg | grep mouse
[ 1.012047] mousedev: PS/2 mouse device common for all mice
[ 17.336506] psmouse serio4: synaptics: Touchpad model: 1, fw: 7.2, id: 0x1c0b1, caps: 0xd04773/0xa40000/0xa0000, board id: 3655, fw id: 590211

¿Alguna idea?

Gracias, un saludo

PD: Toshiba Satellite t130-132

Imagen de Marcelinator
+1
0
-1

Tengo un MMO7 de Mad Catz y sucede algo parecido.
Aunque encontré un archivo para configurarlo, en la misma respuesta indicaba que "reiniciando" las X, se restablecía el ratón.
Así que, cuando arranco y se me para el ratón, siimplemente pulso Ctrl+Alt+F1 (para irme a una consola de texto) y vuelvo a las X con Ctrl+Alt+F7
¡ Y ya no se vuelve a ir el ratón !
Puedes probar y comentarnos.

+1
0
-1

¿Me ayudas a entenderlo, por favor?

Imagen de doctorPOISON
+1
+1
-1

Hola, tengo Ubuntu Studio 14.04 y me pasaba lo mismo, en mi caso instalé laptop_mode_tools porque se me calentaba mucho, y al parecer este programita por defecto desactiva todos los dispositivos usb cuando se está funcionando con baterías. Desconozco si laptop_mode_tools viene ya con ubuntu 14.04 o si lo tienes instalado, pero por si acaso mira a ver si fuese eso.
Paso a paso, extraído de http://blog.desdelinux.net/como-configurar-laptop-mode-tools/

Cómo evitar que el mouse entre en modo de suspensión

Por defecto, laptop-mode-tools viene configurado de tal forma que todos los dispositivos USB entran en modo de suspensión al desconectar la laptop de la corriente.

Esto significa que cuando dejes de usar el mouse por unos segundos y quieras volver a utilizarlo probablemente tarde un rato en responder. Incluso es posible que no puedas “reavivarlo”.

Para evitar este comportamiento, basta con editar un archivo de configuración. Antes que nada, necesitamos saber el ID del mouse. Para ello, desconectalo y volvelo a conectar. Luego, abrí un terminal y escribí:

dmesg

Al final de todo debería aparecer una línea similar a la siguiente:

[13634.540582] hid-generic 0003:046D:C052.0005: input,hidraw0: USB HID v1.10 Mouse [Logitech USB Laser Mouse] on usb-0000:00:1a.0-1.2/input0

En este caso, el IDE del mouse es: 046D:C052

Ahora, sólo basta editar el archivo de configuración de laptop-mode-tools que controla la autosuspensión de dispositivos USB:

sudo nano /etc/laptop-mode/conf.d/usb-autosuspend.conf

Buscá la línea que dice AUTOSUSPEND_USBID_BLACKLIST y agregá el ID del mouse. Siguiendo nuestro ejemplo, debería quedar así:

AUTOSUSPEND_USBID_BLACKLIST="046D:C052"

Créditos: blog.desdelinux.net

+1
+1
-1
Imagen de maestrobanana
+1
+1
-1

Muchas gracias por la respuesta al hilo. En mi caso ese mismo era el problema.

+1
+1
-1