no tengo entorno grafico

Imagen de almirantenel
0 puntos

Hola:
Después de una actualización la pantalla se me quedo en 3/4 aprox y el monitor me decía desconocido. por lo que trate instalar un driver para mi gráfica (intel PowerVR ) desde los repositorios con lo que al reiniciar el sistema no me funcionaba el entorno grafico he borrado, reinstalado y reconfigurado el xserver-xorg en varias ocasiones pero nada cuando doy starx o X me da fatal error no screen found
perdonen la redacción y la sintaxis pero estoy escribiendo desde el movil

Imagen de almirantenel
+1
0
-1

Mi placa base es una ASROCK AD2550B-ITX
con un procesador Atom D2550 integrado
la grafica integrada Intel PowerVR SGX545
todo esto me fucionaba bien con Ubuntu 12.04 LTS con Kernel 3.8 hasta que despues de una actualizacion me quede sin entorno grafico adjunto imagen del error:

[inline:IMG_20140624_162315.jpg]
despues de eso instale el kernel 3.2 con el que tengo entorno grafico aunque con baja resolucion
despues instale el kernel 3.13 y el error fue similar y sin entorno grafico.
en la instalacion me dio los siguientes errores.:
update-initramfs: Generating /boot/initrd.img-3.13.0-031300-generic
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169

desintale este he instale el 3.8 con resultado identico, errores:

update-initramfs: Generating /boot/initrd.img-3.8.2-030802-generic
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.8.2-030802-generic /boot/vmlinuz-3.8.2-030802-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.8.2-030802-generic /boot/vmlinuz-3.8.2-030802-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.8.2-030802-generic /boot/vmlinuz-3.8.2-030802-generic
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.8.2-030802-generic
Found initrd image: /boot/initrd.img-3.8.2-030802-generic
Found linux image: /boot/vmlinuz-3.2.0-64-generic
Found initrd image: /boot/initrd.img-3.2.0-64-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Microsoft Windows XP Home Edition on /dev/sda1
done
Configurando linux-image-extra-3.8.2-030802-generic (3.8.2-030802.201303031906) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.8.2-030802-generic /boot/vmlinuz-3.8.2-030802-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.8.2-030802-generic /boot/vmlinuz-3.8.2-030802-generic
update-initramfs: Generating /boot/initrd.img-3.8.2-030802-generic
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.8.2-030802-generic /boot/vmlinuz-3.8.2-030802-generic

desintale el kernel 3.8 he instale el 3.15 con el mismo resultado errores:
update-initramfs: Generating /boot/initrd.img-3.15.0-031500-generic
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.15.0-031500-generic /boot/vmlinuz-3.15.0-031500-generic
como ven el error es similar en todos los kernel .

Espero haber sido lo bastante explicito en el problema si alguien puede ayudarme lo agradeceria.

+1
0
-1
Imagen de Goyo
+1
0
-1

Parece que puede haber un problema con el firmware del adaptador inalámbrico pero no se me ocurre qué relación puede tener con el problema del título, si es que la tiene.

+1
0
-1
Imagen de almirantenel
+1
0
-1

El primer entorno grafico lo perdí al instalar la biblio ia32-libs porque no funcionaba el emulador del SDK android en eclipse.(olvide decir que estoy con la version amd64).
¿Crees que ese sea el problema ?
¿con instalar el refit o el elilo, se soluciona?

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

depende de que otros paquetes importantes desinstalaste por instalar ia32libs, no tengo conocimiento de refit ni elilo, pero si no son drivers o el servidor gráfico entonces no se va a solucionar instalando esos programas.

por ahí en /var/log hay un historial de que paquetes instalas... tal vez ahí puedas encontrar una pista de tu problema...

En fin mientras vives sin interfaz gráfica... puedes usar estos programas:

- dvtm (te permite tener varias terminales en una sola pantalla, lee el manual).
- w3m (excelente navegador web en modo texto, lee el manual, B es para ir a la página anterior, no esta muy explícito en el manual).
- finch (cliente de IM multiprotocolo, si tienes facebook, puedes conectarte al chat)
- moc (music on console, hay más reproductores en texto, pero uso más ese)
- emacs o vim (editores de texto, ambos muy útiles y te permiten hacer muchas cosas, lee el manual y practica)
-fbi (te permite ver imágenes desde la terminal, debes abrirlo como root, o configurar los permisos de /dev/fb0)
-man (el manual, ejemplo: man emacs)
- info (otro manual, ejemplo: info emacs)
- nano (humilde editor de texto, te puede sacar del apuro, de forma simple y no tan exhaustiva como emacs o vim)

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de VitaliyK
+1
-1
-1

Deberias probar a usar xdiagnose que viene preinstalado en ubuntu. Sirve para controlar los graficos.

+1
-1
-1
Imagen de almirantenel
+1
0
-1

De momento estoy usando el kernal 3.2 que no me da problemas graves . No se porque con kernels superiores me da problemas con fedora no me pasa . Gracias por las respuestas .
Saludos.

+1
0
-1
Imagen de Alcruz
+1
0
-1

Es un clásico de las integradas Intel, en general las distros soportan estas integradas si son contenporáneas o sea si la gráfica y la versión de la distro son de la misma época, pero cuando pasa el tiempo las distros dejan de soportarlas, esto me pasó en dos oprtunidades y la única solución que encontré fue ponerle una gráfica PCI Nvidia , por suerte no son caras y es la solución definitiva a futuro.
La verdad es que no se entiende esta falta de soporte sabiendo que los controladore Intel son llibres, pero claro, la prioridad la tienen los gamers y las Intel no son para jugar, sino para trabajar.

+1
0
-1
Imagen de almirantenel
+1
0
-1

no puedo poner una grafica pci. Porque mi motherboard es una mini itx con un solo puerto PCI que lo uso para el WiFi. Además me parece que la 12.04 lts es bastante actual no creo que ese sea el problema.

+1
0
-1