[Solucionado] Problem with MargeList - Spotify

Imagen de RafaGuitar
0 puntos

Hola a todos:

Os cuento un problema que me ha surgido de pronto al actualizar los repositorios con 'sudo apt-get update'.

Al final me sale un error con MergeList, os vuelco lo que me sale en la terminal:

Ign http://es.archive.ubuntu.com trusty InRelease
Ign http://security.ubuntu.com trusty-security InRelease
Ign http://dl.google.com stable InRelease
Ign http://extras.ubuntu.com trusty InRelease
Obj http://deb.playonlinux.com trusty InRelease
Ign http://archive.canonical.com trusty InRelease
Des:1 http://repository.spotify.com stable InRelease [2.980 B]
Ign http://ppa.launchpad.net trusty InRelease
Ign http://es.archive.ubuntu.com trusty-updates InRelease
Des:2 http://security.ubuntu.com trusty-security Release.gpg [933 B]
Ign http://dl.google.com stable InRelease
Obj http://extras.ubuntu.com trusty Release.gpg
Ign http://ppa.launchpad.net trusty InRelease
Obj http://archive.canonical.com trusty Release.gpg
Obj http://deb.playonlinux.com trusty/main amd64 Packages
Ign http://es.archive.ubuntu.com trusty-backports InRelease
Des:3 http://repository.spotify.com stable/non-free amd64 Packages [944 B]
Des:4 http://security.ubuntu.com trusty-security Release [58,5 kB]
Obj http://extras.ubuntu.com trusty Release
Obj http://dl.google.com stable Release.gpg
Obj http://deb.playonlinux.com trusty/main i386 Packages
Ign http://ppa.launchpad.net trusty InRelease
Obj http://archive.canonical.com trusty Release
Obj http://es.archive.ubuntu.com trusty Release.gpg
Obj http://dl.google.com stable Release.gpg
Des:5 http://repository.spotify.com stable/non-free i386 Packages [943 B]
Obj http://extras.ubuntu.com trusty/main Sources
Ign http://ppa.launchpad.net trusty InRelease
Des:6 http://es.archive.ubuntu.com trusty-updates Release.gpg [933 B]
Obj http://archive.canonical.com trusty/partner amd64 Packages
Des:7 http://es.archive.ubuntu.com trusty-backports Release.gpg [933 B]
Obj http://archive.canonical.com trusty/partner i386 Packages
Obj http://extras.ubuntu.com trusty/main amd64 Packages
Ign http://ppa.launchpad.net trusty InRelease
Obj http://dl.google.com stable Release
Obj http://extras.ubuntu.com trusty/main i386 Packages
Obj http://es.archive.ubuntu.com trusty Release
Ign http://ppa.launchpad.net trusty InRelease
Ign http://linux.dropbox.com trusty InRelease
Obj http://dl.google.com stable Release
Des:8 http://security.ubuntu.com trusty-security/main Sources [30,6 kB]
Des:9 http://es.archive.ubuntu.com trusty-updates Release [58,5 kB]
Ign http://ppa.launchpad.net trusty InRelease
Obj http://dl.google.com stable/main amd64 Packages
Des:10 http://security.ubuntu.com trusty-security/restricted Sources [14 B]
Ign http://ppa.launchpad.net trusty InRelease
Obj http://dl.google.com stable/main i386 Packages
Des:11 http://security.ubuntu.com trusty-security/universe Sources [6.808 B]
Ign http://ppa.launchpad.net trusty InRelease
Obj http://linux.dropbox.com trusty Release.gpg
Des:12 http://es.archive.ubuntu.com trusty-backports Release [58,6 kB]
Des:13 http://security.ubuntu.com trusty-security/multiverse Sources [688 B]
Obj http://ppa.launchpad.net trusty Release.gpg
Des:14 http://security.ubuntu.com trusty-security/main amd64 Packages [105 kB]
Obj http://ppa.launchpad.net trusty Release.gpg
Obj http://es.archive.ubuntu.com trusty/main Sources
Obj http://dl.google.com stable/main amd64 Packages
Obj http://ppa.launchpad.net trusty Release.gpg
Obj http://linux.dropbox.com trusty Release
Obj http://es.archive.ubuntu.com trusty/restricted Sources
Obj http://ppa.launchpad.net trusty Release.gpg
Obj http://dl.google.com stable/main i386 Packages
Obj http://es.archive.ubuntu.com trusty/universe Sources
Obj http://ppa.launchpad.net trusty Release.gpg
Obj http://es.archive.ubuntu.com trusty/multiverse Sources
Des:15 http://security.ubuntu.com trusty-security/restricted amd64 Packages [14 B]
Obj http://ppa.launchpad.net trusty Release.gpg
Obj http://es.archive.ubuntu.com trusty/main amd64 Packages
Des:16 http://security.ubuntu.com trusty-security/universe amd64 Packages [35,9 kB]
Obj http://ppa.launchpad.net trusty Release.gpg
Des:17 http://repository.spotify.com stable/non-free Translation-es_ES
Des:18 http://repository.spotify.com stable/non-free Translation-es_ES
Ign http://deb.playonlinux.com trusty/main Translation-es_ES
Obj http://es.archive.ubuntu.com trusty/restricted amd64 Packages
Obj http://linux.dropbox.com trusty/main amd64 Packages
Des:19 http://security.ubuntu.com trusty-security/multiverse amd64 Packages [1.157 B]
Des:20 http://repository.spotify.com stable/non-free Translation-es_ES
Des:21 http://repository.spotify.com stable/non-free Translation-es_ES
Des:22 http://repository.spotify.com stable/non-free Translation-es_ES
Obj http://ppa.launchpad.net trusty Release.gpg
Ign http://deb.playonlinux.com trusty/main Translation-es
Obj http://es.archive.ubuntu.com trusty/universe amd64 Packages
Des:23 http://security.ubuntu.com trusty-security/main i386 Packages [102 kB]
Ign http://extras.ubuntu.com trusty/main Translation-es_ES
Des:24 http://repository.spotify.com stable/non-free Translation-es_ES
Des:25 http://repository.spotify.com stable/non-free Translation-es_ES
Des:26 http://repository.spotify.com stable/non-free Translation-es_ES
Ign http://archive.canonical.com trusty/partner Translation-es_ES
Obj http://ppa.launchpad.net trusty Release.gpg
Obj http://es.archive.ubuntu.com trusty/multiverse amd64 Packages
Ign http://deb.playonlinux.com trusty/main Translation-en
Ign http://extras.ubuntu.com trusty/main Translation-es
Obj http://es.archive.ubuntu.com trusty/main i386 Packages
Ign http://archive.canonical.com trusty/partner Translation-es
Obj http://ppa.launchpad.net trusty Release
Obj http://linux.dropbox.com trusty/main i386 Packages
Obj http://es.archive.ubuntu.com trusty/restricted i386 Packages
Ign http://archive.canonical.com trusty/partner Translation-en
Ign http://extras.ubuntu.com trusty/main Translation-en
Obj http://ppa.launchpad.net trusty Release
Des:27 http://security.ubuntu.com trusty-security/restricted i386 Packages [14 B]
Des:28 http://security.ubuntu.com trusty-security/universe i386 Packages [35,9 kB]
Obj http://es.archive.ubuntu.com trusty/universe i386 Packages
Obj http://ppa.launchpad.net trusty Release
Des:29 http://security.ubuntu.com trusty-security/multiverse i386 Packages [1.392 B]
Obj http://es.archive.ubuntu.com trusty/multiverse i386 Packages
Obj http://ppa.launchpad.net trusty Release
Obj http://ppa.launchpad.net trusty Release
Obj http://security.ubuntu.com trusty-security/main Translation-en
Obj http://es.archive.ubuntu.com trusty/main Translation-es
Obj http://ppa.launchpad.net trusty Release
Obj http://es.archive.ubuntu.com trusty/main Translation-en
Obj http://ppa.launchpad.net trusty Release
Obj http://ppa.launchpad.net trusty Release
Obj http://es.archive.ubuntu.com trusty/multiverse Translation-es
Obj http://ppa.launchpad.net trusty Release
Obj http://es.archive.ubuntu.com trusty/multiverse Translation-en
Obj http://ppa.launchpad.net trusty/main amd64 Packages
Obj http://security.ubuntu.com trusty-security/multiverse Translation-en
Obj http://ppa.launchpad.net trusty/main i386 Packages
Obj http://es.archive.ubuntu.com trusty/restricted Translation-es
Obj http://es.archive.ubuntu.com trusty/restricted Translation-en
Obj http://security.ubuntu.com trusty-security/restricted Translation-en
Obj http://es.archive.ubuntu.com trusty/universe Translation-es
Obj http://ppa.launchpad.net trusty/main amd64 Packages
Obj http://es.archive.ubuntu.com trusty/universe Translation-en
Obj http://ppa.launchpad.net trusty/main i386 Packages
Obj http://security.ubuntu.com trusty-security/universe Translation-en
Des:30 http://es.archive.ubuntu.com trusty-updates/main Sources [80,4 kB]
Ign http://dl.google.com stable/main Translation-es_ES
Des:31 http://es.archive.ubuntu.com trusty-updates/restricted Sources [14 B]
Ign http://dl.google.com stable/main Translation-es
Obj http://ppa.launchpad.net trusty/main amd64 Packages
Des:32 http://es.archive.ubuntu.com trusty-updates/universe Sources [60,1 kB]
Ign http://dl.google.com stable/main Translation-en
Obj http://ppa.launchpad.net trusty/main i386 Packages
Ign http://dl.google.com stable/main Translation-es_ES
Des:33 http://es.archive.ubuntu.com trusty-updates/multiverse Sources [2.681 B]
Ign http://dl.google.com stable/main Translation-es
Des:34 http://es.archive.ubuntu.com trusty-updates/main amd64 Packages [214 kB]
Ign http://dl.google.com stable/main Translation-en
Obj http://ppa.launchpad.net trusty/main amd64 Packages
Obj http://ppa.launchpad.net trusty/main i386 Packages
Obj http://ppa.launchpad.net trusty/main amd64 Packages
Des:35 http://es.archive.ubuntu.com trusty-updates/restricted amd64 Packages [14 B]
Obj http://ppa.launchpad.net trusty/main i386 Packages
Des:36 http://es.archive.ubuntu.com trusty-updates/universe amd64 Packages [154 kB]
Des:37 http://es.archive.ubuntu.com trusty-updates/multiverse amd64 Packages [7.397 B]
Obj http://ppa.launchpad.net trusty/main amd64 Packages
Obj http://ppa.launchpad.net trusty/main i386 Packages
Des:38 http://es.archive.ubuntu.com trusty-updates/main i386 Packages [210 kB]
Obj http://ppa.launchpad.net trusty/main amd64 Packages
Ign http://security.ubuntu.com trusty-security/main Translation-es_ES
Des:39 http://es.archive.ubuntu.com trusty-updates/restricted i386 Packages [14 B]
Obj http://ppa.launchpad.net trusty/main i386 Packages
Ign http://security.ubuntu.com trusty-security/main Translation-es
Des:40 http://es.archive.ubuntu.com trusty-updates/universe i386 Packages [154 kB]
Ign http://security.ubuntu.com trusty-security/multiverse Translation-es_ES
Ign http://security.ubuntu.com trusty-security/multiverse Translation-es
Ign http://security.ubuntu.com trusty-security/restricted Translation-es_ES
Ign http://security.ubuntu.com trusty-security/restricted Translation-es
Ign http://linux.dropbox.com trusty/main Translation-es_ES
Ign http://security.ubuntu.com trusty-security/universe Translation-es_ES
Obj http://ppa.launchpad.net trusty/main amd64 Packages
Des:41 http://es.archive.ubuntu.com trusty-updates/multiverse i386 Packages [7.569 B]
Ign http://security.ubuntu.com trusty-security/universe Translation-es
Obj http://ppa.launchpad.net trusty/main i386 Packages
Ign http://linux.dropbox.com trusty/main Translation-es
Obj http://es.archive.ubuntu.com trusty-updates/main Translation-en
Obj http://ppa.launchpad.net trusty/main amd64 Packages
Obj http://ppa.launchpad.net trusty/main i386 Packages
Obj http://es.archive.ubuntu.com trusty-updates/multiverse Translation-en
Ign http://linux.dropbox.com trusty/main Translation-en
Obj http://es.archive.ubuntu.com trusty-updates/restricted Translation-en
Obj http://es.archive.ubuntu.com trusty-updates/universe Translation-en
Des:42 http://es.archive.ubuntu.com trusty-backports/main Sources [14 B]
Des:43 http://es.archive.ubuntu.com trusty-backports/restricted Sources [14 B]
Des:44 http://es.archive.ubuntu.com trusty-backports/universe Sources [7.265 B]
Des:45 http://es.archive.ubuntu.com trusty-backports/multiverse Sources [768 B]
Des:46 http://es.archive.ubuntu.com trusty-backports/main amd64 Packages [14 B]
Des:47 http://es.archive.ubuntu.com trusty-backports/restricted amd64 Packages [14 B]
Des:48 http://es.archive.ubuntu.com trusty-backports/universe amd64 Packages [8.141 B]
Des:49 http://es.archive.ubuntu.com trusty-backports/multiverse amd64 Packages [619 B]
Des:50 http://es.archive.ubuntu.com trusty-backports/main i386 Packages [14 B]
Des:51 http://es.archive.ubuntu.com trusty-backports/restricted i386 Packages [14 B]
Des:52 http://es.archive.ubuntu.com trusty-backports/universe i386 Packages [8.157 B]
Des:53 http://es.archive.ubuntu.com trusty-backports/multiverse i386 Packages [619 B]
Obj http://es.archive.ubuntu.com trusty-backports/main Translation-en
Obj http://es.archive.ubuntu.com trusty-backports/multiverse Translation-en
Obj http://es.archive.ubuntu.com trusty-backports/restricted Translation-en
Obj http://es.archive.ubuntu.com trusty-backports/universe Translation-en
Ign http://es.archive.ubuntu.com trusty/main Translation-es_ES
Ign http://ppa.launchpad.net trusty/main Translation-es_ES
Ign http://es.archive.ubuntu.com trusty/multiverse Translation-es_ES
Ign http://es.archive.ubuntu.com trusty/restricted Translation-es_ES
Ign http://ppa.launchpad.net trusty/main Translation-es
Ign http://es.archive.ubuntu.com trusty/universe Translation-es_ES
Ign http://ppa.launchpad.net trusty/main Translation-en
Ign http://ppa.launchpad.net trusty/main Translation-es_ES
Ign http://es.archive.ubuntu.com trusty-updates/main Translation-es_ES
Ign http://ppa.launchpad.net trusty/main Translation-es
Ign http://es.archive.ubuntu.com trusty-updates/main Translation-es
Ign http://ppa.launchpad.net trusty/main Translation-en
Ign http://es.archive.ubuntu.com trusty-updates/multiverse Translation-es_ES
Ign http://ppa.launchpad.net trusty/main Translation-es_ES
Ign http://es.archive.ubuntu.com trusty-updates/multiverse Translation-es
Ign http://ppa.launchpad.net trusty/main Translation-es
Ign http://es.archive.ubuntu.com trusty-updates/restricted Translation-es_ES
Ign http://ppa.launchpad.net trusty/main Translation-en
Ign http://es.archive.ubuntu.com trusty-updates/restricted Translation-es
Ign http://ppa.launchpad.net trusty/main Translation-es_ES
Ign http://es.archive.ubuntu.com trusty-updates/universe Translation-es_ES
Ign http://es.archive.ubuntu.com trusty-updates/universe Translation-es
Ign http://ppa.launchpad.net trusty/main Translation-es
Ign http://es.archive.ubuntu.com trusty-backports/main Translation-es_ES
Ign http://es.archive.ubuntu.com trusty-backports/main Translation-es
Ign http://es.archive.ubuntu.com trusty-backports/multiverse Translation-es_ES
Ign http://ppa.launchpad.net trusty/main Translation-en
Ign http://es.archive.ubuntu.com trusty-backports/multiverse Translation-es
Ign http://ppa.launchpad.net trusty/main Translation-es_ES
Ign http://es.archive.ubuntu.com trusty-backports/restricted Translation-es_ES
Ign http://es.archive.ubuntu.com trusty-backports/restricted Translation-es
Ign http://es.archive.ubuntu.com trusty-backports/universe Translation-es_ES
Ign http://ppa.launchpad.net trusty/main Translation-es
Ign http://es.archive.ubuntu.com trusty-backports/universe Translation-es
Ign http://ppa.launchpad.net trusty/main Translation-en
Ign http://ppa.launchpad.net trusty/main Translation-es_ES
Ign http://ppa.launchpad.net trusty/main Translation-es
Ign http://ppa.launchpad.net trusty/main Translation-en
Ign http://ppa.launchpad.net trusty/main Translation-es_ES
Ign http://ppa.launchpad.net trusty/main Translation-es
Ign http://ppa.launchpad.net trusty/main Translation-en
Ign http://ppa.launchpad.net trusty/main Translation-es_ES
Ign http://ppa.launchpad.net trusty/main Translation-es
Ign http://ppa.launchpad.net trusty/main Translation-en
Ign http://ppa.launchpad.net trusty/main Translation-es_ES
Ign http://ppa.launchpad.net trusty/main Translation-es
Ign http://ppa.launchpad.net trusty/main Translation-en
Descargados 1.469 kB en 12seg. (115 kB/s)
Leyendo lista de paquetes... ¡Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/repository.spotify.com_dists_stable_non-free_i18n_Translation-es%5fES
E: No se pudieron analizar o abrir las listas de paquetes o el archivo de estado.

He estado leyendo por internet pero no he encontrado alguna solución para este problema. He llegado a acceder a la carpeta /var/lib/apt/lists/ y borrar todo el contenido para volver a actualizar y descargar todos los paquetes de nuevo pero sigue saliendo el problema. He borrado el programa Spotify (tenía instalada la versión para Linux y con la cual funcionaba bastante bien y durante bastante tiempo), pero la única forma que he tenido de que no me aparezca dicho error es borrando del archivo 'source.list' la línea correspondiendo al Spotify (aunque ya sé que con esto no hago nada), pero en fin.

Espero que podáis ayudarme y muchas gracias de antemano

PD: si sirve de ayuda, cuando me sale este error ni siquiera puedo acceder al Centro de software de Ubuntu. Entra pero me cierra la ventana sola.

Imagen de Gabriel_M
+1
0
-1

.... la única forma que he tenido de que no me aparezca dicho error es borrando del archivo 'source.list' la línea correspondiendo al Spotify (aunque ya sé que con esto no hago nada),...

Justamente, si haces algo:¡eliminas el link que da el error! Esa es la solución.
¿Para qué tienes habilitados los repositorios de sources?

+1
0
-1
Imagen de RafaGuitar
+1
0
-1

Ya, hombre. No sé, simplemente lo quité porque me aparecía el error. Pero claro, si lo quito, ¿cómo instalo el Spotify? Supongo que habrá que dejarlo por si actualizan el programa, etc, etc.

Los pasos que pone la página para instalarlo son estos:

# 1. Añade esta línea a tu lista de repositorios
# editando /etc/apt/sources.list
deb http://repository.spotify.com stable non-free

# 2. Si quieres comprobar los paquetes descargados,
# tendrás que añadir nuestra clave pública
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 94558F59

# 3. Ejecuta apt-get update
sudo apt-get update

# 4. Instala Spotify
sudo apt-get install spotify-client

El enlace del punto uno es el que tengo que quitar para que no me aparezca el error, pero, si no lo pongo, ¿cómo lo instalo?

+1
0
-1
Imagen de .doc
+1
0
-1

me parece que ese repositorio que dices es de Debian, no de Ubuntu. No se yo si te servirá y, en cualquier caso, no es nada recomendable mezclar repos de varias distros... si no son plemamente compatibles.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

... de la aplicación expresan:

Spotify para Linux
Aquí, los proyectos no están respaldados por Spotify, por lo que es posible que no funcionen como se tenía planeado o que sean retirados en cualquier momento, pero si te gusta lo que estamos haciendo, avísanos y si resultan ser lo suficientemente populares es posible que se conviertan en funciones permanentes de Spotify.
Éste es un avance de Spotify para Linux. Como un lanzamiento previo, esta versión aún no está soportada, pero la estamos ejecutando nosotros mismos e intentaremos asegurarnos de que mantenga el paso para Mac y Windows.
Así que ¿cómo la obtienes? La hemos empacado para Debian Squeeze/Ubuntu.

Parece lógico que tratándose de un paquete de estas características tenga problemas con el sistema operativo.

+1
0
-1
Imagen de RafaGuitar
+1
0
-1

Bueno, muchas gracias por todo, creo que con estos comentarios me está todo un poco más claro (teniendo en cuenta que soy relativamente nuevo en el mundo ubuntu.

No obstante, he estado investigando por internet y he conseguido dar con un artículo que explica como instalar spotify en ubuntu 14.04 y de esta forma parece que el error ha dejado de producirse en mi equipo (para los que aún tenga la "cabezonería" de instalarlo).

http://www.atareao.es/ubuntu/instalar-spotify-en-ubuntu-trusty-tahr/

Así que de nuevo, muchas gracias por los comentarios, y creo que, por mi parte podría dar el tema por solucionado. ;-)

+1
0
-1