XGL/Compiz con tarjeta de video intel 915

+1
0
-1

Después de varias pruebas por fin tengo XGL estable en mi máquina, un ACER travelmate 4101 wmli, he tenido que cambiar algunas cosas de las instrucciones que dan en el wiki de ubuntu.

Lo primero deciros que el rendimiento no es malo, es más diría que es prometedor los bien que se mueve en casi todas las situaciones.

El primer cambio es que en el fichero xorg.conf te dicen que desactives el dri y el GLcore, a mi me funciona solo si comento GLcore, no hay que comentar la linea de dri, quedaría de esta forma:

Load "dri"
# Load "GLcore"

Otra corrección es que tiene que estar activada la extensión composite, añadiendo esta al fichero xorg.conf:

Section "Extensions"
Option "Composite" "Enable"
EndSection

El último paso es no activar todos los plugins, hay plugins dejan el compiz helado, a mi el plugin miniwin en concreto, tengo activos casi todos menos ese, lo que teneis que hacer es en la línea con la que ejecutáis el compiz en principio activar solo unos pocos: move, resize, cube ;), place, gconf, por ejemplo, os bajáis de synaptic gset-compiz y vais problando la configuración que mejor os venga.

Esto me funciona en mi equipo, no se si a alguien mas le puede ayudar.

salu2

Comentarios

Imagen de Anónimo

Yo tengo Ubnutu Dapper segui todos los pasos de esa guia pero corre super lento me imagino no se activo la aceleracion de la tarjeta, por favor POR FAVOR puedes poner los pasos de como lo lograste y convertirte en mi héroe :P gracias

Imagen de Anónimo

es que no me deja escribir comentarios logeado, me dice que captcha invalido ¿?

primero, siguiendo estos pasos consegui correo XORG/compiz no XGL, sorry pero no he tenido tiempo de actualizar.

segundo, ahora si tengo XGL/compiz y la verdad es que va mejor...

Y ahora la explicación: para correr xgl yo segui varias guias que indicaban que para hacer el cambio efectivo tenias que modificar el fichero /etc/gdm/gdm.conf, bueno pues el primer fiazco, mi fichero de configuración es el etc/gdm/gdm-cdd.conf, asi que cuando lo configure lo que consegui fue tener compiz sobre xorg. La verdad es que no iba mal, ahora ya hice lo s cambios correctos en gdm y si tengo XGL/Compiz lo único que tienes que desactivar del xorg.conf es la extensión composite que XGL ya la trae incluida. Ahora no tengo tiempo pero pondre los cambios concretos que tengo en lo ficheros.

salu2

Imagen de Anónimo

te juro q me duele la cabeza de tanto estar frente al ordenador y no tener listo xgl/compiz :( ayudame please!!! Tnx

Imagen de Anónimo

Hola. Yo tengo los mismos problemas, pero cual fue mi sorpresa que pose un livecd del "korora xgl livecd" y me funciona a la perfección. Os recomiendo a los que tengais nome que arranqueis este livecd y mireis la configuración.

Yo tengo kubunto 6.0 y me lo tendre que currar de otra manera.

Nota: an quitado el link de la web oficial para descargarse el livecd, pero hay un link torrent por ahi que si funciona.

Un saludo

Imagen de Anónimo

Hola a todos,

Yo he instalado el XGL/Compiz en mi portatil con tarjeta gráfica Intel 855 y me va super lento.

Lo he instalado siguiendo el método A de esta página
https://help.ubuntu.com/community/CompositeManager/Xgl

En una sesión GNome normal (con Xorg) escribo: glxinfo | grep rendering
y me responde: direct rendering: Yes (por lo que la aceleración gráfica está activada)

Pero cuando entro en una sesión Xorg+XGL esa misma orden me revuelve: direct rendering: No, lo que indica que el XGL no arranca con la aceleración activada.

Tal y como indica arraclan, dejo activo el módulo "dri", sino no furula nada.

¿Alguna idea?

Spinetto.

Imagen de arraclan

al final me he decidido por esto, xgl esta bien pero el error del firefox que va lento tela era demasiado para mi, encontre por casualidad un post de como instalar aiglx + compiz, y para mi va mejor con la intel que xgl. Aqui os dejo el link del post: http://www.ubuntuforums.org/showthread.php?t=145068

--
arraclan(@)gmail.com
"I'm not anti-social; I'm just not user friendly"
Arraclan, registered Linux user #378069, Ubuntu User #1422

Imagen de khepa

recuerdo haber tenido direct rendering en breezy con la tarjeta intel 915, cambie a dapper pero no logro recordar como active la aceleración. Alguien con direct rendering que me pase su xorg?

khépani

Imagen de santidp

buenas..

fui a instalar Xgl guiandome por lo q dice en esta página
https://help.ubuntu.com/community/CompositeManager/Xgl

como no tenia los drivers con aceleracion 3D instalados fui a https://help.ubuntu.com/ubuntu/desktopguide/C/hardware.html e instalé Xorg como dice allí

luego lo fui a configurar ( sudo dpkg-reconfigure xserver-xorg ) pero se ve que hice algo mal, porque cuando reinicié no me levanta el entorno grafico.. me tira un error, me dice que lo tengo que configurar y me entra solo en modo de texto..

tengo una mother Intel D915 GEV y uso la tarjeta de video on board de esta mother..

si alguien sabe como configurar Xorg o que puedo hacer para que me entre al entorno grafico que me ayude por favor.. no quiero tener que formatear

gracias de antemano.. saludos