Otra solución al Comtrend 351 de Telefónica para DAPPER

Imagen de feten7
0 puntos

Instalar el módem Comtrend 351 en Ubuntu Dapper:

Bueno, os hago partícipes de mi trabajo durante bastantes días, de pruebas con el ueagle-atm, que mis conocimientos no me permitieron configurar, y de muchas otras probatinas con el connexion echouée de resultado que me lo he aprendido de memoria. Panoramix tiene otra pero no he logrado que me funcione, si eso mirad su blog.

Paso 0: Necesitáis el pppoe_3.5-4ubuntu1_i386.deb y el driver de eagle: eagle-usb-2.3.3.tar.bz2 a descargar de su web.

Primero, al iniciar Ubuntu metéis el cd de Ubuntu Dapper, es que lo vamos a usar con Synaptic. Descomprimís el eagle-usb-2.3.3.tar.bz2. Y también abréis una terminal. Aplicaciones, Accesorios, Terminal.

Segundo, En Synaptic, os metéis en Configuración,Repositorios. Incluís el cd como Repositorio e instaláis el "build essential".
Instaláis también:
linux-headers-2.6.15-23 (versión 2.6.15-23.39) será instalado
linux-headers-2.6.15-23-386 (versión 2.6.15-23.39) será instalado
linux-headers-386 (versión 2.6.15.22) será instalado
No sé si hacen falta todos, pero vamos, que yo lo he hecho así.
Cerrad ya el Synaptic.

Tercero, En la terminal:

cd eagle-usb-2.3.3
sudo ./configure
sudo make
sudo make install
sudo eagleconfig (ES01, luego ya el nombre de usuario,....)
y ahora como le déis a sudo startadsl os dirá lo de la connexion echouée tan majico que he visto muchas pero muchas veces.
Así que en vez de eso:
sudo pppoeconf
y le dáis a todo que sí, que no tengo ni idea de algunas cosas que pregunta.
Luego con pon dsl-provider se funciona.

Posibles problemas:
sudo: make: command not found
-Si no encuentra el make es que no habéis instalado el build essential

error: kernel-sources cannot be found!
- Es que os falta por instalar linux headers

You have to run ./configure first!
- Os habéis saltado el ./configure antes del make

========================================================================
distribution detected Debian

dhcp support dhclient

pppd support yes
pppoa support yes
pppoe support no (runtime detection)

install eagleconnect (tcl/tk frontend) yes

generate documentation no
========================================================================

Es que no habéis instalado el pppoe. Cuando lo hagáis y volváis a ejecutar sudo ./configure saldrá pppoe support yes

dpkg: el área de la base de datos de estado está bloqueada por otro proceso
- Está abierto Synaptic, cerradlo y volved a intentarlo

Imagen de feten7
+1
0
-1

sudo eaglectrl -d
CMVs successfully sent to driver.
Options successfully sent to driver.
Using DSP code for POTS line
DSP code successfully loaded.
pon dsl-provider
Plugin rp-pppoe.so loaded.
/usr/sbin/pppd: In file /etc/ppp/peers/dsl-provider: unrecognized option 'eth0'
Esto pasa porque no se le ha dado tiempo suficiente.
pon dsl-provider
Plugin rp-pppoe.so loaded.

+1
0
-1