Problemas con el software-center (incluyo salida consola)

Pues eso... desde la barra de unity doy al software-center y no hace nada...

Así que me ido a terminal e intento ejecutar desde allí... aquí si abre el software-center (aunque tarda un poco). La salida es:

/usr/bin/software-center:25: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.

from gi.repository import Gtk, GObject

/usr/share/software-center/softwarecenter/ui/gtk3/views/purchaseview.py:29: PyGIWarning: WebKit2 was imported without specifying a version first. Use gi.require_version('WebKit2', '4.0') before import to ensure that the right version gets loaded.

from gi.repository import WebKit2 as webkit

2016-09-15 19:13:01,038 - softwarecenter.backend.zeitgeist_logger - WARNING - Support for Zeitgeist disabled

/usr/share/software-center/softwarecenter/ui/gtk3/widgets/symbolic_icons.py:23: PyGIWarning: PangoCairo was imported without specifying a version first. Use gi.require_version('PangoCairo', '1.0') before import to ensure that the right version gets loaded.

from gi.repository import Gtk, Gdk, GLib, PangoCairo

2016-09-15 19:13:01,089 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'

2016-09-15 19:13:01,711 - softwarecenter.region - WARNING - failed to use geoclue: 'org.freedesktop.Geoclue.Error.notAvailable: Geoclue master client has no usable Address providers'

2016-09-15 19:13:02,013 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file

2016-09-15 19:13:02,014 - softwarecenter.plugin - INFO - activating plugin ''

2016-09-15 19:13:02,069 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()

2016-09-15 19:13:02,401 - softwarecenter.db.update - WARNING - failed to load file /var/lib/apt-xapian-index/cataloged_times.p: unsupported pickle protocol: 3

/usr/share/software-center/softwarecenter/ui/gtk3/widgets/videoplayer.py:29: PyGIWarning: Gst was imported without specifying a version first. Use gi.require_version('Gst', '1.0') before import to ensure that the right version gets loaded.

from gi.repository import Gst

2016-09-15 19:13:05,059 - softwarecenter.db.update - WARNING - failed to load file /var/lib/apt-xapian-index/cataloged_times.p: unsupported pickle protocol: 3

/usr/bin/software-center:184: Warning: Source ID 79 was not found when attempting to remove it

Gtk.main()

/usr/bin/software-center:184: Warning: Source ID 158 was not found when attempting to remove it

Gtk.main()

2016-09-15 19:13:15,585 - softwarecenter.db.utils - INFO - software-center-agent finished with status 0

---------------------------

He intentado de todo... desinstalarlo y volverlo a instalar, un sudo dpkg --configure -a matar sesiones que pudieran estar bloqueando el Dpkg, reconstruir apt-get, purgarlo... nada de nada.

Al final he instalado el cairo-dock y desde él si lo habré... es más, una vez abierto desde el cairo he anclado el software-center a la barra unity y me aparecen dos software-center (no se si es la misma versión)... desde el nuevo icono (de unity) si puedo abrirlo, desde el original no...

Alguien puede ayudarme para quedarme únicamente con el dock de Unity...

Salu2 y gracias por vuestro tiempo

NOTA: la primera vez que ejecute software-center desde terminal me decía que no estaba instalado, al instalarlo me decía que necesitaba paquetes (no entiendo como funcionaba antes)... por eso creo que tengo dos versiones diferentes o que unity se ha quedado pillado apuntando a una que ya no existe (tampoco tengo claro por que ha desaparecido).