donde está wvdial¿?

Hola a todos:

Hace ya tiempo que llevo "jugando" con ubuntu y dos días que lo tengo instalado "ya en serio" en un portátil UPI junto con un WinXP.

Pues resulta que descubrí, como otros muchos desgraciados, que mi portátil NO tiene modem, sino que es un Winmodem, por lo que tengo que recurrir a nuestro amigo "Gates" para navegar (¡por supuesto con Firefox!).

Y tras buscar en la red encontré en este foro una posible solución a mi problema(instalando driver, compilando kernel,...). Todo va sobre ruedas hasta que tengo que usar wvdial:

El sistema me dice que no lo tiene instalado, que no existe. Me extrañó mucho así que decidí buscarlo en el repositorio de ubuntu-es para instalarlo (recordad que uso XP para internet).

Bajé la versión wvdial_1.54.0-1ubuntu_i386.deb que es la que me corresponde. La copié en la carpeta /home/usuario de Ubuntu y le pasé el dpkg -i pero esta vez me indica el sistema que falta una librería. Concretamente la libwvstreams3-base, con lo que hasta aquí he llegado. Antes de instalar/desinstalar librerías quería que alguno de los expertos me recomendara qué debo hacer. Os resumo mi problema:

1.¿Cómo es que el SO de ubuntu que instalé (v. 4.10 adquirido con la revista TodoLinux nº 48) no trae wvdial?

2.Tampoco en Synaptic viene en la lista de paquetes sin instalar, por lo que se supone que la versión que tengo no contempla su instalación a posteriori.

3.¿Cómo puedo instalar wvdial de forma fácil y sin destrozar el resto del SO?

Muchas gracias por vuestras respuestas.

Un novato linuxero.

Imagen de scumler
+1
0
-1

1.- Si no está wvdial es que los desarrolladores de Debian y/o Ubuntu han estimado que no debe estar. Eso no significa que no puedas hacer lo mismo con otro paquete que si hayan estimado idóneo.

2.- Me remito al punto 1º

3.- Si persistes queriendo instalar wvdial pues, en principio, simplemente instalando las dependencias que te pida el paquete wvdial_1.54.0-1ubuntu_i386.deb que has descargado debería funcionarte. Si son las libwvstreams3-base, pues instálalas. Instalar librerias no es destrozar un sistema (esto, por suerte, no es windows) y si guardas un mínimo de precauciones (leer los mensajes de apt-get, no machacar nada que no sepas que es, etc...) todo seguirá igual o mejor que antes. Y, en el peor de los casos, si algo falla es muy probable que en poco tiempo alguien te ayude a solucionarlo :-D

4.- Un simple 'aptitude search wvdial' en mi sistema me ofrece:

root@uele:~# aptitude search wvdial
p webmin-wvdial - wvdial configuration module for webmin
i wvdial - PPP dialer with built-in intelligence

Por tanto asumo que, al menos en Warty viene 'de serie' al no haberlo yo instalado. ¿Has comprobado que no esté ya en tu sistema?

5.- Una rápida búsqueda en google con 'wvdial ubuntu package' me da como primera página esta:

http://higgs.djpig.de/ubuntu/www/hoary/comm/wvdial

en la cual, entre muchas otras cosas, dicen las dependencias del paquete.

Espero que la parrafada te ayude.

Saludos.

+1
0
-1
Imagen de euphoria
+1
0
-1

yo tengo el ubuntu descargado de la web que supongo que sera la misma version y si trae el wvdial simplemente ve a synatpic en el configuracon del sistema y ya ahi esta. suerte

salu2:euphoria

Software is like sex, is better when is free...

+1
0
-1

Software is like sex, is better when is free...

Imagen de Anónimo
+1
0
-1

Gracias por tu comentario. Qué versión tienes concretamente, por si me sirve de ayuda?

+1
0
-1
Imagen de Anónimo
+1
0
-1

En primer lugar, gracias por tu ayuda, Scumler.

Descargué de la página que me indicas la librería necesaria y me dispuse a instalarla, cuando... ¡ahora me pide la libgam0!

Descargo ésta última y cuando me dispongo a instalarla, dice que es incompatible con una librería del sistema y la quita. Por otro lado, me sigue pidiendo otra librería más: esta vez la gaim. Por lo que finalmente desisto en el intento y reinstalo las librerías que trañia por defecto.

Creo que el error está en la versión que he instalado. Por alguna razón no trae el wvdial y yo LO NECESITO para poder instalar el dichoso win-modem. Así que creo que lo haré será bajarme una distro completa del repositorio.

He leído por aquí que existen dos versiones: la Warty (que creo que es la que tengo) y la Hoary. ¿Cuál me recomiendáis? Os recuerdo que tengo un portátil UPI Pentium IV a 2,4 con una ram de 700 megas y un disco duro de 30 gb: actualmente tengo usados 10 para XP y 20 para ubuntu.

Muchas gracias de nuevo.

Espero ansioso vuestras respuestas.

+1
0
-1
Imagen de scumler
+1
0
-1

a desinstalar la versión que has puesto tú, tanto de wvdial como de la librería, y a instalar la versión que viene en Warty. En teoría, todo debería estar preparado para cumplir correctamente las dependencias.
Con aptitude, en consola, o synaptic, en gráfico, tienes la prueba a dos clics.

Respecto la versión de Ubuntu, yo me quedaría con Warty (que es la más estable). Hoary es la que actualmente aún no está depurada para entornos productivos (eso no significa que no funcione bién, solamente que puede darte alguna que otra sorpresa).
Únicamente en el caso de que Warty no te reconociera todo el hard, sería bueno intentar a ver si Hoary tiene algún paquete o módulo de kernel que si lo hiciera. Si no es así, ahórrate sustos. ;-)

Saludos

+1
0
-1