¿Qué les pasa a mis DNS's?

Imagen de Orejapico
0 puntos

Hola a todos. Últimamente he comprobado que en mi PC no funciona correctamente Internet de un tiempo a esta parte. En concreto, un día le dio por no funcionar, y después de analizar y de probar cosas observé que las casillas donde se indica la DNS estaban vacías, algo muy extraño porque en su día las rellené yo y no las he vuelto a tocar. Al rellenarlas, todo volvió a la normalidad. Pero, y he aquí lo extraño, cada vez que reinicio las pierdo!! Que no me supone un gran problema, porque al ponerlas vuelve a funcionar, pero ¿por qué desaparecen? Y ¿qué hacer para evitarlo?

No sé si servirá de mucha ayuda, pero he observado un cierto comportamiento anómalo del ordenador en general desde que instalé MySQL (por el tema del Amarok). En fin, agradeceré vuestra ayuda.

Imagen de yeimsvond
+1
0
-1

A mi me pasó lo mismo cuando instale dapper por primera vez, lo arreglé de la siguiente manera:

1.-Edita el archivo /etc/network/interfaces
2.- Añade debajo de la lína iface eth0 lo suigente:

dns-nameservers "tu dns primario" "tu dns secundario"

Sin las comillas hay pon tus direcciones del dns

Un saludo y suerte

+1
0
-1
Imagen de Orejapico
+1
0
-1

Sí señor, problema resuelto :) Muchas gracias.

Ahora, creo que voy a quedarme con las ganas de saber por qué ocurrió... en fin, al menos ya funciona.

+1
0
-1

 

**************************************************************

-Si en la caja dice "Funciona en Windows XP o superior", ¿por qué no consigo arrancarlo en mi Ubuntu?