Problema con D-Link dwl-g630 en Dapper

Imagen de ghiskard
0 puntos

Estoy intentando conectarme a internet con una tarjeta wifi D-Link dwl-g630 en Dapper y ocurre que si bien detecta e instala los drivers, junto con detectar y conectarme con la red inalámbrica, al final, no logro conectarme a internet:

ifconfig muestra:
ath0 Link encap:Ethernet HWaddr 00:13:46:62:92:DD
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:243 dropped:0 overruns:0 frame:243
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:200
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:9 Memory:c8be0000-c8bf0000

iwlist scan muestra:
Cell 01 - Address: 00:14:BF:0C:79:D6
ESSID:"linksys_SES_32811"
Mode:Master
Frequency:2.412 GHz (Channel 1)
Quality=31/94 Signal level=-64 dBm Noise level=-95 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100

iwconfig muestra:

ath0 IEEE 802.11g ESSID:"linksys_SES_32811"
Mode:Managed Frequency:2.412 GHz Access Point: 00:14:BF:0C:79:D6
Bit Rate:1 Mb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

dhclient muestra:

Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/ath0/00:13:46:62:92:dd
Sending on LPF/ath0/00:13:46:62:92:dd
Sending on Socket/fallback
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 19
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 16
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 6
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

¿Aguien puede darme una ayuda?

Imagen de ghiskard
+1
0
-1

Urgando en la red llegué a la siguiente solución:

El controlador que viene con dapper no es el indicado para la tarjeta por lo cual hay que usar ndiswrapper que permite el uso del controldaro de windows.
En primer lugar y como la tarjeta al conectarse automáticamente carga el módulo ath_pci hay que desactivarlo, esto se realiza con
rmmod ath_pci
y más permanente con
sudo nano /etc/modprobe.d/blacklist
en donde se agrega al final
blacklist ath_pci

Después de esto se instala ndiswrapper-utils mediante el gestor de paquetes synaptic
Descargamos el controlador windows de la página de soporte, en mi caso particular la tarjeta es de revisión d1 por lo cual el controlador está localizado en la página chilena de soporte de d-link
Luego en el directorio donde se encuentra el driver:
ndiswrapper -i archivo.inf
ndiswrapper -l debería mostrar el controlador e indicar que está presente el hardware
luego con
ndiswrapper -m
queda establecido que cargará la tarjeta con este controlador al iniciar
y listo, ya se tiene instalada la tarjeta y visible con ifconfig y iwconfig lo que queda es configurarla y conectarse a internet...

+1
0
-1