Bloqueo en los gestores de instalación de paquetes.

Imagen de RuonorY
0 puntos

Tengo un problema con los instaladores, tuve que cerrar Automatrix mientras instalaba paquetes en mi sistema y desde entonces no me funciona ningún otro gestor de paquetes, cuando intento instalar un archivo .deb me dice que no está permitido ejecutar más de un gestor al mismo tiempo, parece que desde que cerré Automatrix se comporta como si estuviese siempre abierto.

¿Sabéis algún modo de corregir este error? persiste incluso reiniciando.

Imagen de gabiel
+1
0
-1

¿Podrías publicar el mensaje exácto que da apt-get al intentar realizar alguna operación?

En principio, podrías ver que proceso está bloqueando al resto mediante sudo fuser /var/lib/dpkg/lock; y tras eso, matar el proceso mediante sudo kill -9 pid_que_te_devuelva_el_comando_anterior

Saludos.

♠ ♣ ♥ ♦
Este comentario puede contener trazas de cacahuetes, almendras y germen de trigo.
[Miguel A. Santamaría Rogado] [JID: gabiel@ubuntu-es.org] [Normas del foro]

+1
0
-1
Imagen de RuonorY
+1
0
-1

En realidad no uso apt-get, soy muy nuevo en esto y de momento prefiero usar el modo gráfico para todo, he intentado usar aptitude y no logro instalar el paquete.

Hago doble clic sobre el paquete y luego pulso en instalar paquete, después me pregunta si quiero dar permiso de ejecución a esa aplicación (recuerdo que es .deb) y me pide el pass del root, luego dice exactamente:
"Solo se permite la ejecución simultanea de una única herramienta de gestión de software. Por favor, cierre cualquier otra aplicación como "gestor de aplicaciones", "aptitude" o "Synaptic" primero."

Ovbiamente no tengo ninguno de estos gestores abierto.

He hecho lo que me has dicho pero cuando escribo:

$sudo fuser /var/lib/dpkg/lock

seguidamente me pide el pass de root y luego vuelve de nuevo a $ sin decirme nada.

+1
0
-1
Imagen de Gold_man
+1
0
-1

Así es LINUX, un poco soberbio... :)
Te sugiero, ya que tiendes a usar mayoritariamente el modo gráfico tal como todos los que venimos de Windows, que en la Barra de Menu, en SISTEMA bajes hasta ADMINISTRACION y de ahí hasta MONITOR DEL SISTEMA.
Cuando se abra la ventana, arriba a la derecha tienes las pestañas de procesos, recursos y dispositivos. En procesos revisa si tienes algo (durmiendo o ejecutándose) que se parezca a Automatix, Sinaptyc, etc. Si es así "mátalo" sin piedad (botón en la esquina inferior derecha: "finalizar proceso").
Luego instala lo que necesites. Creo que eso debería ayudarte.
Saludos.

Gold_man

+1
0
-1

Gold_man

Imagen de Anónimo
+1
0
-1

Pues tiene que ser muy grave porque eso es lo primero que intenté hace y nada, no aparece nada con el nombre de un gestor.

Creo que voy a reinstalar, no es la primera vez que me cargo la distro mezclando cosas. Lo importante es que por primera vez he conseguido sentirme cómodo en Linux y ahora no tengo que rendirme, estoy seguro de que conseguiré abandonar Windows del todo, ya que realmente no hay nada en él que yo necesite y no pueda encontrar en Ubuntu.

Gracias por todo.

+1
0
-1
Imagen de gabiel
+1
0
-1

Antes de reinstalar, por si acaso la solución es sencilla, prueba a ejecutar el asistente para instalar deb's desde un terminal (mediante gdebi-gtk), de esa forma te mostrará más información sobre lo que ocurre al ejecutarlo.

Saludos.

♠ ♣ ♥ ♦
Este comentario puede contener trazas de cacahuetes, almendras y germen de trigo.
[Miguel A. Santamaría Rogado] [JID: gabiel@ubuntu-es.org] [Normas del foro]

+1
0
-1
Imagen de FERdeBOER
+1
0
-1

Espero que no hayas reinstalado.

Me acaba de pasar lo mismo y lo he solucionado con
sudo dpkg --configure -a

Había intentado desinstalar Automatix por si era ese el problema y me salió que no se podía y que tal vez debía ejecutar eso.

Lo hice y ahora esta funcionando de nuevo el gestor de actualizaciones, Synaptic...

+1
0
-1