Como tener aMsn 0.96 con antialias y con la posibilidad de utlilizar cualquier fuente que tengamos instalada.

+1
0
-1

Con ésto instalamos la última versión estable de amsn (salida hace muy poco) y le damos el aspecto que se merece a uno de los mejores mensajeros escritos hasta el momento.

Abrimos un terminal y con ésto quitamos la versión anterior de amsn y de tcltls ( el símbolo $ reprecenta que estoy en la consola por lo tanto no se escribe ):

$ sudo aptitude remove amsn tcltls

Ahora instalamos los paquetes necesarios para compilar el amsn y demás:

$ sudo aptitude install build-essential libc6-dev libx11-dev libxft-dev imagemagick libpng

Descargamos y compilamos de ésta manera tk y tcl para que nos proporcione antialias en las fuentes:

$ wget ftp://ftp.tcl.tk/pub/tcl/tcl8_5/tcl8.5a5-src.tar.gz
$ tar xzvf tcl8.5a5-src.tar.gz
$ cd tcl8.5a5/unix
$ ./configure --prefix=/usr
$ make
$ sudo make install

$ cd
$ wget ftp://ftp.tcl.tk/pub/tcl/tcl8_5/tk8.5a5-src.tar.gz
$ tar xzvf tk8.5a5-src.tar.gz
$ cd tk8.5a5/unix
$ ./configure --prefix=/usr --enable-xft
$ make
$ sudo make install

Ésto es para que funcionen las nuevas versiones sobre el amsn:

$ cd /usr/bin
$ sudo rm wish
$ sudo ln -s wish8.5 wish

Finalmente compilamos el amsn:

$ cd
$ wget http://optusnet.dl.sourceforge.net/sourceforge/amsn/amsn-0.96.tar.bz2
$ tar jxvf amsn-0.96.tar.bz2
$ cd amsn-0.96
$ ./configure --with-tcl=/usr/lib/ --with-tk=/usr/lib/
$ make
$ sudo make install

Si todo salió bién escribimos amsn y al iniciar seción nos ofrecerá descargar tls (sin ésta libreria no podemos conectarnos), elegimos el adecuado para nuestra arquitectura de procesador (la más común x86, para procesadores de 32 bits), ponémos instalar y finalmente tendremos nuestro amsn listo para funcionar con la posibilidad de cambiarle las fuentes a cualquiera que tengamos instalada y con antialias.

Como bonus les dejo unos themes que hice a partir de uno para ubuntu.

http://www.gnome-look.org/content/show.php?content=46224

http://www.gnome-look.org/content/show.php?content=40557

deben descargarlos y descomprimirlos en /home/TU_NOMBRE_DE_USUARIO/.amsn/skins , luego abren el amsn y lo elijen entrando a /cuenta/preferencias/apariencia/elejir tema (skin)

-----

Actualizado a las versiones a5 de tk/tcl

-----------------------

Visiten mi blog! http://symphox.blogspot.com/

Comentarios

Imagen de Anónimo

lo he hecho todo
y al ejecutar mi nuevo amsn me dice:

Fallo en segmentacion

:S

y no se me ejecuta ... alguien me puede ayudar?

Imagen de kelp

A mi me pasa exactamente lo mismo, a ver si alguien sabe qué puede ser...

http://aceitunassinhueso.com

Las tres cosas más peligrosas del mundo son: un programador con un soldador, un ingeniero de hardware con un parche de software y un usuario con una idea

Imagen de sympozium

Prueben con ésto (ya lo edité):
$ cd /usr/bin
$ sudo rm wish
$ sudo ln -s wish8.5 wish

-----------------------------------------------------

Visiten mi blog!! http://symphox.blogspot.com/

Imagen de JohnyRisu

ahí está el asunto ... ahora si funciona ... gracias ... x cierto, antes el anónimo era yo, k no estaba logeado ... jejeje. Un saludo y gracias

Imagen de kelp

Exacto, ya funciona :D
Muchas gracias!
Joe, así parece otro programa :D Mi vista te lo agradecerá eternamente xD

http://aceitunassinhueso.com

Las tres cosas más peligrosas del mundo son: un programador con un soldador, un ingeniero de hardware con un parche de software y un usuario con una idea

Imagen de kique_36

no se porque para ejecutarlo tengo que hacerlo por medio de terminal,algo hice mal?¡gracias
y otra cosa cuando intento abrir el correo hotmail me sale esto en la consola...

(firefox-bin:6224): Gtk-WARNING **: cannot open display:
You should really not run firefox through sudo WITHOUT the -H option.
Anyway, I'll do as if you did use the -H option.
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

····················································· quisiera ser lo que era cuando queria ser lo que soy· .....................................................

Imagen de sympozium

Probá reiniciando y rehaciendo el acceso.

-----------------------------------------------------

Visiten mi blog!! http://symphox.blogspot.com/

Imagen de ZeryOs

Todo me fue a la perfección, el unico detalle es que... se pueden borrar las carpetas??
tcl8.5a4
tk8.5a4
amsn-0.96RC1

Y otra duda es... no he podido agregar imagenes para cambiar mi Display (Imagen para mostrar)
ESpero me puiedas ayudar.. y gracias :P.

------------------------------------------------------------------------
Si deseas entrar y moderar una web, referente a Linux, contactame ;).
Mi blog

------------------------------------------------------------------------
Usuario viejo, re-encontrandose con Ubuntu.
Gracias a esta web por todo.

Imagen de sympozium

las carpetas se pueden borrar, y por lo de las imágenes asegurate que tengas instalado imagemagick (sino sudo aptitude imagemagick )

-----------------------------------------------------

Visiten mi blog!! http://symphox.blogspot.com/

Imagen de ZeryOs

Lanzo eso y me manda esto xD...

----------------------------------------------------
zeryos@zeryos-ubuntu:~$ sudo aptitude imagemagick
Password:
Orden desconocida "imagemagick"
aptitude 0.4.0
Modo de uso: aptitude [-S nombre_fichero] [-u|-i]
aptitude [opciones] ...
Acciones (si no se especifica ninguna, aptitude entrará en modo interactivo):

install - instala/actualiza paquetes
remove - elimina paquetes
purge - elimina paquetes junto con sus ficheros de configuración
hold - bloquea paquetes
unhold - desbloquea un paquete
markauto - marca paquetes como instalados manualmente
unmarkauto - desmarca paquetes como instalados manualmente
forbid-version - prohíbe a aptitude actualizar a una versión específica de un p aquete.
update - descarga las listas de paquetes nuevos/actualizables
upgrade - realiza una actualización segura
dist-upgrade - realiza una actualización, posiblemente instalando y eliminando paquetes
forget-new - olvida qué paquetes son "nuevos"
search - busca un paquete por nombre y/o expresión
show - muestra información detallada de un paquete
clean - elimina los ficheros de paquetes descargados
autoclean - elimina los ficheros de paquetes descargados obsoletos
changelog - muestra el registro de cambios del paquete
download - descarga los ficheros .deb para un paquete
reinstall - Descargar y (posiblemente) reinstalar un paquete ya instalado

Opciones:
-h Este texto de ayuda
-s Simula las acciones, pero en realidad no las realiza.
-d Sólo descarga paquetes, no instala o desinstala nada.
-p Siempre pide confirmación de las acciones
-y Supone que la respuesta a preguntas simples del tipo sí/no es « sí»
-F formato Especifica el formato para mostrar los resultados de las búsque das, lea el manual
-O orden Especifica como se deben ordenar los resultados de la búsqueda, lea el manual
-w ancho Especifica el ancho del visor para dar formato a los resultado de la búsqueda
-f Trata de arreglar paquetes rotos de forma agresiva.
-V Muestra la versión de los paquetes a instalar.
-D Muestra las dependencias de los paquetes cambiados automáticame nte.
-Z Muestra el cambio del tamaño instalado de cada paquete.
-v Muestra información extra (puede darse más de una vez)
-t [distrib] Establece la distribución desde la que se instalan los paquetes
-q en modo línea de comandos, suprime los indicadores incrementales de progreso .
-o opconf=val Establecer directamente la opción de configuración llamada 'o pconf'
--with(out)-recommends, Especifica si se tratan o no las recomendaciones como dependencias fuertes
-S fnombre: lee la información de estado extendida de aptitude de fnombre.
-u : Descarga una nueva lista de paquetes al arrancar.
-i : Realiza una instalación al arrancar.

Este aptitude no tiene poderes de Super Vaca.
zeryos@zeryos-ubuntu:~$ sudo aptitude imagemagick
Orden desconocida "imagemagick"
aptitude 0.4.0
Modo de uso: aptitude [-S nombre_fichero] [-u|-i]
aptitude [opciones] ...
Acciones (si no se especifica ninguna, aptitude entrará en modo interactivo):

install - instala/actualiza paquetes
remove - elimina paquetes
purge - elimina paquetes junto con sus ficheros de configuración
hold - bloquea paquetes
unhold - desbloquea un paquete
markauto - marca paquetes como instalados manualmente
unmarkauto - desmarca paquetes como instalados manualmente
forbid-version - prohíbe a aptitude actualizar a una versión específica de un paquete.
update - descarga las listas de paquetes nuevos/actualizables
upgrade - realiza una actualización segura
dist-upgrade - realiza una actualización, posiblemente instalando y eliminando paquetes
forget-new - olvida qué paquetes son "nuevos"
search - busca un paquete por nombre y/o expresión
show - muestra información detallada de un paquete
clean - elimina los ficheros de paquetes descargados
autoclean - elimina los ficheros de paquetes descargados obsoletos
changelog - muestra el registro de cambios del paquete
download - descarga los ficheros .deb para un paquete
reinstall - Descargar y (posiblemente) reinstalar un paquete ya instalado

Opciones:
-h Este texto de ayuda
-s Simula las acciones, pero en realidad no las realiza.
-d Sólo descarga paquetes, no instala o desinstala nada.
-p Siempre pide confirmación de las acciones
-y Supone que la respuesta a preguntas simples del tipo sí/no es «sí»
-F formato Especifica el formato para mostrar los resultados de las búsquedas, lea el manual
-O orden Especifica como se deben ordenar los resultados de la búsqueda, lea el manual
-w ancho Especifica el ancho del visor para dar formato a los resultado de la búsqueda
-f Trata de arreglar paquetes rotos de forma agresiva.
-V Muestra la versión de los paquetes a instalar.
-D Muestra las dependencias de los paquetes cambiados automáticamente.
-Z Muestra el cambio del tamaño instalado de cada paquete.
-v Muestra información extra (puede darse más de una vez)
-t [distrib] Establece la distribución desde la que se instalan los paquetes
-q en modo línea de comandos, suprime los indicadores incrementales de progreso.
-o opconf=val Establecer directamente la opción de configuración llamada 'opconf'
--with(out)-recommends, Especifica si se tratan o no las recomendaciones como dependencias fuertes
-S fnombre: lee la información de estado extendida de aptitude de fnombre.
-u : Descarga una nueva lista de paquetes al arrancar.
-i : Realiza una instalación al arrancar.

Este aptitude no tiene poderes de Super Vaca.
--------------------------------------------------------------------

En resumen, me dice que no tengo poderes de Super Vaca xD.
Alguna idea? xD,
Pero bueno... lance
sudo apt-get install imagemagick
y ne dijo que lo tengo en la version mas recuente :S.

------------------------------------------------------------------------
Si deseas entrar y moderar una web, referente a Linux, contactame ;).
Mi blog

------------------------------------------------------------------------
Usuario viejo, re-encontrandose con Ubuntu.
Gracias a esta web por todo.

Imagen de kique_36

amigos sigo con el mismo drama cuando quiero ejecutar amsn como usuario normal me sale este error ...El archivo de la configuracion de los autoestados esta corrupto... pero en modo root ejecuto de lo mas normal...

····················································· quisiera ser lo que era cuando queria ser lo que soy· .....................................................

Imagen de Anónimo

Antes que nada xD.. soy ZeryOs
Pues cabe una posiblidad... desinstala TODO... luego elimina la carpeta de .aMSN de tu directorio personal..

Luego vuelve a seguir esta guia y tal vez te vaya bien :P.. a mi me funciono para solucionar mis problemas... =D..

Hasta luego ;).

Imagen de kique_36

no me habre el navegador cuando quiero recibir correo..algo esta mal quizas sea una tonteria,y aparte no entiendo porque tengo que iniciarlo a modo de root no como usiario normal...bueno saludos

quisiera ser lo que era cuando queria ser lo que soy

····················································· quisiera ser lo que era cuando queria ser lo que soy· .....................................................

Imagen de sympozium

en en amsn, dentro de cuenta/preferencias/otras tenés que definir en navegador, en mi caso pongo "firefox $url" (sin las comillas)

-----------------------------------------------------

Visiten mi blog!! http://symphox.blogspot.com/

Imagen de kique_36

sino me equivoco tienes que darle $ sudo apt-get install imagemagick

····················································· quisiera ser lo que era cuando queria ser lo que soy· .....................................................

Imagen de sympozium

Me alegro, y perdón por la equivocación.

-----------------------------------------------------

Visiten mi blog!! http://symphox.blogspot.com/

Imagen de JohnyRisu

una cosa ... me va todo bien, menos la webcam ... k la cosa es k me la detecta pero dice ke estoy detras de un router y k no tengo abierto los puertos ... mentira, ya k los he abierto todos ... pero nada .... alguien me puede ayudar con este tema?

Imagen de Anónimo

hago todos los pasos bien, pero cuando llego a la parte del comando "make", me dice que no encuentra el comando.
que es lo que pasa?
siguiendo tus pasos, me trabé en la primera vez que pusiste
$ make

Imagen de ZeryOs

Pues yo tambien tengo errores, y puse un post pero nadie me hizo caso xD...
http://www.ubuntu-es.org/node/21439 Post con mis problemas xD

Aun asi se los pongo, alomejor me puedan ayudar :S...
1.- No puedo cambiar las imagenes para mostrar (Cuando hago Examinar... no hace nada)
2.- No puedo enviar archivos
3.- Falla el recivir archivos
4.- No veo mis emoticons (los que me envian si los veo)
5.- No puedo enviar zumbidos en una comversacipón de mas de 2 personas

Y pues se supone que no me falta ninguna libreria...

Espero me puedan ayudar... hasta luego :P.
------------------------------------------------------------------------
Si deseas entrar y moderar una web, referente a Linux, contactame ;).
Mi blog

------------------------------------------------------------------------
Usuario viejo, re-encontrandose con Ubuntu.
Gracias a esta web por todo.

Imagen de Anónimo

Buenas, soy novato en linux y mi problema es el siguiente:

Trate de seguir estos pasos para poner el amsn con las fuentes true type y al principio el tlc lo izo todo sin problema xo al llegar al tk el "./configure --prefix=/usr --enable-xft" lo realizo bien pero me llamo la atencion la siguiente linea:

checking for xft configuration... configure: WARNING: Can't find xft configuration

pero el problema llegó cuando me pongo a hacer el make, mpiezan a salir error del tipo:

syntax error before ‘)’ token y al final ponia make: *** [tk3d.o] Error 1

y me es imposible compilarlo, no se k pasa, aver si alguien me puede echar un cable

Gracias ;-)

Imagen de Anónimo

Gracias, funciona de maravilla! :D

Imagen de Segata Sanshiro

Al principio tuve muchos problemas con las dependencias, al instalar los paquetes. Ni synaptic ni apt-get me instalaban los paquetes -dev, tuve que descargarlos a mano desde packages.ubuntu.com via web y resolver los problemas de dependencias manualmente. Para la próxima vez, ¿como puedo configurar los gestores de paquetes para que me cojan ese tipo de paquetes?

Pero bueno, una vez solucionado he de decir que el resultado es maravilloso. El antialiasing quizás sea un poco bestia, pero me gusta (por algo me compré la Dreamcast cuando todos tenían una Ps2 ^^u...) Y poder elegir cualquier fuente no tiene precio.

Muchas gracias por el tutorial, cuando vi por primera vez que habría que recompilar el aMsn para poder tener antialiasing me desanimé, pero siguiendo estas instrucciones ha sido facilísimo! ¿Habrá que hacerlo todo de nuevo con una nueva versión de aMsn o bastará con recompilarlo en nuestro pc?

Bueno, gracias de nuevo y un saludo ^^

Imagen de sympozium

Lo de los paquetes -dev no se me ocuerre otra cosa q tengas mal el sources.list , en un ubuntu dapper 6.06 con todos los repositorios activados tienen q estar. Y teóricamente con una versión nueva de amsn solo haría falta compilarlo sin repetir nada más ni borrar la versión anterior, pero eso es lo mas probable no lo seguro, yo no tengo idea de como van a hacer la próxima versión, de todas formas creo q lo mejor sería q la próxima versión venga con antialias propio.

-----------------------------------------------------

Visiten mi blog!! http://symphox.blogspot.com/

Imagen de Anónimo

A mi me saliò todo perfectamente bien, EXCEPTO que va muy lento... arranqué y si conecta si puedo cambiar mi imagen y todo, pero va muy lento, es porque consume muchos màs recursos? o porque? como puedo cambiar al 0.95 ? saludos