Configuración de Internet por red

Imagen de TaTooKa
0 puntos

Buenas, estoy migrando de a poco a Linux, instalé hace poco Ubuntu y casi todo me funciona de maravilla.
El problema es que mi proveedor de Internet es bastante raro, se llama Alpha 2000. Es el ISP que provee internet a mi edificio, y cuando lo contratamos nos dieron ciertos datos para configurar en red y el acceso, que es un cable de red que entra a mi HUB.
La información que me dieron para conectarme para cada PC es:

Dirección IP
Máscara de Subred
Gateway
DNS 1
DNS 2

Con esto lo configuro desde windows (tengo 3 PCs con windows, para cada una me dieron un IP distinto, el resto queda igual), y en todas las PCs tengo internet sin problemas. Cuando instalé Linux pensé "buenísimo, nada de configurar módems USB, esto va a funcionar a la primera", pero no fue así, pongo exactamente todos los datos como tiene que ser en la configuración de red de Ubuntu, pero no pasa nada. Intentar hacer PING me devuelve "network is unreachable", abrir páginas web me dice simplemente que no encontró el host de destino, etc.

Otro detalle de mi conexión a internet (desde windows) es que desde la web no se tiene acceso a mi PC, es decir, el router del edificio bloquea todas las conexiones, solo puedo "salir" desde mi PC a la web pero no al revés, es decir que no puedo crear servidores de absolutamente nada, porque al dar mi IP público de internet, en realidad se estarían conectando al router, que obviamente no rutea ningun puerto a mi PC... Bueno, al menos eso es lo que entendí yo porque los de Soporte Técnico no me quisieron explicar demasiado.

Probé llamar a mi ISP pero obviamente su respuesta fue "No ofrecemos soporte para Linux". Para poder instalar los paquetes más importantes me vi obligado a configurar un Proxy básico desde otra de mis PCs, pero con todos los problemas que esto conlleva, la calidad de conexión deja mucho que desear y tira bastantes errores, no es una opción.

Todos los paquetes los pude bajar de los repositorios por el proxy, tengo todo funcionando y se podría decir que tengo un "pseudo-acceso a internet". Me gustaría que me den alguna pista de cómo configurar correctamente mi conexión (es decir, directo y no por proxy), ya que busqué por todo este foro pero ningun caso me ayudó.

saludos,

Imagen de TaTooKa
+1
0
-1

El problema estaba en la máscara de Subred. Ellos me daban una 255.255.255.248, según el consejo de un amigo probé usando 255.255.0.0 y funcionó perfectamente.

Ahora tengo problemas con apt-get, no puedo desconfigurarle el proxy, por lo tanto intenta conectarse al mismo en vez de directo y no funciona.

¿Alguna sugerencia?

---------------------------
TaTooKa
http://tatooka.blogspot.com

+1
0
-1

---------------------------
TaTooKa
http://tatooka.blogspot.com

Imagen de leonblanco
+1
0
-1

solo como una sugerencia.. revisa el archivo /etc/network/interfaces ahi puedes encontrar información util. ;)

+1
0
-1
Imagen de TaTooKa
+1
0
-1

Buen consejo, estuve mirándolo, tiene la info de mis placas de red. Pero del proxy nada... Cuando todavía usaba el proxy tiré archivos de config por todos lados para hacerlo funcionar, y ahora no puedo descubrir cuales me faltan revertir. La variable $http_proxy sigue con el proxy... ALguno tiene alguna sugerencia?

---------------------------
TaTooKa
http://tatooka.blogspot.com

+1
0
-1

---------------------------
TaTooKa
http://tatooka.blogspot.com