Dapper sin InterNet por Usb WIFI. AYUDA

Imagen de miyasaki
0 puntos

Hola. Os escribopara versipodemos conseguirque en mi ubuntudapper funcione internet.

Uso un Comtrend 536+ que tengo en una habitacion, yelotra habitracion ( donde tengo el pc) tengo al ordenador conectado una especio de pendrive wifi que se comunica conel routerComtrend dfe la otra habitacion.

Pues no consigo tener internet.

Heleido bastantes mensajes sobre este problema en los forosincluso uno que era identico al mio. GHe provado todoloquese decia en esos post y no he conseguido nada.

Tantop el comtrendcomo el usb wifi son los que daba jazztel. Loque pasa es queyolo uso ahoracon telefonica yen windows xp va perfecto.

Os pongo lo que me dan los siguientes comandosque escribo en el terminal:

---con ifconfig:

miyasaki@miyasaki-desktop:~$ ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:97 errors:0 dropped:0 overruns:0 frame:0

TX packets:97 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:8092 (7.9 KiB) TX bytes:8092 (7.9 KiB)

wlan0 Link encap:Ethernet HWaddr 00:02:E3:45:44:81

UP BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

---con iwconfig:

miyasaki@miyasaki-desktop:~$ iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 802.11b/g NIC ESSID:""
Mode:Managed Frequency=2.412 GHz Access Point: Not-Associated
Bit Rate:11 Mb/s
Retry:off RTS thr=2432 B Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=12/92 Signal level=10/154 Noise level=161/154
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:1820 Invalid misc:0 Missed beacon:0

---con iwlist:

miyasaki@miyasaki-desktop:~$ iwlist scanning

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

sit0 Interface doesn't support scanning.

wlan0 Scan completed :

Cell 01 - Address: 00:14:7C:B3:8F:64

ESSID:"Martin"

Mode:Master

Frequency:2.462 GHz (Channel 11)

Quality:4/92 Signal level=-240 dBm Noise level=-256 dBm

Encryption key:on

Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s

36 Mb/s; 48 Mb/s; 54 Mb/s

Cell 02 - Address: 00:60:B3:FA:67:D8

ESSID:"WLAN_8F

Mode:Master
Frequency:2.432 GHz (Channel 5)

Quality:72/92 Signal level=-222 dBm Noise level=-256 dB

Encryption key:on

Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s

6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s

36 Mb/s; 48 Mb/s; 54 Mb/s

Cell 03 - Address: 00:03:C9:8D:F6:18

ESSID:"Comtrend"

Mode:Master

Frequency:2.462 GHz (Channel 11)

Quality:68/92 Signal level=-220 dBm Noise level=-256 dBm

Encryption key:on

Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s

24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s

12 Mb/s; 48 Mb/s

Aqui mirouter lo detecta es el Cell03, el Comtrend

---con dhclient:

miyasaki@miyasaki-desktop:~$ sudo dhclient

Internet Systems Consortium DHCP Client V3.0.3

Copyright 2004-2005 Internet Systems Consortium.

All rights reserved.

For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/wlan0/00:02:e3:45:44:81

Sending on LPF/wlan0/00:02:e3:45:44:81

Listening on LPF/eth0/00:13:d3:b8:c4:d5

Sending on LPF/eth0/00:13:d3:b8:c4:d5

Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8

DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8

DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15

DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14

DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15

DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14

DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 19

DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15

DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4

No DHCPOFFERS received.

No working leases in persistent database - sleeping.

No se si con estaindoramcion podeishyudarme. Pero decidme algo.

Imagen de mtma
+1
0
-1

Antes de "sudo dhclient" tienes que conectarte al AP que detecta el "iwlist"
Tendrías que ejecutar
"sudo iwconfig wlan0 mode managed essid Comtrend key [cual] ap any"
para que se conecte a cualquier AP de la red Comtrend, solo falta que cambies [cual] por la clave correspondiente ya que en el iwlist dice que si la usas. Luego ejecuta
"sudo dhclient wlan0" y tendría que quedar funcionando.

Suerte

Matias

+1
0
-1

Matias

Imagen de miyasaki
+1
0
-1

He hecho lo que decias y me dice esto:

miyasaki@miyasaki-desktop:~$ sudo iwconfig wlan0 mode managed essid Comtrend key xxxxxxxx ap any
Error for wireless request "Set Encode" (8B2A) :
invalid argument "xxxxxxxx".

y despues el sudo dhclient wlan0 no hepusto pero no hapasado nada.

Las xxxxxxxx es la clave WEP. No la digoen el foropor seguridad.

Todos los pasos que he seguido en orden han sido:

sudo iwconfig
sudo ifconfig wlan0 up
sudo iwlist sccanning
sudo iwconfig wlan0 mode managed essid Comtrend key xxxxxxxx ap any
sudo dhclient wlan0

+1
0
-1
Imagen de mtma
+1
0
-1

Otra forma mas sencilla es ir al menu "sistema" -> "configuración de red" y elegir el adaptador inalámbrico y configurarlo desde ahí.
Pon el nombre de la red, la clave y en la parte inferior selecciona dhcp.

Suerte

Matias

+1
0
-1

Matias

Imagen de miyasaki
+1
0
-1

Parece ser que habia puesto mal la clave WEP.

He acabado configurando los parametros por gedit

en /etc/resolv.conf he puesto las dns detelefonica que me dieron.

en/etc/network/interfaces he puesto losdatos siguientes:

iface wlan0 inet static
wireless-essid Comtrend
wireless-key xxxxxx
address 192.168.1.5 (lo he puesto acabando en cinco porque me ha dadola gana)
netmask 255.255.255.0
gateway 192.168.1.1 (es la direccion que escribo desde el firefox en windowspara entrar enlaconfiguracion de mi router)

Tambien mehe asegurado que desde el menugrafico queaparece al escribir desde un terminal: network-admin, esten las mismasconfigraciones de dns , clave web y ips estaticas y demas que he mencionado antes.

y entonces al hacer los pasos : sudo iwconfig, sudo ifconfig wlan0, sudo iwlist wlan0 scan, sudo iwconfig wlan0 mode managed essid Comtrend key xxxxxx ap any, sudo dhclient wlan0 me heencontrado quesigo con internet.

si despues de todoesto, vuelvo hahacer sudo iwconfig. apareceesto:

miyasaki@miyasaki-desktop:~$ iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 802.11b/g NIC ESSID:"Comtrend"

Mode:Managed Frequency=2.412 GHz Access Point: 00:11:E6:6D:A2:45

Bit Rate:1 Mb/s

Retry:off RTS thr=2432 B Fragment thr:off

Power Management:off

Link Quality=76/92 Signal level=36/154 Noise level=161/154

Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

Tx excessive retries:1324 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

Por lo que se ve, hadetectado la red Comtredn un access point. Creo quecon esto ya debveria estartodo hecho, pero sigo sin internet.

Duespes he puesto un widget o como se llame en la barra superior de gnaome que se llama; "monitor de reder" y me apareceuna redllamada :"lo" que `poen que está incativa, y la red wlano0 (que antes no me aparecia) pero me poen en estado: desconectado.

NO SEQUE HACER.

+1
0
-1
Imagen de AlvaroBF
+1
0
-1

Tengo exactamente el mismo problema que tú, ahora mismo estoy en un portatil, y no consigo conectar al router de jazztel ni desde la tarjeta interna, ni desde la usb wifi tambien de jazztel.

SI configuro los datos en el menu de "Red" y intento guardar los datos el programa se queda cargando y tengo que cerrarlo .

SIgo sin internet, y en windows me va perfecto. Por cierto, antes de instalar uBuntu tenia instalado Kubuntu e iba perfecta la conexión wifi.

A ver si encontramos alguna solucion

+1
0
-1
Imagen de mtma
+1
0
-1

Se mezclo todo :(

Prueba de ejecutar (en linux con la configuración que lograste) "ping 192.168.1.1" si los paquetes no se pierden, significa que estas conectado pero ese no es el gateway.
Los datos del gateway los podes sacar de win en propiedades de la conexion de red que usas para internet, o en la linea de comandos (de windows) ejecuta ipconfig /all y te dara toda la configuración.

Volviendo a los pasos anteriores:
La idea es que "dhclient" configure todo esto automáticamente con los datos del servidor DHCP de tu router

Yo seguiría estos pasos:
Saca lo que agregaste a en/etc/network/interfaces
Luego solo ejecuta:
"sudo iwconfig wlan0 mode managed essid Comtrend key xxxxxx ap any"
"sudo dhclient wlan0" (esto remplaza al ifconfig wlan0 up pasándole automáticamente los datos del dhcp)

Y tendría que quedar funcionando. Lo puedes comprobar si al ejecutar "ifconfig wlan0" entre los datos que da, ya tiene configurada la dirección ip y el gateway.

La otra forma es que saques los datos del windows como te dije y los introduzcas a mano como hiciste anteriormente en /etc/network/interfaces

Considera probar también las otras redes detectadas.
El adaptador "lo" es un loop a tu propia maquina que siempre se configura.

Matias

+1
0
-1

Matias