Compilar el kernel para los drivers de NVidia

Hola a todos, soy Miguel y llevo en ubuntu muy poquito tiempo, vengo de Guadalinex. Recientemente acabo de comprarme un AMD64 y he decidido cambiarme a la version 64 bits, pero el problema que tengo no es ese, sino que tambien he comprado una tarjeta Nvidia Geforce 6600GT y no se como instalar los drivers de la pagina oficial. Yo instalo los de los repostorios, pero me sale la pantalla de NVidia (la del logo) pero se queda totalmente bloqueado. (por si sirve de ayuda, la parte de arriba del logo se va recortando y luego se queda a cuadraditos todo)

Me he bajado los drivers, pero claro, yo no se como precompilar el kernel y como decirle al instalador de nvidia donde esta. Yo se que este es un tema muy repetido, pero es que no consigo echarlo a andar con ningun Howto que he encontrado. Algun alma caritativa que me de solamente las instrucciones, no me hace falta explicarmelo, de eso ya me encargo yo, paso por paso, o mejor dicho, instruccion a instruccion.

P.D. tengo el kernel 2.6.8.1-3-amd64-generic, que es lo que pone con el comando uname -r

Un saludo y muchas gracias por anticipado

Imagen de Anónimo
+1
0
-1

Una actualiza a horary array6 (yo soy un usuario si demasiados conocimientos y es perfectamente usable) y otra lee los comentarios de este post de Barrapunto. Será más que suficiente ;-)

http://barrapunto.com/articles/05/03/02/193211.shtml

Saludoss

+1
0
-1
Imagen de Anónimo
+1
0
-1

Me he bajado la version horary array6 y he instalado los parches como pone en la pagina de Barrapnto, pero el caso es que lo instalo y pongo startx y funciona OK (aunque da un error de rivafb que no se como quitar). El caso es que si lo hago de esa manera funciona, si le doy a reiniciar funciona, pero si le doy a apagar y lo vuelvo a encender me da un error en el enlace o algo parecido (symbols)
/usr/X11R6/lib/modules/libfb.a:fbmmx.o

Alguna sugerencia??

+1
0
-1