INSTALACION DE UBUNTU SERVER 6.06 SOBRE POWEREDGE 1800 + LTO3

Imagen de yoda27mhz
0 puntos

Buenas,

Porque instalar ubuntu server? Es una buena pregunta... En mi caso, necesito un servidor de datos, que pueda compartir ficheros entre Unix (aix, irix, solaris) y Windows(2k, xp).

El Hardware:

Dell PowerEdge 1800
1x3Ghz Xeon
2x73Gb scsi Raid1 para Sistema Operativo.
3x146Gb scsi Raid5 para Datos.
1x SEAGATE DAT72 (DELL)
1x IBM ULTRIUM-TD3 (DELL POWERVAULT 110T)

En el momento de la instalacion, al generar los raids por hardware no hubo problema.

Instalo Ubuntu Server AMD64.

Instalo las X segun esta pagina(http://www.kickbill.com/?p=185) el nombre de alguno de los paquetes está mal.
Puedes buscar el nombre exacto con apt-cache search

Intento arrancar las X ... no funciona

Hice un dpkg-reconfigure xserver-xorg y le dije que era una VESA

Intento compartir los directorios por el entorno grafico.... no funciona. Lo hago a pelo, y pongo que los usuarios se validen en un PDC.

Intento compartir directorios por el entorno grafico.... no funciona, y encima me modifica el fichero smb.conf.????
Despues de buscar y ver errores en una xconsole, en cuentro la solucion, compartir con la opcion

/directorio *(rw, insecure)

Bueno, hasta aqui a sido bastante facil... ;)

Necesito montar un sistema de backup para cubrirme las espaldas... no hay problema de capacidad tengo una LTO3 400Gb/800Gb .

instalo el paquete mtx y mt.

Pruebo con la DDS4,me devuelve:

root@SERV:/# mt -f /dev/nst0 status
SCSI 2 tape drive:
File number=0, block number=0, partition=0.
Tape block size 0 bytes. Density code 0x26 (DDS-4 or QIC-4GB).
Soft error count since last status=0
General status bits on (41010000):
BOT ONLINE IM_REP_EN

Funciona! Hasta ahora todo bien.

Pruebo con la LTO3, me devuelve:
root@SERV:/# mt -f /dev/nst0 status
/dev/nst1: Input/output error

No funciona!

Busco documentacion en la pagina de DELL, no hay casi nada.

hago un more de /proc/scsi/scsi me devuelve:

Host: scsi1 Channel: 00 Id: 06 Lun: 00
Vendor: SEAGATE Model: DAT DAT72-052 Rev: A060
Type: Sequential-Access ANSI SCSI revision: 03
Host: scsi2 Channel: 00 Id: 01 Lun: 00
Vendor: IBM Model: ULTRIUM-TD3 Rev: 5BG2
Type: Sequential-Access ANSI SCSI revision: 03

Busco informacion en la pagina de IBM, ULTRIUM-TD3, hay drivers!!!, pero solo para RedHat y Suse.

http://www-1.ibm.com/support/docview.wss?uid=swg21193425

Los drivers:

ftp://ftp.software.ibm.com/storage/devdrvr/Linux/

Intento pasar los rpm a deb con la utilidad alien

root@SERV:/tmp# alien -d IBMtape-2.1.5-2.6.9-34.EL.x86_64.rpm
Warning: Skipping conversion of scripts in package IBMtape: postinst postrm preinst prerm
Warning: Use the --scripts parameter to include the scripts.
ibmtape_2.1.5-1_amd64.deb generated

Lo pruebo con la opcion --scripts

root@SERV:/tmp# alien -d --scripts IBMtape-2.1.5-2.6.9-34.EL.x86_64.rpm
ibmtape_2.1.5-1_amd64.deb generated

root@SERV:/tmp# dpkg -i ibmtape_2.1.5-1_amd64.deb
(Leyendo la base de datos ...
65215 ficheros y directorios instalados actualmente.)
Preparando para reemplazar ibmtape 2.1.5-1 (usando ibmtape_2.1.5-1_amd64.deb) ...
The kernel level is 2.6.15-26-amd64-server on your system
The current level of IBMtape supports Kernel 2.6.9-34.ELsmp and 2.6.9-34.EL only.
Exiting the installation.
dpkg: error al procesar ibmtape_2.1.5-1_amd64.deb (--install):
el subproceso pre-installation script devolvió el código de salida de error 100
Se encontraron errores al procesar:
ibmtape_2.1.5-1_amd64.deb

Pruebo forzando

root@SERV:/tmp# dpkg -i --force-all ibmtape_2.1.5-1_amd64.deb
(Leyendo la base de datos ...
65215 ficheros y directorios instalados actualmente.)
Preparando para reemplazar ibmtape 2.1.5-1 (usando ibmtape_2.1.5-1_amd64.deb) ...
The kernel level is 2.6.15-26-amd64-server on your system
The current level of IBMtape supports Kernel 2.6.9-34.ELsmp and 2.6.9-34.EL only.
Exiting the installation.
dpkg: error al procesar ibmtape_2.1.5-1_amd64.deb (--install):
el subproceso pre-installation script devolvió el código de salida de error 100
Se encontraron errores al procesar:
ibmtape_2.1.5-1_amd64.deb

Se os ocurre alguna manera de solucionar este problema?

Tambien estuve haciendo pruebas con el bacula + sql, y no hay manera de que se conecte a la base de datos, he leido por algun foro, que no funciona con la version 1.36 y que hay que compilar la 1.38, pero aun asi, no he logrado que funcione.

Probé con la sqlite y si que funciona, pero todos los manuales recomendaban la base de datos sobre mysql.

Alguno la habeis conseguido instalarlo sobre esta version de ubuntu?

Un saludo,

Imagen de yoda27mhz
+1
0
-1

Buenos dias,
Me respondo a mi mismo:

Despues de buscar y buscar... he encontrado esto:

http://www-128.ibm.com/developerworks/forums/dw_thread.jsp?message=13745...

No es que sea exactamente lo mismo, pero bueno. Resulta que a alguien le ha pasado lo mismo, pero con una libreria de cintas LTO 3584, con Gentoo. Ha compilado el kernel incluyendo "scsi generic" y "scsi tape", y le funciona.

Bueno.... voy a probar.

Si consigo solucionar este problema, seguiré con mi guerra con bacula.

Saludos,

+1
0
-1

Linux es facil ;)

Imagen de yoda27mhz
+1
0
-1

Bueno, continuo añadiendo intervenciones y os voy contando mi evolucion, por integrar un servidor ubuntu en mi empresa.

Una vez compilado el kernel incluyendo las dos opciones que arriba detallo, prosigo con mi lucha...

Ahora le toca el turno a Bacula 1.36.3. Tras haberme sentado seriamente y intentar instalar bacula, con el apt-get, que tantos y tantos manuales dicen que es tan facil :) (Mentira!!!) Encontré un manual decente, realizado por Ivan Bao Fernandez, que aunque el manual es sobre la distribucion Debian, a mi me funciono, con una pequeña variacion. El manual, no lo voy a colgar porque ya esta colgado por ahi (https://bailen.wordpress.com/2006/04/30/bulma-bacula-mysql-en-debian-sarge/)

La unica variacion, en el manual, fue que cuando vas a hacer el comando make_mysql_tables, a mi no me habia creado la base de datos, y la cree a mano desde mysqladmin.

Despues de configurar los ficheros del bacula (bacula-dir.conf, bacula-sd.conf, bacula-fd.conf) y empezar a hacer pruebas, me encuentro con dos problemas:

1.- Cuando estas conectado por la wx-console desde windows. Una vez hecho un backup, te vas a restaurar, y no puedes listar los archivos que has respaldado.
Aparece el error: .dir illegal command. enter "done" to exit.

Por lo que he leido por ahi, no te "garantizan" que puedas hacerlo. :( http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg216756....

Desde el mismo servidor si que funciona, y puedes seleccionar el fichero que te de la gana restaurar.

2.- Este error, me pasa cuando hago una consulta de los stores

Device status:
Archive "DDS-4" is not open or does not exist.
Device is BLOCKED waiting for appendable media.
Segun parece este error es un bug, que fue reportado y que en la version 1.38 ya está solucionado.
http://bugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=322753

Lo que no entiendo, es porque está en el repositorio de ubuntu la 1.36.3(22 april 2005), si va tan de culo (el postscript de instalacion no funciona, luego este bug,...), si ya esta disponible la 1.38.11

Un saludo

+1
0
-1

Linux es facil ;)

Imagen de yoda27mhz
+1
0
-1

Otra vez por aqui,
Por fin puedo decir que mi bacula esta funcionando al 80% (aun no tengo cintas LTO3), pero ya puedo decir que bacula, funciona, y funciona bien!!
Como ya tenia los ficheros de configuracion de la version anterior, me ha costado menos, así que ha sido bastante facil. Despues de compilar con las opciones:

./configure --sbindir=/usr/bacula/sbin --sysconfdir=/etc/bacula --with-pid-dir=/usr/bacula/var/run --enable-smartaloc --with-mysql --with-working-dir=/usr/bacula/working

Aseguraos que teneis "/usr/bacula/var/run" y "/usr/bacula/working", porque sino no arranca los servicios y no te dice porque.

Un saludo

+1
0
-1

Linux es facil ;)

Imagen de yoda27mhz
+1
0
-1

Hola,
Alquien ha hecho algun backup de un pdc con bacula?
He encontrado documentacion en ruso, pero no me entero....
http://www.opennet.ru/soft/Bacula_PDC_backup.pdf
Saludos,

+1
0
-1

Linux es facil ;)

Imagen de yoda27mhz
+1
0
-1

Hola,
Alquien ha hecho algun backup de un pdc con bacula?
He encontrado documentacion en ruso, pero no me entero....
http://www.opennet.ru/soft/Bacula_PDC_backup.pdf
Saludos,

+1
0
-1

Linux es facil ;)

Imagen de Anónimo
+1
0
-1

Hola,

instale Bacula en la empresa, funciona bien, soporta 6 ordenadores con Red Hat Enterprise 3 y Fedora Core 4 aunque sobre disco (no cinta). Primero lo mas obvio,

-has probado mysql y te funciona? si es que si, entonces el problema esta en la configuracion bacula, o bien no tienes bien el path hasta el socket (tiene que ser completo, apuntando al archivo de socket de mysql, no solo la ruta) o bien el username y password de mysql. Localiza el archivo de socket que utiliza Mysql en tu sistema, y edita el archivo bacula-dir.conf, vete al recurso Catalog {} y una vez alli ponle algo del estilo de:

# Generic catalog service
Catalog {
Name = MyCatalog
dbname = bacula; user = superman; password = "spiderman";
dbsocket=/home/mysql/mysql.sock
}

Sobreentiendo que el puerto de Mysql es el puerto por defecto (3306 creo), sino puedes cambiarlo, mirate el manual de bacula.

Espero que te sirva..

Guillem.

+1
0
-1