Visualización de applets en firefox

Imagen de Beto52
0 puntos

Hola a todos, soy un nuevo usuario del SO Unbuntu version -Dapper Drake- por cuestiones de estudio le instale el j2sdk para poder hacer aplicaciones, etc. Al principio no podia compilar las aplicaciones, problema del cual encontre solución aquí en el foro; por si alguno tiene el mismo problema les dejo los pasos:

  • Descargamos el j2sdk ya sea el bin o rpm, en mi caso descargue el bin.
  • Una vez descargado le damos su respectivos permisos desde la terminal: sudo chmod 755 jdk-1_5_0_08-linux-amd64.bin
  • Despues de haberle otorgado los permisos procedemos a moverlo al directorio donde queremos que se instale en mi caso /usr/java/ una vez ubicados en el directorio procederemos con su instalción escribiendo lo siguiente: ./jdk-1_5_0_08-linux-amd64.bin
  • Listo en teoria ya podriamos compilar nuestras aplicaciones! pero no es asi :-( este problemita lo solucionamos de la siguiente manera:

  • Como bien saben al instalar el j2sdk nos crea un directorio y contenida dentro de ella encontraremo otro birectorio llamdo bin dentro de este directorio se encuentran dos archivos java y javac; ahora ya conocemos la ubicación de estos archivos :-).
  • Bien, ahora procederemos a ubicarnos en el siguiente directorio: cd /usr/bin
  • Una vez ubicados en este directorio, procederemos a crear unos enlaces hacia los archivos java y javac de la siguiente manera (todo esto desde la terminal):
    sudo ln -s /path_donde_se_encuentran_dichos_archivos/java java
    sudo ln -s /path_donde_se_encuentran_dichos_archivos/javac javac
  • Despues de haber realizado todo lo anterior, podriamos vericarlo tecleando desde cualquier directorio javac y luego pulsar intro desde la terminal ocasionando un despligue de información, con esto ¡ya podriamos compilar y correr nuestras aplicaciones en java :)!.

    Lastimosamente no he encontrado la solución para crear un enlace de algún X archivo que se encuentre en el directorio jre del j2sdk que descargue para poder visualizar mis applets en el browser Firefox :-( si alguien fuese tan amable de solucionarme mi problema se los agradeceria.

    Nota: Encontre algunas soluciones como descargar firefox 32, etc.. pero la verdad no me llama la atención esa solucion, por otro lado he leido tambien descargar el j2re, pero ¡para que descargarlo cuando este solo es un derivado del j2sdk!

    Imagen de mtma
    +1
    0
    -1

    Para el plugin del firefox
    "sudo ln -s /donde/se/encuntra/java(libjavaplugin_oji.so /usr/lib/firefox/plugins" o
    "sudo ln -s /donde/se/encuntra/java(libjavaplugin_oji.so /usr/lib/mozilla-firefox/plugins"
    depende de tu instalación de ubuntu.

    Suerte

    Matias

    +1
    0
    -1

    Matias

    Imagen de Beto52
    +1
    0
    -1

    Hola Matias, dejame ver si te entendi bien, a la hora de de crear el enlace hacia donde tengo el archivo java lo tengo que hacer con el nombre libjavaplugin_oji.so.
    Mi caso:

  • sudo ln -s /usr/java/jdk1.5.0_08/bin/java /usr/lib/firefox/plugins/libjavaplugin_oji.so
  • así te refieres? porque si es de esta manera tampoco me carga los applets, agradeciendo tus respuesta :)

    +1
    0
    -1
    Imagen de mtma
    +1
    0
    -1

    Si y no :)

    Busca en tu directorio de java un archivo con nombre libjavaplugin_oji.so o parecido (seguro terminado en .so) y crea en la carpeta de plugins de firefox un enlace a este archivo.

    Suerte

    Matias

    +1
    0
    -1

    Matias

    Imagen de Anónimo
    +1
    0
    -1

    Hola nuevamente, disculpa tanta molestadera; pero fijate que ya me registre todos los directorios para encontrar el archivo que dices pero no lo encuentro :-(, para que te des una idea me descargue la versión j2sdk 5 update 8 para una amd64 de la pagina oficial.

    +1
    0
    -1
    Imagen de Anónimo
    +1
    0
    -1

    Hola nuevamente, disculpa tanta molestadera; pero fijate que ya me registre todos los directorios para encontrar el archivo que dices pero no lo encuentro :-(, para que te des una idea me descargue la versión j2sdk 5 update 8 para una amd64 de la pagina oficial.

    +1
    0
    -1
    Imagen de mtma
    +1
    0
    -1

    Utiliza la herramienta de busqueda de gnome o en una consola ejecuta
    "sudo updatedb"
    "locate libjava" a ver si lo encuentra.
    Yo tengo la misma versión pero para 32 bits y lo trae.

    Suerte

    Matias

    +1
    0
    -1

    Matias

    Imagen de Anónimo
    +1
    0
    -1

    Ala mano que fregadera la que te tengo :-) pero agradezco tu paciencia. Fijate que ya hice lo que me pediste y no aparece ese archivo del que me hablas, solo esto es lo que me aparece:

    $locate libjava
    /usr/lib/openoffice/program/libjava_uno.so
    /usr/java/jdk1.5.0_08/jre/lib/amd64/libjava_crw_demo.so
    /usr/java/jdk1.5.0_08/jre/lib/amd64/libjava.so

    +1
    0
    -1
    Imagen de mtma
    +1
    0
    -1

    Crea un enlace al ultimo archivo a /usr/lib/mozilla-firefox/plugins (o /usr/lib64/mozilla-firefox/plugins) y ejecuta firefox y en la barra de direcciones pone about:plugins y te dará información sobre que plugins tienes activos.
    Igual sigo buscando soluciones por si no es ese plugin.

    Suerte

    Matias

    +1
    0
    -1

    Matias

    Imagen de Anónimo
    +1
    0
    -1

    Hola, fijate que con anterioridad ya habia echo un enlace con el ultimo archivo que mencionas y tampoco funciona, eh estado buscando una solución por otros foros pero sigo sin encontrar nada, si logras encontrar una solución te lo agradeceria un montón.

    +1
    0
    -1