Kernel Vanilla

Al compilar un nuevo kernel bajado de kernel.org (el 2.6.9) me faltan algunos detalles como el automontaje de los usb o que deja de rula postfix. Hay que hacer un initrd? Cómo?

Imagen de entiak
+1
0
-1

Lo de los usb me suena a que te has dejado el soporte usb por el camino ... lo del postfix me deja sin palabras...

--
Saludos,
Juan. (http://blog.entiak.com)

+1
0
-1

--
Saludos,
Juan. (http://blog.entiak.com)
jbaixauli (at) gmail.com

Imagen de Anónimo
+1
0
-1

No, el usb lo tengo activado como integrado en el núcleo (*). Por lo que he leído por ahí Ubuntu carga con initrd algunos modulos antes de montar la partción, y al compilar mis kernels suelo hacerlos sin initrd.
Lo que quiero saber es si compilando con --initrd me creará una imagen válida, y si no es así, cómo hacerlo bien.

Lo del postfix también me extraña a mi. Se inicia aparentemente bien, pero luego, a través del webmin, compruebo que no es así. Escribo desde Evolution, envió y ningún problemas, pero cuando voy a webmin veo que el mensaje sigue en la cola. Si le doy a "Flush" dice que hubo un error con postfix (¿?)

Gracias.

+1
0
-1
Imagen de entiak
+1
0
-1

1. Con initrd te creará una imagen válida, si

2. Respecto a lo del postfix... para asegurarte ejecuta el comando "mailq" para ver la cola, no sea que el que no se entera sea webmin ...

ah! otra cosa mas, ¿antes te funcionaba postfix? es que creo recordar que por defecto viene configurado para entrega local solo ... o ni eso... por si acaso nunca está de mas hacer un "dpkg-reconfigure postfix"

--
Saludos,
Juan. (http://blog.entiak.com)

+1
0
-1

--
Saludos,
Juan. (http://blog.entiak.com)
jbaixauli (at) gmail.com

Imagen de Anónimo
+1
0
-1

Gracias, en cuanto llegue a casa lo hago y te cuento.

Sí, el postfix en el kernel de ubuntu me funciona perfectamente.

+1
0
-1
Imagen de Lord_ZealoN
+1
0
-1

Te invito a que te registres para saber con quien hablamos

Un saludo ;)
--------------------------------------------
Lord_ZealoN - El predicador
Linux User: #370919
Porqué Ubuntu? Porque yo lo valgo.

+1
0
-1

---
Lord_ZealoN - El predicador | LU:#370919
Guía: http://guia-ubuntu.org/
FAQ: http://www.ubuntu-es.org/book/view/171
How-TO's http://www.ubuntu-es.org/book/view/103

Imagen de Anónimo
+1
0
-1

Ya hice el kgkp --initrd (no me acuerdo del comando completo), pero no me creó una imagen (.img) sino 4 archivos sin extensión del tipo stmp-debian o algo así. Estoy en el curro y ni lo puedo mirar ni me acuerdo. Alguno de esos es el inirtd que debo renombrar o qué demonios hice mal??

Y otra cosa, como tengo activados los drivers de nvidia, no me cargan las X. Cómo podría arreglar eso? Gracias otra vez.

Y sí, terminaré registrándome. Tampoco me gusta escribir como anónimo pero tampoco me sobra tiempo. De esta noche no pasa.

+1
0
-1
Imagen de entiak
+1
0
-1

Lo de los drivers tienes un howto en la sección documentación, dale un vistazo.

Respecto a lo del initrd ... ¿kgkp? ¿eso que es? ¿porque nolo haces con el make?

--
Saludos,
Juan. (http://blog.entiak.com)

+1
0
-1

--
Saludos,
Juan. (http://blog.entiak.com)
jbaixauli (at) gmail.com