Problema instalando Azureus

Imagen de Nevershine
0 puntos

Hola a todos,mi problema es el siguiente:

Tras instalar correctamente java en mi pc (instalando el j2sdk como decía la guía de esta misma página), me dispongo a instalar el cliente para Bittorrent,Azureus. Pues bien cuando lo voy a ejecutar en la terminal (por que en el modo gráfico no pasa nada) con:
"java -jar Azureus2.2.0.2" me dice lo siguiente:
--------------------------------------------------------
Exception in thread "main" java.lang.NoClassDefFoundError: org/eclipse/swt/widgets/Layout
at org.gudy.azureus2.ui.swt.Main.(Main.java:39)
at org.gudy.azureus2.ui.swt.Main.main(Main.java:100)

--------------------------------------------------------
Por mis básicos conocimientos en java,intuyo que quizá tenga algo que ver con la función main de alguna clase....por decir algo.

Agradecería mucho cualquier tipo de aporte.

Imagen de pampero76
+1
0
-1

¿Has probado a usar bittornado? http://www.bittornado.com/ Yo lo uso y me vá de maravilla, en su día intenté instalar otro cliente para bittorrent (creo que el Azureus) y no hubo manera, después probe con bittornado y ningún problema. No es exactamente la respuesta a tu pregunta...pero es todo lo que te puedo decir.

Ta luego

+1
0
-1
Imagen de Nevershine
+1
0
-1

ya,si lo he usado brevemente en windows....y pensé en instalarlo en ubuntu pero s q a mi me gustaba la interfaz del azureus...es =,si no probaré l bittornado u otro parecio.
Gracias d tds formas

+1
0
-1
Imagen de Anónimo
+1
0
-1

Si no me equivoco lo que pasa es que la interfaz gráfica de Azureus fue hecha con eclipse, de ahí que te de ese fallo. Necesitas tener en el classpath el jar con la clase org.eclipse.swt...., mira en http://www.eclipse.org/swt/
Un saludo.

+1
0
-1
Imagen de yerga
+1
0
-1

Si pruebas a ejecutar el archivo ejecutable que viene ¿te da algun error? Me refiero al archivo azureus no al .jar

Un saludo.
------------------------------------------------------------------------
Linux user: 372827
Jabber: yerga@jabber.org
M$N: yerga@linuxmail.org

+1
0
-1

Un saludo.
------------------------------------------------------------------------
GNU/Linux user: 372827
Jabber: yerga@jabber.org
M$N: yerga@linuxmail.org

Imagen de Nevershine
+1
0
-1

Gracias a todos por la ayuda,pero el problema está "solucionado".El caso es que mire la guía de ubuntu y lo instalé tal y como me venía allí (bajandome el archivo comprimido y no el .jar).De todas formas miraré en la web de eclipse para solucionar futuros errores con otros programas.

+1
0
-1