Librerías de ANSI C

Imagen de Daria
0 puntos

SOY PRINCIPIANTE MANEJANDO UBUNTU, Y ESTOY TRABAJANDO CON EL COMPILADOR DE C PERO, cuando quiero compilar un programa en el cual utilizo sentencias de la librerias me manda un error que dice algo asi: ld devuelve un estado de salida 1.

Medio me puse a investigar en la web y encontre que es un error debido a que no estan activadas las librerias, pero no se como activarlas o instalarlas, no se que hacer.

Les agradeceria grandemente si me pudiesen informar que debo hacer.

Imagen de Sormes
+1
0
-1

Para ayudarte sería de gran ayuda que pusieras el error exacto que te da el compilador y que tipo de librerías estas intentando usar.

+1
0
-1
Imagen de Hinux
+1
0
-1

ve si tienes instalado el paquete build-essential...

+1
0
-1
Imagen de Anónimo
+1
0
-1

Estas poniendo al reves los parametros y seguramente te borre el código cada vez que intentas compilar, me equivoco?

lo correcto es:

gcc -o ejecutable codigo.c

y lo estas poniendo asi

gcc codigo.c ejecutable

+1
0
-1