DRIVER ATI 8.29.6

Imagen de topillo
0 puntos

Buenas hoy he instalado los nuevos drivers de ati para ver si han arreglado los cuelges y cuando he reiniciado las x no han arrancado y en el log del servidor x aparece el siguiente error

(EE) fglrx(0): Chipset 0x5960 is not recognized
(EE) fglrx(0): PreInitConfig failed
SetVBEMode failed
(EE) fglrx(0): PreInit failed
(II) fglrx(0): === [atiddxPreInit] === end
(II) UnloadModule: "fglrx"
(II) UnloadModule: "int10"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/lib/xorg/modules/libvgahw.so
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Un saludo

Imagen de Anónimo
+1
0
-1

... eso me recuerda el problema de las x de parte de ubuntu pero ahora es problema de ATI que mal... parece que me apresure en instalarlo, alguna idea de como solucionarlo?

+1
0
-1
Imagen de topillo
+1
0
-1

Ya somos 2, ahora creo que esto no tiene solucion, si el driver propietario de ATI no reconoce el chip de nuestras tarjetas ATI pues estamos apañaos!!! hay que joderse, no probaran las cosas antes? mi tarjeta es una 9250.

Un saludo.

+1
0
-1
Imagen de marrajo
+1
0
-1

Pues a mi en la Daper cuando instalo el driver fglrx me jode el inicio del openoffice asi que a seguir con el driver ATI(mesa)que tiene aceleracion 3D pero de pena como quieras jugar a algo.

+1
0
-1
Imagen de Anónimo
+1
0
-1

la versión 8.27.10 (lo tenia guardado) y recuperé el entorno gráfico :S me falta recuperar la aceleración 3d, despues de todo parece que no tengo que llegar al extremo de reinstalar todo denuevo ;)

+1
0
-1
Imagen de Anónimo
+1
0
-1

Pues al parecer se dieron cuenta del fallo, y ahora esta disponible para la descargar su anterior version 8.28.8

+1
0
-1
Imagen de gabiel
+1
0
-1

No hay ningún error en esa versión, si se lee la página de descarga puede verse que se deja de dar soporte a las siguientes tarjetas:

  • Radeon® 8500/9000/9100/9200/9250
  • Mobility™ Radeon® 9000/9100/9200
  • Radeon® IGP 9000/9100/9200

La versión 8.29.6 no ha sido retirada, tan solo se ha conservado un enlace a la versión anterior por si algún propietario de las mencionadas tarjetas lo necesita. De todas formas, el controlador libre ofrece aceleración 3D desde hace tiempo para todas ellas.

Saludos.

♠ ♣ ♥ ♦
Este comentario puede contener trazas de cacahuetes, almendras y germen de trigo.
[Documentación oficial][Normas del foro]

+1
0
-1
Imagen de topillo
+1
0
-1

Perdón, no pude imaginar que de una version de un controlador a otra dejase de dar soporte a ciertos modelos. Me podrias decir donde puedo encontrar el controlador libre de ati y con ese controlador como puedo activar la aceleracion 3d?

Gracias.

+1
0
-1
Imagen de topillo
+1
0
-1

He ido a la pagina de ATI y mira que lo pone bien claro, me emocione al ver una version nueva y la instale con la esperanza de que me solucionase los cuelgues y no me pare a leer las notas :P

Un saludo.

+1
0
-1
Imagen de gabiel
+1
0
-1

El controlador libre se incluye junto con el resto de x.org; puedes encontrarlo en el paquete xserver-xorg-driver-ati. Ya deberías tenerlo instalado, de hecho, sería el controlador que usases justo después de la instalación. Para usarlo, edita la configuración de las X y especifica "ati" como controlador en vez de "fglrx".

Supongo que habrán retirado el soporte de las R200 [1] para simplificar el desarrollo del controlador y porque el controlador libre ofrecía las mismas características. En su día nVidia hizo lo mismo, aunque el controlador libre correspondiente no ofrece aceleración para las nVidia. De todas formas, es software propietario, así que es normal que ocurran estas cosas.

Saludos.

[1]: Todas las tarjetas afectadas usan este procesador.

♠ ♣ ♥ ♦
Este comentario puede contener trazas de cacahuetes, almendras y germen de trigo.
[Documentación oficial][Normas del foro]

+1
0
-1
Imagen de topillo
+1
0
-1

Vale he probado el driver libre y en el enemy territory me dice que el driver no tiene opengl y me indica este paramentro "+set r_allowSoftwareGL 1" que he utilizado y el juego va a patadas, tambien he probado el counter en cedega y mas de lo mismo ha saltos!!. Este controlador libre se le puede activar para que funcione por opengl? es que si no me veo comprando una nvidia. Dime que hay luz en esta oscuridad!

Gracias

Un saludo.

+1
0
-1
Imagen de gabiel
+1
0
-1

Comprueba que la aceleración está disponible mediante glxinfo | grep Direct si aparece una línea diciendo "No", tendrás que revisar la configuración de las X. También puede que encuentres información interesante en el registro de x.org (/var/log/Xorg.0.log).

Saludos.

PD: No recuerdo si el módulo del controlador propietario (fglrx) interfería al usar el controlador libre o no; por si acaso comprueba que no esté cargado.

♠ ♣ ♥ ♦
Este comentario puede contener trazas de cacahuetes, almendras y germen de trigo.
[Documentación oficial][Normas del foro]

+1
0
-1
Imagen de topillo
+1
0
-1

Y si no me aparece ninguna linea?. Para desinstalar el driver propietario basta con desinstalar los paquetes desde el gestor de paquetes?

Gracias.

+1
0
-1
Imagen de gabiel
+1
0
-1

Ejecuta solo glxinfo y busca una línea que en la que ponga "Direct rendering". Sí para desintalar el controlador solo hay que desintalar los paquetes correspondientes.

Saludos.

♠ ♣ ♥ ♦
Este comentario puede contener trazas de cacahuetes, almendras y germen de trigo.
[Documentación oficial][Normas del foro]

+1
0
-1
Imagen de topillo
+1
0
-1

He desinstalado todos los paqutes con la palabra fglrx en el nombre del paquete he reiniciado y el glxingo me dice que el direct rendering: No

darky@darky-desktop:~$ glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier,
GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, G'LU_EXT_object_space_tess

Si sabeis que es lo que me falta?. estaria bien que la guia ubuntu se centrase tambien en el driver libre y no solo en el propietario.

Un saludo

+1
0
-1
Imagen de gabiel
+1
0
-1

Revisa el registro de x.org para ver si aparece algún error, deberías disponer de aceleración con solo usar el controlador, por ese motivo no hay tanta información sobre él, tan solo "funciona" (bueno, debería :) [1]).

Solo por si acaso, ¿usabas algún parámetro para el controlador propietario?

Saludos.

[1]: No es por darte envidia, pero debería ocurrirte lo mismo que a este otro usuario.

♠ ♣ ♥ ♦
Este comentario puede contener trazas de cacahuetes, almendras y germen de trigo.
[Documentación oficial][Normas del foro]

+1
0
-1
Imagen de topillo
+1
0
-1

He reinstalado el ubuntu para tenerlo limpio, creo que ha sido la mejor solución ya que con mis escasos conocimientos esto se podría alargar una semana mas, y si ahora tengo aceleración 3d pero muy pobre creo que solo aprovecho el 2 % de la potencia de la tarjeta.

Se puede actualizar la guia ubuntu la sección primeros pasos hardware acceleracion3d para que informe que los driver ati que lleva ubuntu ya dan soporte aceleración 3d a ciertos modelos y que los drivers propietarios de ati no dan soporte a todos los modelos actuales. Creo que esto le ahorrara tiempo a mucha gente

¿Se puede mejorar el rendimiento de los drivers libres?

Un saludo.

+1
0
-1
Imagen de gabiel
+1
0
-1

Hay alguna opción que podrías probar; en principio están desactivadas porque pueden dar problemas en algunas tarjetas, pero si funcionan mejoran el rendimiento.

Option "AGPFastWrite" "yes" [1]
Option "AGPMode" "4" [2]
Option "EnablePageFlip" "on" [1]

[1]: Estas dos opciones pueden dar problemas, sobre todo la primera. Pruebalas, si funcionan deberías obtener un rendimiento mayor.
[2]: Aquí tienes que especificar el tipo de AGP que tiene tu placa base y tarjeta gráfica; creo que 4 es tu caso.

Para usarlas, edita la configuración de las X (/etc/X11/xorg.conf) y añadelas a la sección de la tarjeta gráfica (Section "Device"). Tendrás que reiniciar el servidor gráfico tras los cambios. También puedes encontrar más opciones en el manual del controlador (man radeon).

Espero que con esto puedas sacarle más partido a la tarjeta, saludos.

♠ ♣ ♥ ♦
Este comentario puede contener trazas de cacahuetes, almendras y germen de trigo.
[Documentación oficial][Normas del foro]

+1
0
-1
Imagen de Anónimo
+1
0
-1

yo instale el ultimo driver de ati cuando no era para mi tarjeta, me quede sin interfaz gráfica y busque mucho en google y pregunto ¿seguro que lograste desinstalar todos los paquetes con exito? cuando seguia esta guia http://www.ubuntu-es.org/node/19975 siempre había un error en los pasos finales especialmente cuando hacia $ sudo module-assistant build,install fglrx (mirando la guia),,, he hecho muchos procedimientos y pruebas, pero no me dejaba instalar fglrx de ati (version 8.27.10),,, revisando el historial lo último que hice fue: $ sudo dpkg --purge --force-depends fglrx-driver y reinicie todo el procedimiento de la instalación sin problemas (aunque ya habia hecho otros procedimientos este último fue el que me dio resultado), no se si esto te servirá, en todo caso nos cuenta. Salu2

+1
0
-1
Imagen de topillo
+1
0
-1

Al final he reinstalado el sistema y ahora tengo acceleracion3d pero muy pobre.

Un saludo.

+1
0
-1
Imagen de kelp
+1
0
-1

Si que interfiere, aunque cambies la configuración del xorg a ATI. Al menos a mi me daba problemas, los cuales se resolvieron eliminando los paquetes y dejando solo los drivers libres.

Mi blog: http://aceitunassinhueso.com

+1
0
-1

Las tres cosas más peligrosas del mundo son: un programador con un soldador, un ingeniero de hardware con un parche de software y un usuario con una idea

Imagen de Anónimo
+1
0
-1

Estoy de acuerdo con lo de actualizar la guia

Un saludo.

+1
0
-1