Actualizacion de repositorios

Imagen de akdmia
0 puntos

Hola,
hace ya 10 meses comence a desarrollar una aplicacion para gnulinux llamada TuxGuitar la cual depende de SWT
Hasta hoy dispongo de un paquete .deb para ubuntu el cual usa "libswt3.1-gtk-java" y "libswt3.1-gtk-jni" de los repositorios de ubuntu.
pero ahora la proxima version necesita de una version actualizada de swt (3.2)

alguien sabe con quien me tengo que comunicar para saber porque no actualizan la version de swt ?

Imagen de gabiel
+1
0
-1

No se actualizan porque una vez publicada una versión de Ubuntu tan solo se hacen actualizaciones para corregir errores o para subsanar problemas de seguridad. En ninguna actualización se pasa a una nueva versión upstream. Así que tienes dos opciones:

  • Modificas tu aplicación para que pueda usar ambas versiones de las librerías que necesitas.
  • Creas paquetes con las versiones que requiera tu aplicación.

Saludos.

♠ ♣ ♥ ♦
Este comentario puede contener trazas de cacahuetes, almendras y germen de trigo.
[Documentación oficial][Normas del foro]

+1
0
-1
Imagen de akdmia
+1
0
-1

Hola Gabiel, gracias por la respuesta.

suena muy logico ya que si actualizan los paquetes la version de ubuntu nunca seria fija.

tendre que ver si aparece en la proxima version 6.10 Edgy..
tienes idea de donde puedo explorar para ver si swt-3.2 aparece en la lista ?

+1
0
-1
Imagen de gabiel
+1
0
-1

Puedes ver los paquetes que incluye Edgy [1] en estos momentos en packages.ubuntulinux.org.

Saludos.

[1]: También puedes ver los paquetes del resto de versiones de Ubuntu.

♠ ♣ ♥ ♦
Este comentario puede contener trazas de cacahuetes, almendras y germen de trigo.
[Documentación oficial][Normas del foro]

+1
0
-1
Imagen de akdmia
+1
0
-1

Muchas gracias!!

+1
0
-1