Actualizacion y ATI 9600 series sin aceleracion

Imagen de Buldden
0 puntos

hola listeros,

hace dos días actualice haciendo:
sudo aptitude update
sudo aptitude upgrade
sudo aptitude dist-upgrade

y se me actualizaron alrededor de 54 paquetes, entre ellos el kernel y los
drivers de ati(del repositorio de seveas), bueno pues despues de esta
actualización los drivers de ati no funcionan correctamente, en fglrxinfo me
aparece como que estoy usando los drivers MESA y no los de ati, he revisado
xorg.conf y desinstalado y reinstalado los drivers del repositorio de seveas
infinidad de veces sin ningún resultado.

Luego me anime a instalar los drivers de la web oficial de ati, los últimos
que han colgado siguiendo este howto

http://wiki.cchtml.com/index.php/Ubuntu_Dapper_Installation_Guide#Method...

Y el resultado es el mismo, sigo con MESA, luego los elimine por completo y
probé a instalar la versión anterior, la 8.28.8 que tenia preparada en debs y
que antes si funcionaba y tampoco funciona... sigo con MESA.

Este tema ya me tiene un poco extrañado porque ya no se donde puede estar el
fallo, ¿¿en el kernel?? bueno esto son algunos datos mas.

kernel: 2.6.15-27-686 (smp)
tarjeta ati: radeon 9600 series

tambien he probado a instalarlo en mi version antigua del kernel la 2.6.15-26-686 (smp) y sigo obteniendo el mismo resultado.

Tambien probe el driver libre de ati y funciona, pero a medias, en glxinfo me dice que el direct rendering: Yes

Luego cuando juego a enemy territory por ejemplo, el juego va fluido, pero la calidad grafica baja mucho con respecto al controlador fglrx y luego al ejecutar el warcraft III desde cedega (reconfigure cedega, para los nuevos drivers) tiene una calidad grafica malisima y encima va a tirones, cuado que antes funcionaba fluidamente...

Bueno espero que me puedan ayudar, ya que mi ati no es de las que se quedo fuera del driver nuevo y ademas no me funciona el antiguo, cosa que no entiendo.

un saludo y gracias a todos.

Imagen de topillo
+1
0
-1

Vale, cuando instalas el driver protierario 2.28.1 luego tienes que editar el archivo /ect/X11/xorg.conf y buscar la linea que pone Driver "ati" y poner Driver "fglrx", es por eso cuando pones glxinfo te informa que usas el driver de mesa3d.

Un Saludo.

+1
0
-1
Imagen de Buldden
+1
0
-1

Gracias por la respuesta,

los drivers los he manejado correctamente en todo momento, vamos que cuando he querido usar el propietario he tenido "fglrx" y cuando he querido el libre pues "ati".

uns saludo.

+1
0
-1
Imagen de Buldden
+1
0
-1

Ya conseguí la solución, que paso por desinstalar el controlador propietario de ati y luego hacer una limpia manual de todos los restos que quedaron de las anteriores instalaciones, use el comando

sudo find / -name *fglrx*

y luego elimine todos los archivos y directorios que me dio la salida del comando, exceptuando mis archivos que contenían ese nombre.

Luego con un sencillo

sudo aptitude install ubuntu-fglrx-686

se instalo todo lo necesario, reinicie, y ya todo funciona correctamente.

Los paquetes los obtengo del repositorio de seveas.

De todo esto supongo que no funcionaba por causa de algún resto de la instalación anterior que estaba creando conflicto.

un saludo, gracias a todos, y espero que le pueda servir a alguien más.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Hola, tengo exactamente el mismo problema que tu para mi ATI 9600 XT. Puedes especificar exactamente cuales son los repositorios de seveas. He encontrado por la web varios y quería asegurarme. Los que he encontrado exactamente son estos:

deb http://seveas.theplayboymansion.net/seveas dapper-seveas drivers
deb-src http://seveas.theplayboymansion.net/seveas dapper-seveas drivers

Y luego en otra página, estos:

deb http://seveas.imbrandon.com dapper-seveas drivers
deb-src http://seveas.imbrandon.com dapper-seveas drivers

Gracias de antemano.

+1
0
-1
Imagen de Buldden
+1
0
-1

Hola, pues yo uso el primero de los dos q propones, aun asi son lo mismo pero distintos mirrors.

Concretamente yo tengo estas lineas:

# Seveas
deb http://seveas.theplayboymansion.net/seveas dapper-seveas all
deb-src http://seveas.theplayboymansion.net/seveas dapper-seveas all

que es para usar todos los paquetes del repositorio, no solo los drivers, como tienes tu.

un saludo

+1
0
-1
Imagen de Anónimo
+1
0
-1

¿esos drivers funcionarian en un portatil compaq presario v5000 con tarjet grafica ati radeon express 200m? ¿podrias darme los pasos a seguir, uno a uno? antes de la respuesta, gracias

+1
0
-1
Imagen de Buldden
+1
0
-1

Pues supongo q si funcionaran,

es sencillo, añades las lineas siguientes a tu /etc/apt/source.list

# Seveas
deb http://seveas.theplayboymansion.net/seveas dapper-seveas all
deb-src http://seveas.theplayboymansion.net/seveas dapper-seveas all

¿como lo añades?

pues si usas ubuntu: en consola escribes sudo gedit /etc/soruce.list y los copias/pegas
si usas kubuntu pues igual pero sustituyendo gedit por kate o kwrite.

una vez termines este paso, pues en la misma consola haces:

sudo aptitude update

y luego solo tienes q instalar el paquete correspondiente a los drivers, esto depende de la arquitectura, por ejemplo con un kernel 386 debes instalar ubuntu-fglrx-386 con un 686 pues el mismo paquete pero cambiando 386 por 686.

¿como lo instalas?, pues con este comando en la consola

sudo aptitude install ubuntu-fglrx-386 (si usas 386)

¿como sabes que tipo de kernel usas?, pues facil solo tienes q escribir lo siguiente en una consola:

uname -r

y lo que se encuentre apartir del ultimo guion sera la arquitectura, por ejemplo en mi caso:
uname -r
2.6.15-27-686

por lo q podras ver q tengo 686

bueno si quieres ver todos las arquitecturas q soporta los drivers de este repositorio lo puedes hacer como sigue

sudo aptitude search ubuntu-fglrx

creo q solo estan las siguientes 386, 686 y k7

Bueno una vez lo instales ya estara todo listo (si mal no recuerdo, solo tendras q reiniciar y listo, aun asi si ves que no te funciona deberias probar ha hacer esto en una consola:

sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

y luego reiniciar.

entonces si no te funciona pues es q algo no anda bien.

para saber si esta funcionando haces en una consola

fglrxinfo

y deberias de ver algo parecido a esto:

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9600 Generic
OpenGL version string: 2.0.6011 (8.28.8)

si te aprece MESA en lugar de ATI y RADEON es que no esta funcionando.

bueno espero que te sirva, pq la verdad me he liado un poco intentando explicarte lo mejor q se.

un saludo y suerte.

+1
0
-1
Imagen de Anónimo
+1
0
-1

muchas gracias, ahora mismo no puedo hacerlo, pero en cuanto tenga un hueco lo hare.

¡Muchas gracias!

+1
0
-1
Imagen de Anónimo
+1
0
-1

yo twngo la misma grafica y van . te bajas los drivers de la pag de ati y siigues los pasos que te indican

+1
0
-1
Imagen de cs101
+1
0
-1

Yo tenía aceleración gráfica antes de la actualización a xorg 7.0, pero después la perdí.
Tras muchos esfuerzos e intentos inútiles logré hacerla funcionar con el nuevo driver de ATI 8.29.6

Lo hice adaptando las instrucciones dadas por Jersoncito y Carbinator a la nueva versión del driver (simplemente cambiando los números de versión).

Lo primero es bajar el nuevo driver:
https://www2.ati.com/drivers/linux/ati-driver-installer-8.29.6.run

Instalar las herramientas necesarias.
Desde consola:

sudo apt-get update
sudo apt-get install module-assistant build-essential
sudo apt-get install fakeroot dh-make debconf libstdc++5 gcc-3.3-base

Crear los paqutes .deb asi:

chmod +x ati-driver-installer-8.29.6.run
./ati-driver-installer-8.29.6.run --buildpkg Ubuntu/dapper

Nota: Con la tecla (tab) puede autocompletar el nombre del archivo descargado. Es importante saberlo, puesto que los nombres pueden variar, por version o arquitectura.

Instalar los paquetes .deb

sudo dpkg -i xorg-driver-fglrx_8.29.6-1_i386.deb
sudo dpkg -i fglrx-kernel-source_8.29.6-1_i386.deb
sudo dpkg -i fglrx-control_8.29.6-1_i386.deb

Remover los viejos paquetes:

sudo rm /usr/src/fglrx-kernel*.deb

Nota: Si no encuentra paquetes a limpiar, es porque no los habia.

Compilar Kernel

sudo module-assistant prepare,update
sudo module-assistant build,install fglrx
sudo depmod

Nota: Si después usted actualiza a un nuevo kernel, perdera la aceleración 3D y será necesario repetir esta instalación.

Actualizar el archivo xorg.conf (no hace falta abrirlo, simplemente teclead los siguientes comandos en la consola):

sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

Reiniciar la computadora

Para confirmar la instalacion, abra consola y escriba:

glxgears –iacknowledgethatthistoolisnotabenchmark

Vera una pequeña ventana con engranajes 3D.
Tras de ellos, los valores frames/segundos deberian estar entre 700 y 1000

Luego escribir:

glxinfo

(las primeras líneas deberían decir: “Direct Rendering yes”)

+1
0
-1
Imagen de Anónimo
+1
0
-1

¿Esto funciona también con el nuevo driver de ati 8.31.5?
Acabo de ir a la web de ati a bajarme los drivers, y he visto que hay nueva versión..., por lo que se supone que tendría que ir mejor..., ¿no?

Gracias por el manual, esperaré vuestras respuestas y me pondré manos a la obra para instalar estos drivers... xDDD

Souf

+1
0
-1
Imagen de souf
+1
0
-1

Bueno, lo he intentado instalar, y como lo voy a instalar en una 6.10 (edgy), he puesto esto:

bash ati-driver-installer-8.31.5-x86.x86_64.run --buildpkg Ubuntu/edgy

Pero nada, me da error:

Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.31.5....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: Ubuntu/edgy
[: 182: ==: unexpected operator
./packages/Ubuntu/ati-packager.sh: 182: pushd: not found
Package build failed!
Package build utility output:
dpkg-parsechangelog: error: cannot open debian/changelog to find format: No such file or directory
dpkg-buildpackage: unable to determine source package is
./packages/Ubuntu/ati-packager.sh: 182: popd: not found
Removing temporary directory: fglrx-install

¿Alguien me puede orientar?
Gracias

+1
0
-1
Imagen de PosTi85
+1
0
-1

No entiendo porque os enrevesais tanto con drivers que no se de donde coño vienen. Si teneis una tarjeta superior a 9500 (por poner una cota, no recuerdo a partir de cual funcionaba bien). Basta con pillar los que te trae el propio SO:

$ sudo apt-get update
$ sudo apt-get install linux-restricted-modules-$(uname -r)
$ sudo apt-get install xorg-driver-fglrx
$ sudo depmod -a
$ sudo aticonfig --initial
$ sudo aticonfig --overlay-type=Xv

Reinicia. Comprueba que funciona:

$ glxinfo | grep render
direct rendering: Yes

YA ESTÁ

+1
0
-1
Imagen de Buldden
+1
0
-1

Hola,

me parece que te estas equivocando, ya que yo tengo una ati radeon 9600 series (supongo q superior a la 9500) y el driver que propones (los libres) tiene un rendimiento PESIMO (en mi PC) con respecto al driver que se comenta en el mensaje anterior al tuyo y que son los drivers propietarios de ATI (la empresa fabricante del chip grafico) que aunque no son lo bueno que deberian (vease los drivers de nvidia) son bajo mi punto de vista muchisimo mejores que los libres (cosa que veo normal pq ati no les suministra informacion para desarrollar el driver).

Lo digo con todo respeto y sin intenciones de ofender a nadie.

un saludo.

+1
0
-1
Imagen de PosTi85
+1
0
-1

Buldden, no te preocupes, no me has faltado el respeto :) por lo menos ahora se que los propios de ATI son mejores :), la próxima vez que formatee (si un disco duro con linux tiene tendencia a formatearse, como windows) instalaré esos.

Gracias por tu respuesta ;).

SAlu2

+1
0
-1
Imagen de Buldden
+1
0
-1

Me alegro que el comentario te sirva para algo, esa era la idea, aportar algo de lo poco que se :D

Bueno respecto a lo de formatear, pues por mi experiencia te diria que no, en linux no se tiende al formateado de discos ni a la reinstalación, sino a todo lo contrario, tener un sistema estable en el que solo tienes que preocuparte de actualizar y disfrutar de el, asi que podrias animarte a instalar el driver propietario, si no lo consigues estaré encantado en ayudarte, además de toda esa gente que tiene cien mil howto's sobre el tema.

Curioso mi mensaje duplicado.... :(

un saludo.

+1
0
-1
Imagen de gabiel
+1
0
-1

Hilando un poco más fino, en las tarjetas de ATI con procesador r200 [1] y anteriores, el rendimiento de los libres es más que aceptable [2]. De hecho, las últimas versiones del controlador propietario de ATI no dan soporte a estas tarjetas, y lo dejan "en mano" de los controladores libres.

Saludos.

PD: (cosa que veo normal pq ati no les suministra informacion para desarrollar el driver)
Ahí está el "truco", para los procesadores r200 sí que ofrecieron colaboración.

[1]: Radeon 9200 y cía. si no os situais.
[2]: Mi 9200 se defiende para ejecutar un Quake III con los libres sin problemas; y hablo de la versión incluída con Hoary.

♠ ♣ ♥ ♦
Este comentario puede contener trazas de cacahuetes, almendras y germen de trigo.
[Documentación oficial][Normas del foro]

+1
0
-1
Imagen de Anónimo
+1
0
-1

Hola, tengo una Radeon 9600, y no consigo dar con las actualizaciones de los drivers, me puedes pasar el enlace para poder actualizar la tarjeta.

muchisimas gracias por adelantado, un saludo a todos..

+1
0
-1
Imagen de David C.
+1
0
-1

Para el post anterior decirle que los drivers de la tarjeta los puede encontrar en la web de ATI, creo que www.ati.com

Ahora, comento mi problema, bajé los drivers de ati, los instalé (despues de muchas desaveniencias), glxinfo me dice que uso los drivers de ati, y todo eso, en principio todo bien, hasta que arranco glxgears -printfps, los frames son de 300f/s osea de risa, soy novatisimo, como la mayoría y desanima bastante no poder hacer esto en 5 minutos, sabiendo lo mismo de windows.

Fuy fiel al guión de (metodo 2)
http://wiki.cchtml.com/index.php/Ubuntu_Edgy_Installation_Guide#Method_2...
Pero me atasqué... no entiendo eso de: IMPORTANT: You have to recompile the kernel module after each kernel update!

Que diantres quiere decir!!!

Salud·2

+1
0
-1

Salud*2

Imagen de jess
+1
0
-1

Hola, eso de "You have to recompile the kernel module after each kernel update!" no es mas que el día que actualices tu kernel (si lo actualizas) tendrás que volver a repetir las instrucciones anteriores a dicha nota (siempre es bueno revisar también las fuentes por si hubiera un driver mas actual).

saludos

+1
0
-1