apt-get dist-upgrade

Imagen de herje
0 puntos

Hola estoy corriendo Ubuntu warty y deseo hacer un dist-upgrade de mi distro ya que en principio solo instalé en local desde el cd y posteriormente habilité en el sources.list los diferentes repositorios, incluyendo los "universe".

Tengo corriendo una imagen 2.6.8.1-3-686-smp la cual previamente he holdeado para que no me actualize el kernel al hacer el dist-upgrade.

La pregunta es: ¿Es correcto hacer el dist-upgrade con los repositorios "universe" o me debo limitar a los "restricted"? es decir...¿al hacer un dist-upgrade con los universe, no se estaría entrando en la versión de
desarroyo?

En este momento mi sources.list queda así:

-------------

deb http://archive.ubuntu.com/ubuntu warty main restricted
deb-src http://archive.ubuntu.com/ubuntu warty main restricted

deb http://archive.ubuntu.com/ubuntu warty universe
deb-src http://archive.ubuntu.com/ubuntu warty universe

deb http://security.ubuntu.com/ubuntu warty-security main restricted

deb-src http://security.ubuntu.com/ubuntu warty-security main
restricted

----------------

Gracias

Imagen de Lord_ZealoN
+1
0
-1

El dist-upgrade solo sirve para actualizar de distro.

Lo tendrás que hacer para pasar a hoary.

Para lo que quiers tienes que hacer, primero un update (para refrescar los paquetes desde inet) y luego un upgrade

$ sudo apt-get update
$ sudo apt-get upgrade

Cuando quieras pasar a hoary, entonces tendrás que cambiar en los repositorios la palabra warty por hoary y entonces hacer un update y un dist-upgrade.

Un saludo.
--------------------------------------------
Lord_ZealoN - El predicador
Linux User: #370919
Porqué Ubuntu? Porque yo lo valgo.

+1
0
-1

---
Lord_ZealoN - El predicador | LU:#370919
Guía: http://guia-ubuntu.org/
FAQ: http://www.ubuntu-es.org/book/view/171
How-TO's http://www.ubuntu-es.org/book/view/103

Imagen de entiak
+1
0
-1

El dist-upgrade también sirve para actualizar la distribución, sobretodo cuando paquetes nuevos reemplazan a otros y todo eso ;) (util sobretodo en versiones de desarrollo), vamos que yo siempre utilizo dist-upgrade (ahora que tengo hoary sobretodo, pero vamos que antes también ;) )

--
Saludos,
Juan. (http://blog.entiak.com)

+1
0
-1

--
Saludos,
Juan. (http://blog.entiak.com)
jbaixauli (at) gmail.com