Como instalo archivos .tar.gz, .tar.tgz, .tar

Imagen de davidg
0 puntos

Hola, Tengo varios dias intentando instalar xmms, pero aun no lo he logrado, he seguido las instrucciones q aqui muy bien señalan, pero hasta ahora no me han funcionado, el caso es he intentado instalar el paquete desde terminal, y desde synaptic, pero nada funciona.

Quisiera q por favor me dijeran como instalo un archivo q se encuantra en el dico duro en ubuntu, ya q lo q he leido hasta ahora creo q se refiere a instalarlo desde internet directamente, lo q he hecho es bajarme los paquetes en la oficina y traermelos a mi maquina.

Gracias a todos por la atencion y la ayuda q me puedan brindar...

Atte. El Principiante

Imagen de mz
+1
0
-1

si has bajado un .deb:
$sudo dpkg -i paquete_a_instalar.deb

si es un .tar.gz
$sudo tar -zxvf archivo.tar.gz (esto lo decomprime)
$cd directorio_del_archiv_Descomprimido (entramos)
$less README (o install, o el archivo que haya para ver un poco si requiere algo especial)
y aunque a partir de aqui no es siempre igual, la mayoria son:
$sudo ./configure (si ves algun error, instala lo que de error)
$sudo make (si hay errores aqui y no los abia en el configure, ni idea)
$sudo make install

y ya esta instalado.

que me corrijan si me equivoco en algo

pd: si el arhivo es tar.bz para descomprimir tar -zvjf archivo.tar.bz

+1
0
-1
Imagen de akdmia
+1
0
-1

Hola, solo quiero remarcar algo...

siempre se toma como que tar.gz o tar.bz2 es:
./configure.. make y make install....

si bien en muchos casos esto es cierto... nunca hay que olvidarse
de que el formato tar es un empaquetado.. y bz,bz2 comprimen...
es decir.. dentro de un tar.gz puede haber desde fotos de mujeres desnudas
hasta codigo fuente de un programa...

la idea de remarcar esto, es porque ya varias veces me tope con foros de gente diciendo
que ponia ./configure.. "command not found".. y resultaba que el programa que estaba intentando
compilar, ya venia compilado.. y solo bastaba ejecutar con el binario..

bueno.. a esto quiero llegar.. un tar.gz no se instala.. (un .zip tampoco).. es el contenido lo que puede
ser instalable, compilable.. o hasta ser simplemente archivos de video.....
por eso cuando nos bajamos un archivo de estos.. lo mejor es descomprimirlo y ver que hay dentro.. y en base a lo que encontremos vemos como seguimos.

una cosita.. tar -z... (y el x ?? )
yo descomprimo asi:
tar xfz archivo.tar.gz
tar xfj archivo.tar.bz2

x = descomprimir..
z = formato gz
j = formato bz2
f = para q use un archivo
v = para q muestre el proceso (no es necesario)

+1
0
-1
Imagen de Cristobal López
+1
0
-1

Para instalarlo con esos tres pasos es mejor así:
./configure
make
sudo make install
Para no crear ficheros basura que luego no se pueden borrar si no es con la herramienta mc
Y para desinstalarlo poner sudo make uninstall
Un saludo

http://tobalin-cristobal.blogspot.com/

+1
0
-1
Imagen de davidg
+1
0
-1

Hola Akdmia, Gracias por tu respuesta, pero a que te refieres con q solo falta ejecutar con el binario??????

+1
0
-1

El Principiante

Imagen de akdmia
+1
0
-1

Me refiero a que un tar.gz es un archivo comprimido.. (asi como .zip y .rar)
y quizas dentro de ese tar.gz, el programa ya este compilado.. (cosa que aveces pasa)

configure es un archivo para configurar lo que luego se instalara.
el comando "make" compila fuentes.
el comando "make install" mueve los archivos compilados al directorio de instalacion

es decir.. hacer:
------------
./configure
make
make install
-------------
significa que estas compilando el codigo fuente de un programa, y una vez compilado se crean los archivos binarios a los cuales le haces 2 click para q el programa levante.
pero si el programa ya esta compilado no existira el "configure"

+1
0
-1
Imagen de wataru
+1
0
-1

Hola.

Me parece todo muy bonito, y lo explicais tan bien.... pero tengo una pregunta:

Al descargar el archivo "XXX.tar.gz" de una web o lo que sea. Donde lo guardo??? como le digo a la consola donde esta el archivo?? es que aqui decis como se instala y descomprime pero no me sale. Supongo porque no le especifico donde esta el archivo.

Ayuda por favor. 

+1
0
-1
Imagen de otakuyose
+1
0
-1

buenas tardes, gracias por responder. He esado leyendo las respuestas y en algo me han ayudado, por lo mens ya he descomprimido y ya entendi que todo zip o tar no necesariamente se instala mira mi problema es el siguiente. tengo un hp dv2000 con ubuntu 10.10 todo va bien pero no reconoce el wifi mi tarjeta es una broadcom bueno leyendo y leyendo vi q se podia hacer usando el shell o consola y yo la verdad se poquisimo consola solo recuerdo dos de windows y esooo en fin segun esto: http://www.taringa.net/posts/linux/7944982/Solucion-al-problema-de-BROAD... indica pasos y de manera grafica y facil la nstalacion pero yo me quedo en elprimer paso donde dice que debo entrar a Centro de software de Ubuntu . Una vez ahí tenemos un buscador arriba a la derecha, escribimos Ndiswrapper pero cuando le doy instalar da error de descarga, bueno el punto es que como vi los detalles del error me dice que no se conecta no se por que si yo estoynavegando bien, pero en detalles me dice los archivos que no bajaron osea ninguno, son tres: dos son .deb que ya los instale y el ultimo es el .tar.gz bueno los busque en internet y los baje de la pagina de ubuntu este es el que no instalo aun: ndisgtk-0.8.5.tar.gz bueno segun leo en el post descomprimes y luego make istall pero ya descomprimi y no encuentro nada instalable dentro de la carpeta: le di el comando ls como pides y sale esto:

yose@IOM-HP:~/ndisgtk-0.8.5$ ls
Makefile ndisgtk.desktop.in ndisgtk-kde.desktop.in NEWS
ndisgtk ndisgtk-error.png ndisgtk.png po
ndisgtk.8 ndisgtk.glade ndisgtk.xpm
yose@IOM-HP:~/ndisgtk-0.8.5$

por mi poca experiencia se que ninguna de esos es un ejecutable o instalable por eso cuando le doy configure o install no funciona. asumo q esa carpeta no se instala solo se mueve a algun lugar q no se donde es... te pediria por favor que me ayudes.

saludos

+1
0
-1
Imagen de pototolinux
+1
0
-1

Yo uso Macbuntu y realizo la descompresion con la terminal y despues me aparece una carpeta con un candado, con el mismo nombre del archivo que descomprimi, y en la terminal no puedo cambiarme a ese directorio...que pueo hacer ?

+1
0
-1
Imagen de Bloodsucker
+1
0
-1

xmms está en los repositorios.
Ves a Synpatic y ahí lo pod?as instalar... Echa un vistazo a www.guia-ubuntu.org/dapper

suerte!

Mas dudas sobre linux?, preguntamelas en mi blog ---> http://bloodblog.coconia.net/

+1
0
-1

 

 

--- Mi Blog: http://bloodblog.coconia.net/

Imagen de davidg
+1
0
-1

Hola, saludos a todos, quiero agradecerles por toda la informacion q muy rapidamente me prestaron, la verdad son muy buenos y rapidos respondiendo a las enormes dudas de nosotros los q estamos comenzando con ubuntu.

Gracias a la informacion q me facilitaron, pude por lo menos descomprimir el archivo del xmms, el cual por cieto, solo tiene en su extension ".tar" y no ".tar.gz" como creo q deberia ser. Luego de descomprimir el archivo ".tar" me voy a mi carpeta personal q es donde se encuentra el archivo, y al abrir la carpeta q acabo de descomprimir los archivos q c encuentran dentro de esta aparecen con un candado en la parte superior derecha de cada emblema, de todas maneras procedo a ejecutar el "./configure" y me dice "command not found", por favor ayudenme a terminar con la instalacion del xmms, no me voy a dar por vencido y no voy a desencantarme de ubuntu, Gracias...

P.D: Que es eso de ejecutar con el binario???

+1
0
-1

El Principiante

Imagen de mz
+1
0
-1

el make y make install no llevan ./

pero aun asi mejor te lees el readme o install q venga adjunto, ahi dicen como instalarlo.

+1
0
-1
Imagen de davidg
+1
0
-1

De verdad son muy rapidos respondiendo..., gracias, pero igual me dice "command not found" es cuando ejecuto el "./configure", y segun lo que he leido debo cocarlo irremediablemente antes del make y del make install, o acaso hay otra forma?

+1
0
-1

El Principiante

Imagen de akdmia
+1
0
-1

Es exactamente lo q comento en mi post de mas abajo...

tar.gz es un simple archivo comprimido..
./configure:
./ significa es el directorio.. y configure el archivo..
cuando ejecutas eso, lo que estas haciendo es ejecutar un archivo llamado "configure" en el directorio actual..
si te dice "command not found" es porq ese archivo no existe.
entonces pueden pasar 3 cosas..
1_ no estas parado en el directorio donde descomprimiste el tar.gz..
$pwd (te dice donde estas parado)

2_ las fuentes q bajaste no tienen un archivo configure:
$ls (veras la lista de archivos)

3_ lo que bajaste no es codigo fuente.

tira un ls en la carpeta y veamos que tienes..

+1
0
-1
Imagen de davidg
+1
0
-1

Probare lo q me acabas d comentar, de verdad muchas gracias por tu tiempo y tu ayuda...

Ahhhh por cierto tienes correo? si tienes gmail agregame Davidgxxl@gmail.com...

Despues q pruebe esta ultima indicacion q acabas de darme te escribo...

+1
0
-1

El Principiante

Imagen de akdmia
+1
0
-1

Imagen de cosarara97
+1
0
-1

Bueno, primero instalas las dependencias. También debes tener instalado el paquete build-essentials.

Luego:
1 Coges el *.tar/*.tar.gz/*.tar.bz2 o lo que sea
2 Lo descomprimes en alguna carpeta
3 Abres la carpeta
4 Haces click derecho (dentro de la carpeta) y le das a "abrir en un terminal". Lo importante es que en el terminal estés dentro de la carpeta del codigo fuente.
5 dentro del terminal:
./configure
make
sudo make install

Puedes probarlo sin el configure, pero lo mas probable es que te de error.

Dew!

+1
0
-1
Imagen de Cristobal López
+1
0
-1

Bien, lo primero es saber si te lo has bajado de aquí http://www.xmms.org/download.php y ¿el fichero se llama xmms-1.2.10.tar.gz? Espero que lo hayas bajado de aquí porque es la web oficial de xmms.
Lo segundo son las dependencias (lo que pone como requirements en la web de xmms), antes de instalar xmms debes instalar los paquetes de los que depende, en este caso son:

* ALSA output: ALSA 0.9.0 or better.
* Esound output: esound 0.2.8 or better.
* Mikmod input: libmikmod 3.1.10
* Ogg Vorbis input: libvorbis
* OpenGL Visual plugin: Mesa 3.0 or better.

Supongo que los tendrás ya casi todos instalados, si acaso puede faltarte el mesa, pero si pones tu cd de ubuntu en el ordenador donde quieres instalar xmms y le dices que lo añada a los repositorios, seguramente podrás instalar el mesa y los otros desde synaptic.
Una vez tengas las dependencias instaladas lo que has de hacer es poner (según el readme del tar que te has bajado):

cd xmms-1.2.10
./configure
make
sudo make install

Y de esa manera ya lo tendrás instalado.
Un saludo :smile:

http://tobalin-cristobal.blogspot.com/

+1
0
-1
Imagen de davidg
+1
0
-1

Muchas Gracias por tu ayuda, he bajado el xmms desde donde me indicas y ahora creo q si voy a poder terminar la instalacion, solo me queda una pregunta: las librerias o dependecias, se instalan con los mismos comandos (./configure, make,... etc)?

Espero tu respuesta,...Gracias.

+1
0
-1

El Principiante

Imagen de cosarara97
+1
0
-1

Si descargas las dependencias en tar's tambien deberías poder instalarlas con esos comandos, pero lo mas seguro es que estén en synaptic.

+1
0
-1
Imagen de Anónimo
+1
0
-1

llego hasta ./configure
y me sale este error:
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details

¿que hago?

+1
0
-1
Imagen de kelp
+1
0
-1

Fíjate donde publicas tus dudas, la cafetería no es para ello.


Equipo de moderadores del foro
+1
0
-1

Las tres cosas más peligrosas del mundo son: un programador con un soldador, un ingeniero de hardware con un parche de software y un usuario con una idea

Imagen de Rodr
+1
0
-1

Cuando se empieza a trabajar con el gestor de paquetes Synaptic , a veces se complica un poco poder descargar programas, pero otra de las opciones que te ofrece ubuntu, es en Aplicaciones- Añadir y quitar. En esta aplicacion podras encontrar tambien una lista de programas muy extensa, en donde se presentan una serie de iconos que identifican al programa, y en mi opinión es mejor empezar a trabajar con esta aplicacion antes de pasar al gestor de paquetes Synaptic.

+1
0
-1
Imagen de peketravieso
+1
0
-1

Señores con todo respewto y a leguas se nota que son unos expertos en todo lo que es linux y derivados pero aun no encuentro una persona que me diga como instalar eseos archivos cuando se usa windows

+1
0
-1
Imagen de jesus751990
+1
0
-1

Lo he intentado varias veces pero no me sale

root@jesus-laptop:/home/jesus# sudo tar xfz sunbird-0.9.es-ES.linux-i686.tar.gz
tar: sunbird-0.9.es-ES.linux-i686.tar.gz: No se puede open: No existe el fichero ó directorio
tar: El error no es recuperable: salida ahora
tar: Child returned status 2
tar: Salida con error demorada desde errores anteriores

jesus@jesus-laptop:~$ sudo tar -zxvf sunbird-0.9.es-ES.linux-i686.tar.gz
tar: sunbird-0.9.es-ES.linux-i686.tar.gz: No se puede open: No existe el fichero ó directorio
tar: El error no es recuperable: salida ahora
tar: Child returned status 2
tar: Salida con error demorada desde errores anteriores

root@jesus-laptop:/home/jesus# sudo tar -zxvf sunbird-0.9.es-ES.linux-i686.tar.gz
tar: sunbird-0.9.es-ES.linux-i686.tar.gz: No se puede open: No existe el fichero ó directorio
tar: El error no es recuperable: salida ahora
tar: Child returned status 2
tar: Salida con error demorada desde errores anteriores

nada que soy incapaz, podeis ayurdame

+1
0
-1
Imagen de locomania
+1
0
-1

yo tambien tengo problemas y es que cuando lo descomprimo y le doy .\configure me dice que phyton interpreter not found o algo asi... que es lo que me esta pidiendo que instale?????

+1
0
-1
Imagen de locomania
+1
0
-1

perdon por el doble post crei que no se habia mandado....

+1
0
-1
Imagen de victormga25
+1
0
-1

hola!!!
necesito ayuda!!!

Necesito trabajar con un programa que se llama Grass GIS, aparece en la listade Synaptic, le digo que lo quiero instalar, descarga algunas cosas pero como tal no encuentro la aplicacion por ningun lado, ya la descargue e intente hacerlo como dices pero tampoco me funciono, espero que me puedas ayudar lo necesito para hacer un trabajo.

De antemano muchas gracias!!!

+1
0
-1

VMGA

Imagen de ubuntero novato
+1
0
-1

Hola soy un novato en ubuntu que quiere huir del imperio microsoft.Mi problema es que hay programas de Ubuntu como xvideoservicethief que no estan ni en el centro de software ni aparecen en synaptic (este mu compliao) y me los descargo de la red.Claro aqui no hay exe y no los puedo ejecutar.Este en cuestion en un install.sh.Ayudenme si sigo asi tendré que volver a any video converter masstube acatcher(youtube-dl es lentisimo,ffmpeg no convierte nada con el winff...)en fin en sus manos estoy

+1
0
-1
Imagen de TOTO_THE_KING_OF_WARCRAFT
+1
0
-1

hellooo soy muy nuevo en esto del linux y me
ayudaria mucho saber donde puedo encontrar
ayuda sobre el linux brlix no encuentro en ningun
lugar una ayuda sobre eso
poque cuando hago apt-get me dice imposible encontrar paquete del & el archivo que yo busque&

ahh y por si acaso no hay un programa que baje todas las dependencias

POR FAVOR QUE ALGUIEN ME AYUDE PLEASEEE

saludos
por cierto muy buen foro

+1
0
-1
Imagen de danielcaraj
+1
0
-1

A los tres comentarios de arriba... Lean las normas del foro. no invadan otros posts con sus consultas.

+1
0
-1

---------------------------------------------------------------------------------------------------------------------
Linux User#535363
Normas del foro

Imagen de danielcaraj
+1
0
-1

En Launchpad podés encontrar PPA de Audacious, es muy parecido a xmms.

+1
0
-1

---------------------------------------------------------------------------------------------------------------------
Linux User#535363
Normas del foro

Imagen de DARUTIK
+1
0
-1

Hola, quero decir que si los que hacen la aplicaciones para linux tuviesen que instalar sus programas, y se encuentran conque tienen que compilar tal o cual, estarian hartos. Como dice el titulo, Con lo facil que es un Deb...
Parece que para instalar estos tar.gz o otros parecidos halla que sacarse un master.
Si alguien hiciese algun sitio donde se ubiesen molestado en transformar los .tar en .Deb seria un crack, porque nadie a tenido ganasen todo el universo Linux.
Espero encontrar la solucion a los .tar...

+1
0
-1
Imagen de danielcaraj
+1
0
-1

Desgraciadamente como el trabajo de compilar el código y o crear un .deb la mayoría de las veces lo hacen voluntarios a los que nadie les paga por hacerlo, es probable que no hallan debs para todo, dado también que no todas las distros Linux usan ese tipo de empaquetado (fedora por ejemplo). Fijate en mi otro comentario sobre agregar un PPA, a falta de lo que necesitas quizás hay algo parecido.

Una web donde hay paquetes listos para instalar es getdeb

+1
0
-1

---------------------------------------------------------------------------------------------------------------------
Linux User#535363
Normas del foro

Imagen de DARUTIK
+1
0
-1

Al fin un sitio solo con .Debs....
Era frustante encontrar ese programa que necesitabas y descubrir que esta en .Tar, y no saber que hacer.
El que hizo los .Debs se fijo en una de las pocas virtudes de Windows, los instaladores.

Gracias por el aporte, adios

+1
0
-1