ATI M11 NV [FireGL Mobility T2e] (rev 80) y ubuntu edgy

Imagen de cleto
0 puntos

Hola a todos!

Llevo un tiempo (bastante) liado con este tema. Se trata de poder tener aceleración 3D con la dichosa tarjeta que trae mi blanquito: ATI M11 NV [FireGL Mobility T2e] (rev 80). No sé qué hacer. He consultado por ahí y me ha creado más confusión aún.

El caso es que utilizando el driver "ati", glxinfo dice que tengo aceleración. Sin embargo, el glxgears me da unas super tasas de 23 fps. Tan mala es la tarjeta? :-)

¿Alguien tiene el mismo problema?

Un saludo!

Pd: dejo mi dirección de msn (el_cleto@hotmail.com) por aquello de la lista de usuarios de ubuntu y PPC :-).

Imagen de rbertran
+1
0
-1

Hola,

tengo la misma tarjeta en un iBook G4. Con glxgears me salen 1400 fps. Asi que supongo que el problema es de tu configuracion.

Aqui esta mi configuracion xorg :

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
#FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "glx"
Load "dri"
Load "freetype"
Load "type1"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "int10"
Load "vbe"
Load "extmod"
Load "synaptics"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

#Section "InputDevice"
# Identifier "Synaptics Touchpad"
# Driver "synaptics"
# Option "SendCoreEvents" "true"
# Option "Device" "/dev/psaux"
# Option "Protocol" "auto-dev"
# Option "HorizScrollDelta" "0"
# Option "MinSpeed" "1"
# Option "MaxSpeed" "1.4"
# Option "AccelFactor" "0.1"
# Option "TabButton1" "1"
# Option "FingerHigh" "35"
# Option "FingerLow" "25"
# Option "SHMConfig" "true"
#EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
# Option "Device" "/dev/input/mice"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "LeftEdge" "0"
Option "RightEdge" "850"
Option "TopEdge" "0"
Option "BottomEdge" "645"
Option "MinSpeed" "0.4"
Option "MaxSpeed" "1"
Option "AccelFactor" "0.03"
Option "FingerLow" "55"
Option "FingerHigh" "60"
Option "MaxTapMove" "20"
Option "MaxTapTime" "60"
Option "MaxDoubleTapTime" "100"
Option "TapButton1" "0"
Option "TapButton2" "3"
Option "TabButton3" "2"
Option "HorizScrollDelta" "10"
Option "VertScrollDelta" "30"
Option "SHMConfig" "on"
Option "VertTwoFingerScroll" "true"
EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "stylus"
# Option "Device" "/dev/wacom" # Change to
# # /dev/input/event
# # for USB
# Option "Type" "stylus"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection
#
#Section "InputDevice"
# Driver "wacom"
# Identifier "eraser"
# Option "Device" "/dev/wacom" # Change to
# # /dev/input/event
# # for USB
# Option "Type" "eraser"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection
#
#Section "InputDevice"
# Driver "wacom"
# Identifier "cursor"
# Option "Device" "/dev/wacom" # Change to
# # /dev/input/event
# # for USB
# Option "Type" "cursor"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

Section "Device"
Identifier "ATI Technologies, Inc. M11 NV [FireGL Mobility T2e]"
Driver "radeon"
VendorName "ATI Technologies Inc"
BoardName "M11 NV [FireGL Mobility T2e]"
BusID "PCI:0:16:0"
### Available Driver options are:-
### Values: : integer, : float, : "True"/"False",
### : "String", : " Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # []
#Option "SWcursor" # []
#Option "Dac6Bit" # []
#Option "Dac8Bit" # []
#Option "BusType" # []
#Option "CPPIOMode" # []
#Option "CPusecTimeout" #
Option "AGPMode" "4"
Option "AGPFastWrite" "true"
Option "AGPSize" "32" #
#Option "GARTSize" #
#Option "RingSize" "8"
#Option "BufferSize" "10"
Option "EnableDepthMoves" "true"
Option "EnablePageFlip" "true"
## meu
Option "BackingStore" "true"
## fi meu
#Option "NoBackBuffer" "false"
#Option "DMAForXv" # []
#Option "FBTexPercent" #
#Option "DepthBits" #
#Option "AccelDFS" # []
#Option "PanelOff" # []
#Option "DDCMode" # []
#Option "MonitorLayout" # []
#Option "IgnoreEDID" # []
Option "UseFBDev" "false"
#Option "MergedFB" # []
#Option "CRT2HSync" # []
#Option "CRT2VRefresh" # []
#Option "CRT2Position" "Clone"
#Option "CRT2Position" "Above"
#Option "CRT2Position" "LeftOf"
#Option "MetaModes" # []
#Option "MergedDPI" # []
#Option "MergedXinerama" # []
#Option "MergedXineramaCRT2IsScreen0" # []
#Option "MergedNonRectangular" # []
#Option "MergedMouseRestriction" # []
#Option "DisplayPriority" # []
#Option "PanelSize" # []
#Option "ForceMinDotClock" #
Option "ColorTiling" "true"
#Option "VideoKey" #
#Option "RageTheatreCrystal" #
#Option "RageTheatreTunerPort" #
#Option "RageTheatreCompositePort" #
#Option "RageTheatreSVideoPort" #
#Option "TunerType" #
#Option "RageTheatreMicrocPath" #
#Option "RageTheatreMicrocType" #
Option "RenderAccel" "true"
#Option "SubPixelOrder" # []
#Option "ShowCache" # []
Option "DynamicClocks" "true"
#Option "BIOSHotkeys" # []
#Option "VGAAccess" # []
#Option "ReverseDDC" # []
#Option "LVDSProbePLL" # []
#Option "AccelMethod" "EXA" # XAA is the default
#Option "ConstantDPI" # []

#Com ho tenia abans
#
#Option "CRT2Position" "Above"
#Option "RenderAccel" "true"
#Option "BackingStore" "true"
#Option "EnablePageFlip" "true"
#Option "AGPMode" "4"
#Option "AGPFastWrite" "true"
#Option "UseFBDev" "false"
#Option "UseFB" "false"
#Option "EnableDepthMoves" "true"
#Option "ColorTiling" "true"
#Option "DynamicClocks" "on"

# Mes options
#Option "XaaNoScanlineImageWriteRect" "true"
#Option "XaaNoScanlineCPUToScreenColorExpandFill" "true"
Option "XAANoOffscreenPixmaps" "true"
Option "AddARGBGLXVisuals" "true"
Option "DisableGLXRootClipping" "true"
Option "AllowGLXWithComposite" "true"
Option "DRI" "true"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. M11 NV [FireGL Mobility T2e]"
Monitor "Generic Monitor"
DefaultDepth 24
#Option "AddARGBGLXVisuals" "true"
#Option "DisableGLXRootClipping" "true"
SubSection "Display"
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
Option "AIGLX" "true"
EndSection

Section "DRI"
Mode 0666
# Group "video"
EndSection

Section "Extensions"
Option "Composite" "Enable"
# Option "RENDER" "true"
# Option "DAMAGE" "true"
EndSection

En cualquier caso, no he conseguido hacer funcionar correctamente Beryl o Compiz. El soporte para esta tarjeta es experimental creo. Si lo intentas i te sales con la tuya me me lo dices ;).

Salut!

PD: Por cierto, si esta configuracion tampoco te da buenos resultados sigue los pasos en esta pagina:

https://listas.hispalinux.es/pipermail/linux-ppc-es/2006-September/00091...

+1
0
-1
Imagen de inmolatus
+1
0
-1

Que suerte que tienes aceleración para esa tarjeta... a ver si se consigue aceleración para otras ATIs, todavía no conozco a nadie que tenga acelaración en una x1800 ....

-------------------------------------------------------------------

Imaging all the people sharing all the source

+1
0
-1

 

-------------------------------------------------------------------

Imaging all the people sharing all the source