app32 en ubuntu64

Imagen de amarques74
0 puntos

HOLA tengo un amd 64 y le instale la versión para 64 bits. Mi pregunta es si puedo funcionar perfectamente con programas de 32 bits. Si no es dificil instalar estos programas pues hay muchos casos que no existe versión alguna para programas de 64. En caso de que se pueda podria utilizar los progrmas del cd de 32 bits??? por q no tengo internet en casa y es mucho mas comodo que andar todo el día con el pen-drive.

Me explique????

Imagen de paio
+1
0
-1

Lamentablemente los programas de 32 bits no corren en Ubuntu de 64 bits, por lo que te quedas restringido a los programas de 64 bits. Yo tambien tengo el mismo caso, y hasta ahora he conseguido todo lo que necesito para tener la maquina como quiero.8)

Salu2.-

Nuestras decisiones son quienes hablan por nosotros

+1
0
-1
Imagen de gabiel
+1
0
-1

No exáctamente, un programa compilado para x86 sí funciona en amd64 sin problemas. Ahora bien, todas las librerías que use deben estar compiladas para x86 [1]. Los casos en los cuales no existen versiones compiladas para amd64 suelen ser de aplicaciones propietarias; así que si solo trabajas con software libre no tendrás problemas. Puesto que la única condición es que estén presentes las versiones compiladas para x86 de las librerías que se usen, muchas distribuciones las incluyen por defecto (ej: SuSE, verás que ejecuta aplicaciones de 32 y 64 de forma transparente); pero no es el caso de Ubuntu (por ahora), así que tienes que hacer la instalación de esas librerías por tu cuenta (mediante chroot, o instalando solo las necesarias para una aplicación conreta, por ejemplo para tener un navegador de 32 bits y usar el plugin de flash).

Saludos.

[1]: Lo mismo ocurre en el caso contrario, una aplicación compilada para amd64 solo puede hacer uso de librerías compiladas para amd64. Por este motivo no puedes usar el plugin de flash (x86) en un navegador compilado para amd64.

♠ ♣ ♥ ♦
Este comentario puede contener trazas de cacahuetes, almendras y germen de trigo.
[Documentación oficial][Normas del foro]

+1
0
-1
Imagen de Anónimo
+1
0
-1

Has probado a instalar tomcat en el amd a 64 te funciono???

+1
0
-1
Imagen de paio
+1
0
-1

Y todo me funciona sin problemas. Ademas el tomcat esta escrito en java y responde al jdk o jre que tengas instalado.

Suerte!!

Nuestras decisiones son quienes hablan por nosotros

+1
0
-1