Como Actualizar Firefox De Una Forma Sencilla

+1
0
-1

Para actualizar firefox de una manera sencilla lo primero es bajarse la última versión, la versión 2.0 ya esta disponible en su página oficial, que es esta:

http://www.mozilla-europe.org/es/products/firefox/

Yo la he instalado con éste método que explico (que es una reunión de otros métodos de distintos foros) y me funciona. Cuando ya la tengáis bajada abrís terminal y tecleais:

sudo file-roller

Con esto se os abrirá el descompresor file-roller pero con permisos de root. Ahora presionamos en el botón Abrir y buscamos dónde tenemos el firefox que nos hemos bajado, cuando ya lo tengamos presionamos en el botón Estraer y le decimos que lo queremos extraer en la carpeta opt y presionamos en Extraer, aquí tenéis un pantallazo para vuestra ayuda:

http://img222.imageshack.us/img222/8100/pantallazo1rl1.png

Con esto os lo descomprimirá en la carpeta /opt, con esto ya lo tenéis instalado, para conservar la configuración del firefox que teníamos, abrir terminal y teclear

cd /opt/firefox/plugins/
sudo ln -s /usr/lib/mozilla-firefox/plugins/* .

Para finalizar abrimos el Editor de Menús Alacarte, buscamos el firefox lo señalamos con el ratón, le damos al botón dcho. del mouse, nos aparecerá un menú, clickamos en Propiedades y en Examinar buscamos firefox en /opt, aquí tenéis otro pantallazo:

http://img89.imageshack.us/img89/7581/pantallazo2zu3.png

Y ya lo tenéis instalado. Para instalar una nueva versión basta que descomprimáis la nueva versión en la carpeta /opt como hemos hecho al principio ( es decir, con la orden sudo file-roller).

Saludotes :smile:

Comentarios

Imagen de extremss

Excelente.
Todo perfecto, sin problemas y muy rapido.

Imagen de MegaUbuntu

No me podia esperar 2 semanitas para que salga la version final y lo instale, funciona mucho mas rapido la version 2.0 que la 1.5
Muchas gracias por la info colega !!!

Ubuntu user

Imagen de juanbta2000

despues de hacer todo lo que se comenta, no me funciona. Voy a comprobar la version de firefox y me sigue poniendo que tengo la version 1.5 He seguido todos los pasos al pie de la letra. Que puede pasar?

Imagen de Anónimo

A mi tampoco me cambia la version, sigue diciendo 1.5

Imagen de Anónimo

Y cuando reinicie mi maquina, funciono...

Imagen de randu

Parece que si me funciono les escribo desde el firefox 2

Ing. Randu, Powered by Linux
http://del.icio.us/randu2005
http://www.flickr.com/photos/randu2005

 

 

------------------------------------

Ing. Randu2005, Powered by Linux

http://del.icio.us/randu2005

http://www.flickr.com/photos/randu2005

http://lamentehueca.blogspot.com

Imagen de PedroLuis

Gracias por la informacion. Ademas baje Flashplayer9 en /opt, pero no se como hacer para que me funcione con Mozilla-Firefox 2, ya que cuando navego, me sale una rubrica diciendo
"Additional plugins are required to display all the media on this page"
Encontre aqui que habia que poner lo siguiente para activar el Player pero al ejecutar en la console estos comandos que pongo abajo, sale que no son un directorio.

sudo cp libflashplayer.so /usr/lib/firefox/plugins/
sudo cp libflashplayer.so /usr/lib/mozilla-firefox/plugins/
sudo cp libflashplayer.so /usr/lib/mozilla/plugins/

Si pueden darme una mano estaria muy agradecido.

Saludos de pedroluis.
--------------------------------------------------------------
Recuerda que cualquier momento es bueno para comenzar y que ninguno es tan terrible para claudicar.

Saludos de pedroluis. ;)

--------------------------------------------------------------------------------------------------------

"Free Software Free Society"

Imagen de Cristobal López

Para el flash player instala automatix2 y con él podrás instalar el flash, mira aquí http://www.ubuntu-es.org/index.php?q=node/27220
Saludos

Mi blog-> http://tobalin-cristobal.blogspot.com/

Imagen de Anónimo

otra opción es ponerlo en el directorio que el programa te crea en tu $HOME. Primero busca en /usr/lib para eliminar la version antigua del flash si aun corre por ahi:

find /usr/lib -name libflashplayer.so

si te sale alguna la borras y si no pasas directamente a copiar el archivo libflashplayer.so de la nueva version en el directorio ~/.mozilla/plugins/

para comprobar que has actualizado correctamente pon el la barra del navegador:

about:plugins

Imagen de crouk

Aki os habla un novato del ubuntu. Uso mucho estos foros para actualizar e instalar cosas en ubuntu. Yo tb quise instalar el firefox 2.0 , asi que segui tus instrucciones , pero mi problema viene cuando en alacarte intento buscar el firefox. Todos los pasos anteriores me funcionan pero a mi no me descomprime "firefox" dentro de la carpeta /opt/firefox/ . Al hacer un ls me sale lo siguiente:

root@crouk-ubuntu:/opt/firefox# ls -l
total 36
drwxr-xr-x 3 root root 4096 2006-10-11 20:06 chrome
drwxr-xr-x 2 root root 4096 2006-10-11 08:57 components
drwxr-xr-x 5 root root 4096 2006-10-11 20:06 defaults
drwxr-xr-x 5 root root 4096 2006-10-11 08:57 extensions
drwxr-xr-x 2 root root 4096 2006-10-11 08:57 greprefs
drwxr-xr-x 2 root root 4096 2006-10-11 08:57 icons
drwxr-xr-x 2 root root 4096 2006-10-11 08:57 plugins
drwxr-xr-x 6 root root 4096 2006-10-11 08:57 res
drwxr-xr-x 2 root root 4096 2006-10-11 20:06 searchplugins

Por tanto, no se que directorio colocarle en Alacarte, o lo que he hecho mal... Una Ayudita??? Gracias

-- Cr0uk! --

Imagen de jesusbonillo

Mil gracias, ya empezaba a desesperar, pero ¡por fin! todo ok

by LaMaxky de jesusbonillo

by LaMaxky de jesusbonillo

Imagen de Anónimo

¿¿¿qué es eso de carpeta???

Directorio, por favor... seamos conscientes de lo que decimos ;)

:wq

Imagen de Anónimo

¿? pues no se tú, pero a mí me aparecen carpetas como icono de cada directorio. Vamos que, al menos, són análogos. No desespere Ud. Oiga! :>

Imagen de Anónimo

Muchísimas gracias por la ayuda. Yo también lo acabo de instalar.
Por cierto, la version 2.0 de firefox para linux, ¿está solo en inglés o es que yo me lo he bajado así sin darme cuenta?

Un saludo a todos,

Pedrin.

Imagen de Cristobal López

El enlace que he puesto para descargarlo es un enlace expresamente para tenerlo en español.
Saludos

MiBlog
MiWeb

Imagen de juanperez840

NACEMOS SIN SABER NADA Y MORIMOS APRENDIENDO....

NACEMOS SIN SABER NADA Y MORIMOS APRENDIENDO....

Imagen de gusm

mi ignorancia en linux...lo que tengo que superar...al hacer todo y querer bajar el opt , me sale...no tienes permisos del root....que hago...gracias

Imagen de gusm

mi ignorancia en linux...lo que tengo que superar...al hacer todo y querer bajar el opt , me sale...no tienes permisos del root....que hago...gracias

Imagen de hermess

hola soy muy novato en ubuntu y vengo de usar firefox 2.0.0.0 en win$ ahora que me mudé encontré tu guía para pasarme a 2, pero a 2.0.0.1 que es la versión que está disponible, al instalar mi tema favorito smoke me pasa que no llega a verisón 2.0.0.1 sino hasta la 2 y por mas que busco algo que me guste no lo encuentro y mientras así que en lo que se arregla eso me gustaría regresar a 1.5 que es la que viene presinstalada, solo que ahora no sé ni que hacer, no encuentro una guía para poder desistalar desde terminal, gracias.

Imagen de Cristobal López

No hace falta que desinstales nada porque el ubuntu 1.5 lo sigues teniendo en el pc, basta que marques el icono de firefox, le des a Propiedades y cambies la ruta de /opt/firefox a la ruta donde tienes el firefox 1.5
De todas formas puedes esperar, yo hoy he recibido una actualización del tema Alumuinium
Saludos

MiBlog
MiWeb

Imagen de Anónimo

Hola, aquí otro novato (novatísimo) más. He seguido los pasos sin nigún problema, pero a la hora de abrir el Alacarte, no encuentro a éste por ningún lado. ¿Alguna sugerencia? Muchas gracias!!!!

Imagen de Cristobal López

Alacarte viene instalado por defecto en Ubuntu gnome en Aplicaciones->Accesorios->Editor de menús Alacarte
También puedes crear un lanzador, tienes una ayuda en mi post "Cómo Crear Un Lanzador" en mi bitácora de ubuntu-es.
Si estás en KDE será muy parecido a como se hace en windows.
Saludos

MiBlog
MiWeb

Imagen de albis

Hola a todos los miembros de la comunidad de Ubuntu.
Agradezco a Cristóbal López por publicar esta forma tan fácil de Actualizar Firefox. Funciono tal y como lo explicaste. Soy de Venezuela y me ha costado mucho encontrar una distribución lo suficientemente estable, como para no cambiarla después de varios meses de uso. Espero que la búsqueda haya terminado
Muchas Gracias..

Imagen de Anónimo

Pues e encontrado en esta pagina una forma mas sencilla de hacerlo:

http://everythingelse.wordpress.com/2006/07/15/howto-install-firefox-20-...

El problema que tenia con tu forma era que yo tenia versines mas actuales de algunas librerias, dando fallo al pedir otras mas antiguas ¿? Expliquenme esto.

Pero todabia no e conseguido arreglar que el firefox no se me cierre solo (creo que es por problemas con Javascript)

Saludos ( De todas formas te lo has currado, es que a lo mejor yo soy un poquito inutil :s )

Imagen de Cristobal López

No te había leido antes, pero bueno ese script hace lo mismo que lo que pongo yo en el tuto más las órdenes

sudo dpkg-divert --divert /usr/bin/firefox.ubuntu --rename /usr/bin/firefox
sudo ln -s /opt/firefox/firefox /usr/bin/firefox
sudo dpkg-divert --divert /usr/bin/mozilla-firefox.ubuntu --rename /usr/bin/mozilla-firefox
sudo ln -s /opt/firefox/firefox /usr/bin/mozilla-firefox

que yo ya vi comentadas en el foro de Guadalinex al igual que lo que pongo en el tutorial, Decidí probarlo así porque vi que la gente que empezaba en Linux como yo lo podía instalar al estilo windows, de hecho si visitas mi blog igual te resulta más sencillo porque se ve con imágenes.
La diferencia entre lo mio y el script es que el script lo hace todo por ti, pero como yo no se hacer scripts pues...
Me alegro de que lo hayas instalado.
Que el firefox se te cierre puede ser debido al flash9, intenta instalar el flash9 desde automatix (estos dias Automatix está caido)

Saludos

MiBlog
MiWeb

Imagen de Chino-x

Todo salio bien en la instalación, muchas gracias. Solo me quedo una pregunta, ¿no afecta nada que no haya conservado la configuración anterior? (osea, que no haya tecleado en la terminal cd/opt/firefox...).

Imagen de Cristobal López

¿A qué te refieres a lo de conservar la configuración anterior? ¿Te refieres al firefox que viene preinstalado con Ubuntu? Lo de cd /opt/firefox... es para que tengas todos los plugins operativos en tu nueva actualización de firefox.

Saludos

MiBlog
MiWeb

Imagen de Chino-x

Gracias ahora entiendo, si me refería a los plugins de la version firefox que trae ubuntu por default. Gracias.

Imagen de durin

hola!!

 

Pues si, sin problemas!!! Actualicé el Firefox y todo a la perfección. Muchas gracias por la ayuda :D:D:D 

"La paciencia es un árbol de amargas raices y dulces frutos"

Imagen de josefo

Hola, por favor responderme a gabrielteoria@gmail.com

 

qué sucede si me instalaron Dapper 6.04, y venia con FF 1.5 y ahora quiero actualizar FF a 2.0.0.11, si bajo el paque  de mozilla y lo instalo, se pierden todos los adicionales, configuraciones de FF anteriores, o, PEOR AUN, el Dapper 6.04 lo reconocerá bien todo para video y sonido? 

Imagen de Cristobal López

Hola

pues no pasa nada, al actualizar se sigue conservando todos tus addons y demás configuraciones de tu firefox.

Saludos 

---------------------------------------------------------------------------------------------------- Moderadores

 

Normas