Problemas con tarjeta de red RTL8139/810x

Imagen de fire-eater
0 puntos

Tengo alrededor de 12 colegas en la misma situacion y se ha generado un descontento por este problema de RED conrespecto a LINUX

Tengo una tarjeta de red RTL8139/810x de la cual en windows XP la reconoce y me conecto a la red de mi local, sin embargo al entrar en ubuntu 6.06 me reconoce la tarjeta de red pero esta no se ACTIVA, le he puesto los mismos parametros de red por windows y es en "vano",ademas he encontrado otras personas con problmas similares, alguein por esta via que me responda, soy usuario viejo en linux, pero este mother board nuevo Intel D101GGC con una tarjeta RTL8139/810x ONBOARD es una ANTI-LINUX (trabaja para microsoft pero no para ubuntu)

Hablen de soluciones complejas (sin miedo)

  • trabajo con consola
  • programo
  • lo que haga falta

AGRADESCO CUALQUIER SUGERENCIA

Imagen de mtma
+1
0
-1

Carga el módulo a mano con
"sudo modprobe 8139too" y avisa que error te tira (ejecuta dmesg para mas info sobre la carga).
Si pasa esa parte configura la placa con ifconfig y coméntanos cual es la falla que indica.

Saludos y suerte

Matias

+1
0
-1

Matias

Imagen de tenchi
+1
0
-1

shallow by the net
el grupo de las victimas de realtek - encore en linux os saluda
siempre tenemos preferencia por la parte mas barata que vemos en latienda ,accion normal del hombre intelligente,pero en este caso nos ha de fastidiar hasta las muelas (nos tomo a mi + dos amigos en los foros 3meses para que funcionara gracias al cjadt por la ayuda ).al grano para arreglar la targetica y ponerla a funcionar
primero hay que probar el modulo que biene por defecto con ubuntu asi que se rootean con $su y

pandemonium@leviathan#cd /lib/modules/`uname -r`/kernel/drivers/net
no le quiten comillas ni nada escribanlo asi

denle ahora un $ls y busquen el modulo sundance.ko y el modulo rtl8139oo.ko no estoy seguro del segundo asi que puede que lo aya escrito mal si no lo consiguen busquen uno parecido y prueben con el

luego
para encore
pandemonium@leviathan/lib/modules/`uname -r`/kernel/drivers/net#insmod ./sundance.ko

para realtek
pandemonium@leviathan/lib/modules/`uname -r`/kernel/drivers/net#insmod ./rtl8139oo.ko
olo que corresponda para realtek , el `uname -r` lo va a cambiar por la version de kernel
que tengan instalada

con esto si el modulo en linux esta bien, debera aparecer la targetica en administracion-red ya montada y deberia dejarse ver con un

pandemonium@leviathan$ifconfig
y dejarse poner ip y demas
si esto funciona el modulo esta bien y solo hace falta hacer la entrada para que ubuntu la cargue automaticamente al inicio de ubuntu asi que

leviathan@pandemonium:~#gedit /etc/modules

deveria salir algo como esto en el documento de texto

---------------------
# /etc/modules: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a "#", and everything on the line after them are ignored.

ide-cd
ide-detect
ide-disk
psmouse
sundance

(ya solo le agregan un sundance al final o un rtl8139oo segun corresponda )

con esto deberia ya estar solucionado el problema pero sino funciona el modulo de ubuntu abra que arreglar el driver que biene en el disco de la targeta de red generar el modulo y reemplazar el de ubuntu hasy que comenzemos

saquen el driver que esta dentrode la crpeta de linux que hay en el cd ,sies el mismo disco que ttengo habran dos carpetas marcadas como enl algo la una tiene el driver la otra un documento dee texto la que se nessesita es la que tiene un archivo
sundance main c esta carpeta la copiamos a nuestro home para hacerle el trabajito
ya con la carpeta en home buscamos el sundance main c lo abrimos con el editor de textos
y buscamos la linea 1400 y le agregamos single_for_cpu que quede hasi

pci_dma_sync_single_for_cpu(np->pci_dev, desc->frag[0].addr,

ahora la linea 1653 se le agrega un // al principio

//strcpy(info.bus_info, np->pci_dev->slot_name);

no hay que contar lineas en la esquina inferior derecha el editor dice en que linea y enque columna esta parado el cursor
guardan y listo
para las realtek segun he leido se hace el mismo proseso con el main c haci que habra que probar que no se pierde nada si se va con cuidado

para el siguiente paso hay que tener instalados los kernell headers y el essential build de la version correspondiente de ubuntu ,luego no sreferimos al readme que hay con el driver

b. for kernel 2.6.x
-------------------
#make all
#insmod ./sundance.ko (or sundance.o)
#ifconfig eth0 xxx.xxx.xxx.xxx netmask yyy.yyy.yyy.yyy

1º------------
root@pandemonium:/leviathan/Linux# make all
make -C /lib/modules/2.6.15-23-386/build SUBDIRS=/media/hda10/sofware/Linux modules
make[1]: se ingresa al directorio `/usr/src/linux-headers-2.6.15-23-386'
CC [M] /leviathan/Linux/sundance_main.o
CC [M] /leviathan/Linux/mii.o
LD [M] /leviathan/Linux/sundance.o
Building modules, stage 2.
MODPOST
CC /leviathan/Linux/sundance.mod.o
LD [M] /leviathan/Linux/sundance.ko
make[1]: se sale del directorio `/usr/src/linux-headers-2.6.15-23-386'

2º------------------
root@pandemonium/leviathan/Linux# insmod ./sundance.ko
este comando es para poner ip fija si quieren dhcp no lo utilizen
#ifconfig eth0 xxx.xxx.xxx.xxx netmask yyy.yyy.yyy.yyy

si funciona y sale latargeta de red en administracion -red entonces se puede seguir al paso 3

3º-------------------

root@pandemonium:/leviathan/Linux#cp sundance.ko /lib/modules/`uname -r`/kernel/drivers/net

se hace la entrada en networks

root@pandemonium:/leviathan/Linux#gedit /etc/modules

deveria salir algo como esto en el documento de texto

---------------------
# /etc/modules: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a "#", and everything on the line after them are ignored.

ide-cd
ide-detect
ide-disk
psmouse
sundance

( sundance o rtl8139 lo que sea al final guardas y listo ya estubo)

------------------------------------------------
con esto terminamos al reiniciar deberia montarla con dhcp o con ip fija segun el caso
como nota personal debo agregar que mi damned targetica encore tiene un defecto de fabrica haci que un dia monta ella solita funciona perfecta y al siguiente no monta ni nada y no hay poder sobre latierra o bajo ella que pueda hacerla funcionar , al dia siguiente funciona como una reina de nuevo y como en guindous les funciono perfecto alos cabbbbbr
dela tienda donde la compre no me la cambian por garantia

suerte espero que les sirva cualquier cosa postean que aqui alguno terminara contextando

+1
0
-1

.El hombre ,en lugar de admitir que había muchas cosas en la naturaleza que no podían explicarse con los conocimientos de su época optá por la solución más socorrida en toda la historia: se inventa una explicación ad hoc.

Esta es quizá una de

Imagen de fire-eater
+1
0
-1

TIEMPO RECORD!!!!!!!

Exacto mi amigo tenchi, solo con usar la linea

para el encore
pandemonium@phpinfo/lib/modules/`uname -r`/kernel/drivers/net#insmod ./sundance.ko

HAY QUE ACLARAR POR AQUI QUE EL PROBLEMA SURGE DESDE QUE ARRANCA POR EL LIVE-CD PARA LUEGO INSTALAR
UBUNTU EN EL DISCO DURO. ?PORQUE NO CARGO ESTE MODULO SUNDANCE.KO?

he logrado reslover el problema a mis 12 colegas y entrar en mundo de software libre a mas personas

con personas como ustedes este mundo del soft SOLO ES POSIBLE

gracias a todos, gracias

Viva el software libre, Long Live free software, Ubuntu and so on !!!

+1
0
-1

Un saludo desde CUBA

Quien se levanta hoy por Cuba se levanta para todos los tiempos

Viva el software libre, Long Live free software, Ubuntu and so on !!!

Imagen de carlos valencia
+1
0
-1

saludos

Hey amigo
tengo un problema con la tarjeta de red ENCORE ENL832-TX-ICNT que tiene mi equipo, con windows la salida a internet funciona perfectamente, pero cuando pongo el disco que tiene ubuntu 6.06 i386 desktop no me funciona la salida a internet.

Mi tarjeta madre es una Nvidia Nforce-2 , cuando entro a la base de datos ubuntu de dispositivo,empieza bien el test hasta que llega a NETWORK TEST se queda bloqueado.

Me puedes ayudar en algo?

muchas gracias

+1
0
-1
Imagen de fire-eater
+1
0
-1

No se que te podria aconsejar,
aunque en primer lugar aclarame si esa tarjeta es de RealTek, que es por lo que mi problema surgio, habria que averiguar que modulos (como el sundance.ko) son los necesarios para inicilizar tu tarjeta de red, que seguro eso es lo que pasa

sigue la respuesta que me dieron, en especial el modulo sundance.ko era el que faltaba por cargar,

averigua los modulos necesarios para tu tarjeta de red

Viva el software libre, Long Live free software, Ubuntu and so on !!!

+1
0
-1

Un saludo desde CUBA

Quien se levanta hoy por Cuba se levanta para todos los tiempos

Viva el software libre, Long Live free software, Ubuntu and so on !!!

Imagen de fredd2
+1
0
-1

Creo que deberias hacer un lspci para ver tu tarjeta , despues te vas a google y pegas el resultado que te dio lspci sobre tu tarjeta de red y googliar , yo e echo eso por un una tarjeta marvell 10/100/1000 que si bien funcionaba hacindo todo a mano (ifconfig eth* ip.que.leponia , route add default gw ge.tw.ay etc) asi encontre el modulo que tenia que cargar.
Saludos

te sentiste alguna vez estafado???

+1
0
-1

te sentiste alguna vez estafado???

Imagen de titan837
+1
0
-1

Hola, espero que alguein me pueda ayudar con este problema, hasta ahora me estoy iniciando en linux y como opcion inical tome a ubuntu en el dia de ayer lo instale  y  cuando me fui a conectar a internet veo que no tenia servisio  tratando de configurar con alguna informacion que encontre en internet note que ubuntu no detecto mi tarjeta de red, la tarjeta viene integrada con la board es un (intel D101GGC) en este caso que tengo que hacer agradesco de antemano la ayuda que se me brinde muchas gracias.

+1
0
-1
Imagen de fire-eater
+1
0
-1

titan te recomiendo que sigas este texto que me sirvio a la perfeccion, ademas agregar que lo que pasa (en mi caso) es que ubunto no carga el modulo sundance.ko

lee desde que yo comence este problema!!!!

escribeme si no te funciona pero este es el problema

primero hay que probar el modulo que biene por defecto con ubuntu asi que se rootean con $su y

pandemonium@leviathan cd /lib/modules/`uname -r`/kernel/drivers/net
no le quiten comillas ni nada escribanlo asi

denle ahora un $ls y busquen el modulo sundance.ko y el modulo rtl8139oo.ko no estoy seguro del segundo asi que puede que lo aya escrito mal si no lo consiguen busquen uno parecido y prueben con el

luego
para encore
pandemonium@leviathan/lib/modules/`uname -r`/kernel/drivers/net#insmod ./sundance.ko <-- este es el que no se carga desde que se instalo ububtu!!!!!

para realtek
pandemonium@leviathan/lib/modules/`uname -r`/kernel/drivers/net#insmod ./rtl8139oo.ko
olo que corresponda para realtek , el `uname -r` lo va a cambiar por la version de kernel
que tengan instalada

con esto si el modulo en linux esta bien, debera aparecer la targetica en administracion-red ya montada y deberia dejarse ver con un

pandemonium@leviathan$ifconfig
y dejarse poner ip y demas
si esto funciona el modulo esta bien y solo hace falta hacer la entrada para que ubuntu la cargue automaticamente al inicio de ubuntu asi que

leviathan@pandemonium:~#gedit /etc/modules

deveria salir algo como esto en el documento de texto

---------------------
# /etc/modules: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a "#", and everything on the line after them are ignored.

ide-cd
ide-detect
ide-disk
psmouse
sundance

(ya solo le agregan un sundance al final o un rtl8139oo segun corresponda )

Viva el software libre, Long Live free software, Ubuntu and so on !!!

+1
0
-1

Un saludo desde CUBA

Quien se levanta hoy por Cuba se levanta para todos los tiempos

Viva el software libre, Long Live free software, Ubuntu and so on !!!

Imagen de tenchi
+1
0
-1

la board de intel dgi101ggc  viene con una targeta de red integrada rtl8139 en este caso el modulo creo es 8139too.ko  o talvez 8139cp.ko ,bueno como sea dale

sudo insmod /lib/modules/2.6.15-28-386/kernel/drivers/net/8139too.ko

si no monta con este entonces debe ser el otro ,si no pues buscas uno parecido en /lib/modules/2.6.15-28-386/kernel/drivers/net/

y sigues intentando  

+1
0
-1

.El hombre ,en lugar de admitir que había muchas cosas en la naturaleza que no podían explicarse con los conocimientos de su época optá por la solución más socorrida en toda la historia: se inventa una explicación ad hoc.

Esta es quizá una de

Imagen de freddierith
+1
0
-1

hola tengo una tarjeta de red REALTEK RTL8139/810X FAMILY FAST ETHERNET NIC y no se conecta a internet y nesecito tu ayuda soy novel en linux estoy usando windows y linux en la misma computadora pero no me funciona el internet bajo linux ubuntu favor daar un poco mas de detalle para configurala gracias por adelantado

+1
0
-1

Rick

Imagen de tenchi
+1
0
-1

comenxemos con un

en la seccion de red o network ,en opciones administrador te sale la targeta de red junto con el modem o no ????

 

bueno

___________________________________

la vida no es un guineo , esto lo he sabido desde siempre

+1
0
-1

.El hombre ,en lugar de admitir que había muchas cosas en la naturaleza que no podían explicarse con los conocimientos de su época optá por la solución más socorrida en toda la historia: se inventa una explicación ad hoc.

Esta es quizá una de

Imagen de fire-eater
+1
0
-1

Hay que leer mas y preguntar despues, para las dudas que han surgido des pues que Tenchi explico como cargar el modulo de la tarjeta a mano, se pueden concebir como algo fuera de lugar  preguntar de nuevo por la misma boberia de "Hay mi tarjeta de red es una realtek y no funciona", !Lean, Lean, carajao! desde el principio, parecen unos niños que hay que darles el caramelo en la boca, y trabajen con linux sin miedo, que  linux no es de cristal !!!!

"Ser cultos  es la unica manera de ser libres"

Viva el software libre, Long Live free software, Ubuntu and so on !!!

+1
0
-1

Un saludo desde CUBA

Quien se levanta hoy por Cuba se levanta para todos los tiempos

Viva el software libre, Long Live free software, Ubuntu and so on !!!

Imagen de jheure
+1
0
-1

saves, estaba tratando de entender como hacer funcionar mi tarjeta de wifi RTL8139/810x, pero no entiendo las explicaciones, pues es la primera vez que instalo linux ubuntu, en mi caso es el 10,04.
si lo escribieras lo mas detallado posible te lo agradeceria mas de lo que tu te imaginas.
pues quiero aprender.
porq te de digo todo esto. es por la razon de que no se a que se refieren con $su, tampoco se donde se coloca.

uffff
perdon por mi ignoranci
de ante mano espero tu respuesta.

+1
0
-1
Imagen de charliec114
+1
0
-1

 primero hola gracias por el post:

 

hago lo que explicas arriba pero de entrada me sale un error cuando tecleo insmod ./sundance.ko

 

el error es:

 

error inserting './sundance.ko' : -1 unknown in module

 

al archivo sunsance.ko lo veo al otro rtl..... no, ta tarjeta es nueva encore realtek..... sera que no va a andar? 

 

 

 

Metiendome en esto de linux

+1
0
-1

Metiendome en esto de linux

Imagen de charliec114
+1
0
-1

 Tengo una tarjeta Encore realtek y no me la detectoXubuntu 7.04, hago lo que dices ahi en tutorial pero me salta error de una....

despues de tipear :

insmod ./sundance.ko

 

me sale el error:

 

-1 unknown symbol in module

 

que sera?

desde ya muchas gracias 

 

 

Metiendome en esto de linux

+1
0
-1

Metiendome en esto de linux

Imagen de neokake
+1
0
-1

hola mi notebook tiene los mismos problemas trate de hacer lo que decian pero al hacerlo me sale un error  "error inserting ./8139too.ko: -1 File exits "

porfa ayua que el notebook que tengo para variar el sonido es incompatible con windows xp  asi qu mi unica salia para usar bien el notebook es usar..........................  WWINDOWS VISTA ...    nooooooooooooo!!!!!!

 

no quiero caer tan bajo

 

por favor ayuda........... 

+1
0
-1
Imagen de tenchi
+1
0
-1

mira si el modulo y estra cargado

 sudo lsmod

si esta en la lista lo quitas con

sudo rmmod  8139too.ko 

o

sudo rmmod  8139too

y luego lo vuelves amontar

si no funciona ,pues o recompilas el modulo  o te pasas a feisty

+1
0
-1

.El hombre ,en lugar de admitir que había muchas cosas en la naturaleza que no podían explicarse con los conocimientos de su época optá por la solución más socorrida en toda la historia: se inventa una explicación ad hoc.

Esta es quizá una de

Imagen de fire-eater
+1
0
-1

Pase a los repositorios feisty que estan bastante actualizados, y ese error es propiamente que el modulo parece estar cargado ya, asegurese de saber si es realmente esa la tarjeta Realtek,

cuando cambies a los repo feisty has    apt-get dist-upgrade 

 

Un saludo desde CUBA

Quien se levanta hoy por Cuba se levanta para todos los tiempos

Viva el software libre, Long Live free software, Ubuntu and so on !!!

+1
0
-1

Un saludo desde CUBA

Quien se levanta hoy por Cuba se levanta para todos los tiempos

Viva el software libre, Long Live free software, Ubuntu and so on !!!

Imagen de Fran Davila
+1
0
-1

a mi me pasa igual que a ti con la misma targeta pero tengo un modem zte y la version de ubuntu que uso es ubuntustudio 7.10 me podrian ayudar? aclaro que en la version de ubuntu 7.04 la targeta de red funciona muy bien he incluso desde el live cd se conecta rapidamente, pero en la version ubntustudio 7.10 no se conecta.

Ahora buscando he conseguido el driver de esta targeta para linux, para el kernel 2.4 que es el mismo que tiene ubuntustudio 7.10 pero no se como instalar el make que trae, es solo el make y un archivo de texto que trae el driver, y pesa 25 Kb. Quien lo desee me puede escribir a frankdavilave@hotmail.com y con gusto se lo envio.

+1
0
-1

Cristo vino a salvar no a condenar, sin embargo viene pronto y alli si hara juicio a la raza humana, y el castigo a quienes no lo recibieron sera el llorar y el crugir de dientes.

Imagen de torotorero1977
+1
0
-1

pero desgraciadamente no he tenido la suerte de el, ojala alguien me pueda orientar ya que esto no jala, mi problema esta descrito en el post http://www.ubuntu-es.org/index.php?q=node/89031#comment-247875, gracias por su atención

+1
0
-1