Problemas abriendo aplicaciones con sudo

Imagen de jclaurian
0 puntos

Saludos

Todo empezo al querer instalar automatix, debo agregar un nuevo repositorio, pero al querer abrir el achivo sources me genera un error, es mas, al solo querer abrir Kate como sudo me genera el error, este es:

usuario:$ sudo kate

X Error: BadDevice, invalid or uninitialized input device 166
Major opcode: 144
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 166
Major opcode: 144
Minor opcode: 3
Resource id: 0x0
Failed to open device
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kdeinit: Can't connect to the X Server.
kdeinit: Might not terminate at end of session.
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kded: cannot connect to X server :0.0
DCOP aborting call from 'anonymous-5674' to 'kded'
kded: ERROR: Communication problem with kded, it probably crashed.
kdeinit: Shutting down running client.
---------------------------------
It looks like dcopserver is already running. If you are sure
that it is not already running, remove /root/.DCOPserver_amyta-desktop__0
and start dcopserver again.
---------------------------------

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kdeinit: Can't connect to the X Server.
kdeinit: Might not terminate at end of session.
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kded: cannot connect to X server :0.0
DCOP aborting call from 'anonymous-5681' to 'kded'
kded: ERROR: Communication problem with kded, it probably crashed.
kio (KSycoca): ERROR: No database available!
kio (KSycoca): ERROR: No database available!
""""""""""""""""""""""""""""""""""""""""""" este ultimo se repite una eternidad
KCrash: Application 'kate' crashing...
Warning: connect() failed: : No such file or directory
KCrash cannot reach kdeinit, launching directly.
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Imagen de keygen
+1
0
-1

al parecer tu servidor grafico no esta aceptando conexiones, ahora si estas utilizando gnome por que no utilizas gedit, y si estas utilizando kde seria bueno que reconfiguraras tu servidor grafico. lo que yo recomiendo siempre es utilizar el editor de consola de preferencia el vi, que la mayoria de los sistemas operativos basados en unix lo traen, asi no tienes que depender de una interfaz grafica para editar tus archivos de configuraciones.

el comando para hacerlo es :
sudo dpkg-reconfigure xserver-xorg

pero te aconsejo que leas mas al respecto, antes de hacerlo, y que hagas un respaldo de tu archivo /etc/X11/xorg.conf
--
[vivie siempre libre]

+1
0
-1

--
[vivie siempre libre]