Problema con apt-get y paquetes rotos.

Imagen de tetuje
0 puntos

Bien instalé la distro, y como en las demas, al terminar hice apt-get update , upgrade y dist-upgrade pero en algun paso, me dio un error con un archivo y ahora ya no me deja actualizar ni instalar nada mediante el terminal.
Si abro synaptic me dice que hay un paquete roto y que lo solucione, lo intento arreglar pero mientras lo arregla me vuelve a dar un fallo.

SI por ejemplo intento actualizar me sale lo siguiente.

root@tetuje:/home/tetuje# apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Tal vez quiera ejecutar `apt-get -f install' para corregirlo.
Los siguientes paquetes tienen dependencias incumplidas:
ndiswrapper-modules-2.6.5: Depende: ndiswrapper-utils-0.12
E: Dependencias incumplidas. Pruebe de nuevo usando -f.
root@tetuje:/home/tetuje#

Y si hago apt-get -f install me sale:

aroot@tetuje:/home/tetuje# apt-get -f install
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Corrigiendo dependencias... Listo
Se instalarán los siguientes paquetes extras:
ndiswrapper-utils
Se instalarán los siguientes paquetes NUEVOS:
ndiswrapper-utils
0 actualizados, 1 se instalarán, 0 para eliminar y 2 no actualizados.
31 no instalados del todo o eliminados.
Se necesita descargar 0B/18,7kB de archivos.
Se utilizarán 102kB de espacio de disco adicional después de desempaquetar.
¿Desea continuar? [S/n] s
(Leyendo la base de datos ...
101647 ficheros y directorios instalados actualmente.)
Desempaquetando ndiswrapper-utils (de .../ndiswrapper-utils_0.12-1_i386.deb) ...dpkg: error al procesar /var/cache/apt/archives/ndiswrapper-utils_0.12-1_i386.deb (--unpack):
intentando sobreescribir `/usr/share/man/man8/ndiswrapper.8.gz', que está también en el paquete ndiswrapper
dpkg-deb: el subproceso paste fue terminado por la señal (Tubería rota)
Se encontraron errores al procesar:
/var/cache/apt/archives/ndiswrapper-utils_0.12-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Y no hay manera si entro en synaptic para intentar arreglar los paquetes "rotos" que tengo me da tambien error, por cierto en mientras me dio el error que ha jodido todo esto, estaba actualizando tambien el firefox y ahora ni abre ni nada :(

Imagen de wraith
+1
0
-1

dale tiempo, a veces pasa k al actualizar algun pakete pierde dependendias o esta roto. ve aciendo updates y upgrades y se te solucionara solo en dias.

saludos:)

+1
0
-1

Solo sé que no sé nada.

Imagen de tetuje
+1
0
-1

eL problema es que no me deja instalar ni actualizar nada... algun comando que solucione esto?

+1
0
-1

novato :>

Imagen de wraith
+1
0
-1

prueba esto

sudo apt-get update
sudo apt-get dist-upgrade

si te da problemas prueba cn un
sudo apt-get install -f

postea lo k t dice al acer eso, espero k arregle algo

salu2

+1
0
-1

Solo sé que no sé nada.