Internet con ubuntu 6.10 y modem 56K

Imagen de Lacasito
0 puntos

Veamos, normalmente uso una Gaudainex (Breezy) y la tengo configurada con mi cuenta de Internet sin problemas.
Cuando meto el CD-Live de Dapper en el trabajo (Allí sólo hay Windowses). Le pongo los mismos datos que en Guadalinex y se conecta sin pegas. La interface de Sistema > Administración > Red es la misma.

Sin embargo me he encontrado, al descargar y probar la 6.10 Edgy, con que han cambiado la interface.
Le pongo el módem en /dev/ttyS0, que es donde está porque ha desaparecido el botón Autodetectar.
Le pongo los datos de mi proveedor y se supone que al activar una casillita a la izquierda de "Conexión con módem" debería empezar a marcar porque se han cepillado los botones anteriores que decían "Activar" "Desactivar"

He hecho exactamente lo mismo que con el CD-Live de Dapper y con Guadalinex y sin embargo no hay manera de que conecte. Ni marca ni nada.

El resolv.conf está y tiene las DNS que le meto en la configuración.
Si miro en /etc/ppp y en /etc/chapscripts hay ficheros con los datos de mi proveedor.

He probado a desactivar la tarjeta de red, pero no está activada porque si hago un ifconfig sólo aparece el lo

¿Me puede decir alguien qué han cambiado para que con Dapper sea tan sencillo y con Edgy sea imposible?

El módem es un serie, Conceptronic que va de muerte con todo menos con Edgy.

Gracias.

Imagen de ricardgm
+1
0
-1

A mi me sucede lo mismo.

Lo pruebo con el Live CD de la 6.6 y perfecto.

Lo pruebo con la 6.10 y no se como hacerlo.

¿Alguien sabe porqué han cambiado la interficie? ¿Cómo puedo configurar y conectarme a Internet con mi modem ahora?

+1
0
-1
Imagen de josedelsud
+1
0
-1

Yo postee en el dia de hoy un problema que tengo para hacer funcionar el modem US Robotics ISA PnP 56k con Edgy, me pasa lo mismo, entro en la parte de hardware y aparece como reconocido por Edgy pero no logro que se comunique con el OS, alguien me respondio con un thread probá a ver si te ayuda en algo. (a mi tampoco me aparece el boton donde decia "autodetect" pero supongo que es porque justamente no existe comunicacion entre el sistema operativo y el modem). suerte!

+1
0
-1

Jose

Imagen de Anónimo
+1
0
-1

Yo sigo igual, no estan los botones de detectar modem ni de activar/desactivar.

Donde aparece el modem hay una pequeña casilla, la marco y desmarco pero no hace nada.

En cambio con el Live de la versión anterior, 6.6 consigo que funcione.

+1
0
-1
Imagen de Lacasito
+1
0
-1

Al menos me consuela ver que no soy el único con problemas, lo que indica que a lo peor los chicos de ubuntu se han olvidado de que aún hay gente con módem de 56K.
Probé en el trabajo y la red la detecta sin problemas, activa la interface eth0 y va bien, pero en casa, con el módem, nada de nada.

+1
0
-1

*** ### ***
Ubuntu User #11237

Imagen de josedelsud
+1
0
-1

Intente encontrar la solucion en varios foros pero resultan ser mas los que tenemos el problema que los que tienen alguna solucion, es una pena, porque me gusta Edgy pero asi sin poder conectarme a Internet es imposible que continue usando Edgy y volveré a Dapper si no encuentro una solucion en un tiempo razonble.

+1
0
-1

Jose

Imagen de Anónimo
+1
0
-1

Chicos! Pues parece que tendremos que volver a Dapper, llevo varios días peleándome con la "Configuración de Red" de Edgy y no hay manera de que funcione con mi modem. NO ENTIENDO COMO PUEDE SUCEDER ESTO, yo soy bastante tonto pero tanto no creo.

Con el Live CD de Dapper funciona ... existen los botones de detectar modem y Activar/Desactivar. Con Edgy aparecen unos checkbox que puedes marcar y parece que sustituyan a los botones de Activar/Desactivar pero al marcar el checkbox no hace nada.

+1
0
-1
Imagen de jukary
+1
0
-1

yo tengo un modem interno motorola, pero ni siquiera me lo detecta,como kien dice me jodí sin internet, espero me puedan ayudar

+1
0
-1
Jukary, <<a-teens>> <<Kabah, el pop ha muerto ¡Viva el pop!>>
Imagen de Anónimo
+1
0
-1

Lacasito ¿cuando dices que en el trabajo activas la interface eth0 te refieres a que marcas el checkbox?

+1
0
-1
Imagen de Lacasito
+1
0
-1

No, en realidad, en cuanto arranca el CD-Live detecta la red y la activa automáticamente.
No tengo que hacer más que abrir el navegador y comenzar a navegar.
Me he fijado que la casilla de la izquierda está activada nada más arrancar con el CD-Live.

En el trabajo tenemos una red LAN a través de la cual salimos a Internet.

+1
0
-1

*** ### ***
Ubuntu User #11237

Imagen de Lacasito
+1
0
-1

No os lo vais a creer! No me lo creo ni yo, casi.

¡¡¡ESTOY NAVEGANDO DESDE UBUNTU EDGY EFT 6.10 CON MI PEDAZO DE MODEM CONCEPTRONIC DE 56K A PEDALES!!!

¡LO HEMOS CONSEGUIDO!
Digo lo hemos, porque, aunque yo haya dado con el chiste, ha habido gente en los foros que poco a poco me ha ido dando pistillas sin ellos saberlo.
Bien, os cuento como he llegado a la solución final. Dejadme que me explaye a gusto, por favor, Graciaaaaas!

He leído en un post en inglés que podía usar wvdial.
Lo he configurado, lo he usado y me ha marcado bien, peeeeero... reconectaba una y otra vez y daba un error de pppd que me remitía a la página del man (error 16) para más info.

Allí me he topado con esto (He traducido al cristiano lo mejor que he podido para que todo el mundo lo entienda):

EJEMPLO:
Los siguientes ejemplos asumen que el fichero /etc/ppp/options contiene la opción auth ( como en el fichero predeterminado /etc/ppp/options en la distribución de ppp). Probablemente el uso más común es marcar a un ISP. Esto se puede hacer con un comando como:
pppd call isp

Que yo he reutilizado luego como
pppd call ppp0

porque ése es el comando que se utiliza en Guadalinex y Ubuntu Dapper.

En el mismo man de pppd, en la opción auth dice:

auth
Requiere al peer autentificarse a sí mismo antes de permitir los paquetes de red ser enviados o recibidos. Esta opción es la predeterminada si el sistema tiene una ruta predeterminada.
Si no se especifica esta opción ni la opción noauth, pppd sólo permitirá al peer usar direcciones IP para las cuales el sistema no tiene ya una ruta.

Se me ocurrió mirar esa opción y estaba en auth.

Fui a /etc/ppp/options y cambié:

# Require the peer to authenticate itself before allowing network
# Solicita a peer autentificarse a sí mismo antes de permitir
# packets to be sent or received.
#que los paquetes de la red sean enviados o recibidos
# Please do not disable this setting. It is expected to be standard in
#Porfa, no inhabilite esta opción. se espera que sea un estandar en el
# future releases of pppd. Use the call option (see manpage) to disable
# futuro ediciones de pppd. Use la opción call (ver página del man) para inhabilitar
# authentication for specific peers.
#la autentificación para peers específicos.
auth

por

noauth

Las líneas traducidas entre medio son cosecha propia. No he encontrado una palabra válida para peers, por eso la he dejado tal cual.

la cambié y probé con

pppd call ppp0

¡Y funcionó!

Luego probé marcando la casillita de la izquierda...

¡Y funcionó!

O sea, resumiendo (Te la metí y salí corriendo)
1.- configurar la conexión desde Sistema>Administración> Red.
2.- Cambiar auth por noauth en /etc/ppp/options

Marcar la casilla de la izquierda
Navegar

Imagino que si tenéis instalado el Edgy (Yo he usado el CD-Live) Quizá el comando
pppd call ppp0
haya que ejecutarlo con sudo.

Tened en cuenta que algunas cosas hay que editarlas como root, como

sudo gedit /etc/ppp/options

Un saludo y gracias a todos por vuestra paciencia.
¡No escribimos!

+1
0
-1

*** ### ***
Ubuntu User #11237

Imagen de migatxu
+1
0
-1

El caso es que yo ando con 56k y al pasar de Dapper a Egdy sin actualizar, no tuve ningún jaleo. Si los botones que nombras no están, pero a poco que mire ahora no recuerdo donde, vi /etc/ppp/peers/provider

Una vez configurados los datos de mi conexión gráficamente en Red, ejecute desde un terminal el comando pon y me llevo al archivo que cite antes, lo abrí y leí que tan solo debía especificar donde esta el módem, añadir mi nombre de usuario y el numero del ISP, guardar y luego si conecta ya con un "pon" en el terminal, y para desconectar con "poff". Aun así añadiendo el applet del módem lo haces fácil, pero prefiero el otro modo.

+1
0
-1

"El pollo Popeye es la polla"

Imagen de Lacasito
+1
0
-1

Bueno, a ver, partiendo de mi Guadalinex, veo que /etc/ppp/peers/provider tiene la opción

# Do not ask the remote to authenticate.
noauth

De lo que sí estoy seguro es de que cuando conecto con Guadalinex uso este comando
pppd call ppp0
porque lo tengo en un script para que, pasados unos 40 segundos, me arranque el cortafuegos todo seguido y es ese script el que uso para conectarme. Llegué a él tras observar lo que se ponía en marcha en el sistema con ps aux desde una consola.

En el fichero /etc/ppp/peers/provider no vienen los datos de la conexión, sólo lo que parecen ser unas opciones.
El fichero que contiene los datos está en el mismo directorio y se llama ppp0, y dice:

connect "/usr/sbin/chat -v -f /etc/chatscripts/ppp0"
usepeerdns

noauth

defaultroute

/dev/ttyS0
115200
user "blablabla@blablabla"

que, como ves, también tiene la opción noauth.

Lo que me mosquea es que, acabo de mirar en mi Guadalinex y en el fichero /etc/ppp/options, la opción que yo indico en mi post viene como auth, y no como noauth, como yo sugiero.

No he mirado los ficheros provider ni ppp0 del CD-Live de Edgy. Quizá poniendo noauth en el ppp0 y auth en el options funcione también. Es cuestión de probar.

En Guadalinex también he usado alguna vez pon y poff pero me da la imporesion de que a la gente, en general, le gusta más tener un botón que apretar (o una casilla que marcar) para conectarse que poner comandos en la consola.
Aunque tú y yo los adoremos el método que dicta el manual consiste en señalar una casilla y se trataba de conectarse a Internet con ese método buscando cual era la configuración correcta para conseguirlo.

Gracias por tu aportación. En cuanto pueda arranco con el CD-Live y sigo haciendo pruebas.

+1
0
-1

*** ### ***
Ubuntu User #11237

Imagen de migatxu
+1
0
-1

En providers vienen unas opciones, me refería a rellenar los campos desde el menú Sistema, Administración, Red, bueno como lo venia haciendo solo que no terminaba de ir luego dándole al iconito del applet, de ahi que toque el providers este y ya si. Y mas que nada ejecuto pon porque no quiero que me coma ram el applet a parte de que lo veo inútil, debes darle botón derecho, conectar, para eso termino antes con un pon :P Que siempre tengo una consola abierta en algún lugar ;)

Saludos

+1
0
-1

"El pollo Popeye es la polla"

Imagen de Lacasito
+1
0
-1

Muy bien, he estado haciendo pruebas y tienes razón, en provider se pueden poner las opciones que dices, no las había visto, la prisas... Además hay que cambiar /dev/modem por /dev/ttyS0, la ttySn donde tengas el modem serie.

Cuando ejecutas pon en realidad se ejcuta pppd call provider y en provider ya viene la opción noauth.

Cuando configuras las cosas desde Sistema >... se crea un fichero ppp0 y también se escribe o se crea otro llamado chap-secrets, que es donde está la contraseña.

La secuencia de comandos se conexión es esta:

/usr/sbin/pppd call ppp0
sh -c /usr/sbin/chat -v -f /etc/chatscripts
/usr/sbin/chat -v -f /etc/chatscripts/ppp0

En /etc/chatscripts/ también hay unos ficheros llamados provider y ppp0 (No sonn iguales aunque llevan el mismo nombre) donde están los comandos del modem y el número de teléfono al que llamar.

He probado a dejar la opción auth en options y poner noauth en ppp0, como tengo en Guadalinex, y no funciona.
Cuando pones pppd call ppp0 la consola da este error:
ubuntu@ubuntu:~$ pppd call ppp0
pppd: The remote system is required to authenticate itself
pppd: but I couldn't find any suitable secret (password) for it to use to do so.
pppd: (None of the available passwords would let it use an IP address.)

Cuando pones en options la opción noauth la cosa vuelve a funcionar.

Al menos ya tenemos dos (O más) maneras de conectarnos con Edgy através de un modem

Con la casillita
Con pppd call ppp0 en una consola (killall pppd, para desconectar)
Con pon en una consola (poff para desconectar, o killall pppd)
Con pppd call provider en una consola (poff para desconectar, o killall pppd)

¡Anda que no hemos aprendido!

+1
0
-1

*** ### ***
Ubuntu User #11237

Imagen de migatxu
+1
0
-1

:D

+1
0
-1

"El pollo Popeye es la polla"

Imagen de josedelsud
+1
0
-1

Gentes... comencé con lo "más complejo" y no se me habia ocurrido:

sudo pppconfig

y luego

sudo wvdialconf /etc/wvdial.conf

jajajaja yo tambien estoy navegando desde Edgy y estoy muy contento salvo por lo del apagado automatico que todavia no pude solucionar.

luego wdial y a navegar...
una vez conectado a la red, bajé el automatix y luego con él GnomePPP (interface gráfica de Gnome Dial Up) y acá estamos!

mama mia! jajajajaja

saludos :)

+1
0
-1

Jose

Imagen de Anónimo
+1
0
-1

¡Por fin! Veo que ya se ha solucionado el problema, aunque para los profanos com yo, como en Dapper iba de fábulas ...

¿GnomePPP? ¿Que es? ¿Para que sirve?

+1
0
-1
Imagen de Anónimo
+1
0
-1

Uuffff, soy nuevo en esto ¿alguien puede hacer un resumen para tontos tipo: "Como configurar un modem para conectar Edgy a Internet"?

+1
0
-1
Imagen de Anónimo
+1
0
-1

¡Por fin puedo conectarme!

Hago lo que dice Lacasito:

1. Configurar la conexión desde Sistema >Administración > Red

2. Cambiar auth por noauth en /etc/ppp/options con sudo gedit /etc/ppp/options
3. En Configuración de Red, en la pestaña de conexiones, marco la casilla del modem

Y puedo conectarme a Internet.

Pero tengo una duda, en las propiedades del modem, en la pestaña Configuración tengo marcadas las dos primeras casillas, la segunda "Usar los servidores de nombres del proveedor de servicios de Internet" ¿para que sirve? ¿que hace exactamente?

¡¡¡Gracias por vuestra inestimable ayuda!!!

+1
0
-1
Imagen de migatxu
+1
0
-1

Y para desactivar el altavoz? El molesto altavoz... xD

+1
0
-1

"El pollo Popeye es la polla"

Imagen de Lacasito
+1
0
-1

Eso es otra cosa, este es un extracto de mis apuntes sobre Linux. Lo he aprendido de algún otro foro o de éste, no sé.

Es posible que, mientras se conecta, le resulte escandaloso el sonido del módem. El
fichero que le conecta a Internet está en /etc/chatscripts/ y se llama, normalmente, ppp0.
Contiene unas líneas como estas:
TIMEOUT 60
ABORT ERROR
ABORT BUSY
ABORT VOICE
ABORT "NO CARRIER"
ABORT "NO DIALTONE"
ABORT "NO DIAL TONE"
ABORT "NO ANSWER"
"" "ATZ"
"" "AT&FH0M0"
OK­AT­OK "ATL1DTnnnnnnnnn"
TIMEOUT 75
CONNECT
Para bajar el nivel sonoro del módem cambia la línea OK­AT­OK "ATDTnnnnnnnnn" por OK­AT­OK "ATL1DTnnnnnnnnn" Tenga en cuenta que las nnnnnnnnn sustituyen al número de su proveedor de internet. Note que hemos intercalado L1 entre las letras AT y DT. Si desea silenciar el
módem totalmente, en lugar de L1 ponga L0 o M0, cualquiera de las dos sirve (Comandos Hayes para el módem)

Otra cosa.
He probado hace un rato con el pppconfig y funciona, pero hay que usarlo desde la línea de comandos con pppd call nombredelproveedor o con alguna otra interface.
Obviamente se pueden usar muchas herramientas gráficas que nos hagan la vida más cómoda, pero el sistema ya viene con una (La casillita) y esa no funcionaba. Se trataba (Desde mi punto de vista) de hacerla funcionar. Ya sabemos que en Linux, por suerte, hay casi siempre varias maneras de llegar al mismo sitio y cada cual puede escoger la que más le guste.

Cuando nos conectamos con, por ejemplo, www.linux.org, hay un servidor que traduce ese nombre por el de 198.182.196.56, ese servidor se llama "servidor de nombres de dominio", o DNS. La opción "Usar los servidores de nombres del proveedor de servicios de internet" significa nada más que quieres que el proveedor de internet, tu ISP, te envíe las DNS para resolver los nombres de dominio. Podrías usar unas DNS estáticas, o sea, siempre las mismas, o usar las de otro proveedor diferente. Lo normal es que sea tu ISP quien te resuelva la papeleta.

Un saludo.

+1
0
-1

*** ### ***
Ubuntu User #11237

Imagen de migatxu
+1
0
-1

Gracias por la rápida respuesta Lacasito :) Pero no he conseguido ni bajar el volumen ni deshabilitarlo como comentas. Ni con L0 ni M0 ni L1, ni con "pon" ni con "pppd call provider" Mira que es irritante el sonido cuando se desconectar de noche, que lo deben oír hasta los del quinto xD A ver si llamo de una vez y contrato una ADSL que los 56k ya me ponen nervioso xD

Un saludo

+1
0
-1

"El pollo Popeye es la polla"

Imagen de Lacasito
+1
0
-1

Pues ya no sé decirte más, yo encontré esa solución en algún sitio, la apliqué y me funciona.
Lo que no me ha funcionado nunca son las opciones que hay en la interface gráfica para el volumen del módem, por eso busqué la alternativa.

+1
0
-1

*** ### ***
Ubuntu User #11237

Imagen de Anónimo
+1
0
-1

lei todo el post y veo que han solucionado la conexion para un modem por telefono y me mande a consultarles porque no encuentro la solucion.
tengo adsl y me conectro a traves de un router(usuario y contraseña) a internet en win xp, el tema es que en ubuntu me reconoce bien la tarjeta de red pero nose donde poner el user y pass para conectarme y si es que hace falta (supongo que si).
bueno espero que me puedan tirar una ayuda porque tengo al pinguino durmiendo hace como 2 meses ya.
gracias por la atencion.
diego

+1
0
-1
Imagen de Lacasito
+1
0
-1

Pues me temo que tendrás que mirar en otros post del foro. Seguro que está resuelto ya. Aquí nos referíamos a la conexión a Internet con un módem de 56K de línea telefónica básica, no ADSL.
Lo siento.

+1
0
-1

*** ### ***
Ubuntu User #11237

Imagen de Anónimo
+1
0
-1

Muy bien entonces.. igual gracias por leer mi consulta y hasta pronto.
diego

+1
0
-1
Imagen de Anónimo
+1
0
-1

Hola Lacasito

Disculpa la pregunta pero ¿tu módem es externo-serial?, pregunto esto por que yo tengo un módem interno de 56K, con chip Agere, el cual Dapper me reconocía perfectamente sin hacer nada absolutamente, ni cargar controladores ni nada. Edgy por el contrario no lo reconoce de ninguna forma, ya hice todo lo que vi en este post y en muchos otros y nada de nada. Por eso supongo que los módems de los que hablan aquí deben ser seriales, ya que de alguna forma al menos el sistema los detecta, aún con todo y las fallas que dan y que ustedes han podido solucionar ya.

Gracias.

Saludos

+1
0
-1
Imagen de Edokun
+1
0
-1

Me funciono cambie auth por noauth... uso como modem mi telefono celular... gracias por el tip

+1
0
-1
Imagen de Lacasito
+1
0
-1

Es un Conceptronic serie conectado a /dev/ttyS0.

+1
0
-1

*** ### ***
Ubuntu User #11237

Imagen de MagoDeOz85
+1
0
-1

Estoy leyendo que muxa gente le funciona internet en linux con un modem de 56 kb, yo tengo un conceptronic conexant hsf 56k interno, intente hace un año mas o menos hacerlo funcionar bajo ubunto 64 bits, no pude. Estube leyendo por varios foros que mi modem era un winmodem, que los winmodems no funcionavan en linux y tal, mas tarde encontre unos drivers de este modem en linuxan, pero eran capados (12 k) y bueno depues de bastante tiempo intentandolo, lo deje por imposible. Ahora veo que muxos de vosotros si habeis podido, yo uso linux en la universidad, me gusta, pero sin internet no consigo abandonar definitivamente windows. Es posible hacer funcionar mi modem bajo ubuntu? o estoy soñando? jeje gracias :P

+1
0
-1

*****************************************************************

¡Libresfera, la revista libre!

*****************************************************************

Imagen de MagoDeOz85
+1
0
-1

Nadie contesta?

+1
0
-1

*****************************************************************

¡Libresfera, la revista libre!

*****************************************************************

Imagen de Anónimo
+1
0
-1

como crear una conexion para conectarte usando modem de 56k para poder conectarte a internet con ubuntu 6.10.
porfavor amigos ayudenme. soy novato en esto

+1
0
-1
Imagen de Anónimo
+1
0
-1

hola,,bueno también soy novato, pero se me ocurre que en el manotazo de ahogado que tiras,,te tiro un salvavidas que a lo mejor nos sirve a los dos.
el problema es el siguiente, muchos de lo que escriben lo hacen de tal manera que da a entender que son españoles, tu escritura me da a pensar que sos latino, yo soy argentino ( no hago diferencias pero en mi gran desconocimiento no se si los servicios son iguales ymientas mas datos se den mejor ,,,no? ).
hola tengo un modem PCtel HSP MR (via), como tantos otros quiero hacer una conexión, leyendo el foro o post, he visto unos comando que ya probare, y hasta tanto no lo ponga en práctica no sabre si volver a preguntar, uso ubuntu 6.10 de edgy, la gran pregunta:
en red me detecta una conexión de telefono,propiedades, usuario y contraseña, ( acceso dial up: atlantida, datafull, etc), en el caso de atlantida (atlantidadigital.com ): usuario y contraseña atlantida, telefono ,,,. una ves configurada esa parte, que es casi todo ventanitas,,,en la terminal escribo:

$ sudo pppd call ppp0
por ende me conectare a internet,,,

en caso de que falle o funcine, volvere para decir que finciono o para hacer más preguntas,,,

¿alguien de argentina por decir algo,, o de donde sea,, por favor,,que use estos servicios,, ha configurado de forma similar alguno de estos acceso dial up?
sea en draper, edgy, u otra de ubuntu, me las arreglo para ver el tema de los comandos, de esa forma vi la particion, se que los anonimos al parecer no caen bien y desde ya les agradesco a todos los de ubuntu. (uso mozilla y marque la página,,volvere)
ubuntu al parecer ve mi modencito, pero no se si lo " toca ".
besos y abrazos ,,,

+1
0
-1