Problemas con Java y Adept

Imagen de osinet
0 puntos

Holas soy nuevo en lo que se trata a gnu/linux, y me surgieron problemas los cuales me cuesta resolverlos.

Resulta que estaba tratando de instalar cualquier aplicacion, pero ahora me sale un error, todas las veces que trato de instalarlas:

osinet@osinet:~$ sudo apt-get install amsn
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
E: El paquete sun-java5-bin necesita ser reinstalado, pero no se encuentra un archivo para éste.

El otro problema es con el Adept todo anda bien pero cuando quiero Aplicar Cambios y este lo procesa a medias, saliendo un error: "Se produjo un error al enviar los cambios. Posiblemente hubiera un problema con la descarga de algunos paquetes o se detuvo el envio de paquetes."

Bueno espero me ayuden porfa...

Saludos

Imagen de zEos
+1
0
-1

sudo apt-get update
sudo apt-get upgrade

Lo que parece que pasa es que no tienes actualizada la base de datos de los repositorios.

Que digo yo... que si eres nuevo... ¿que haces tirando de consola? Usa el synaptic. Recargar, marcar cambios, aplicar... fácil, fácil. Y si hay dependencias rotas, o cosas raras, las marca.

+1
0
-1
Imagen de osinet
+1
0
-1

Hice lo que me recomendaste :
sudo apt-get update
sudo apt-get upgrade

pero aun perciste el error
y lo mimso sucede con el Adept que es algo parecido al Synaptic

+1
0
-1
Imagen de Anónimo
+1
0
-1

los paquetes de java-sun estan en el repositorio "multiverse"..
verifica que lo tengas habilitado.

+1
0
-1
Imagen de osinet
+1
0
-1

Holas les cuentoque segui todo lo recomendado por ustedes pero ni aun asi consigo solucionarlos cuando un apt-get upgrade me sale ese error de:
osinet@osinet-laptop:~/sudo apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
E: El paquete sun-java5-bin necesita ser reinstalado, pero no se encuentra un archivo para éste.

no puedo hacer nada porfa ayudenme :(

+1
0
-1