montaje de webcam con modulo spca5xx

+1
0
-1

-Aconsejo hacerlo todo desde una consola de root.

-Bajate las linux-headers de tu kernel, las sources de tu kernel q en ubuntu se llaman linux-sources,
build-essential y las gcc

-Descomprime las sources en /usr/src y enlazar con

#ln -s /lib/modules/tukernel/build /usr/src/linux-sources x.x.x

-Descomprime el driver en tu /home/tu_usuario/nombre_que_queras_dar

$tar -zxvf spca5xx-20050116_sheimers_webshotII_support.tgz

-Pasate al directorio donde haz despcomprimido.

$cd /home/tu_usuario/nombre_q_quieras/spca5xx-20050116_sheimers_webshotII_support

-Pasaremos los comandos de instalacion.

#make

#make install(este puedes cambiarlo por chekinstall y puedes hacer un paquete deb para otra vez o dejarselo a los compañeros colgado en algun sitio :-)

-Cargaremos el modulo para su uso.

#modprobe spca50x

-Añado un paso del compañero erral para carga del modulo de video.

#modprobe videodev

-Enlaza /dev/video0 sino no veras nada aunque se encienda tu webcam.

#ln -s /dev/video0 /dev/video

-Por si no tuvieses añadido tu usuario al grupo video.

#addgroup (nombre usuario) video. Esto añade al grupo video a tu usuario

Utiliza el programa gqcam o camorama para ver si tu webcam funciona.

A mi en particular me ocurria una cosa curiosa el enlace del /dev/video se perdia cuando reiniciaba por lo q tuve q hacer un pequeño script y meterlo en el arranque si te da guerra suelta la pregunta por aqui y te explico, aunque no tiene nada de dificil. :-)
Despues de algunos dias he ido repasando los pasos y creo q no hay ningun fallo auna asi si encontrais algun fallo o hay q añadir algun paso ya sabeis y si os sale bien por favor comentarlo.Abajo teneis donde bajar los drivers.
AQui teneis una lista de webcam's soportadas

Aqui podeis bajarlos

Comentarios

Imagen de Ceskidull

Hola arriero he estado siguiendo tus pasos y todo ha salido bien todo menos los últimos pasos, como tengo una capturadora de video en la carpeta dev me aparecen video0 y video1 mi cámara Web está en video1 pero con gqcam y camorana me dice que el archivo video0 no está disponible y con gnomemeeting solo me detecta video0 y la tarjeta capturadora.

Alguna sugerencia

Imagen de arriero

Primero gracias por pasarte por mi diario :-)
Bueno tu problema se resuelve cambiando el enlace desde video0 a video1 ya q camorama reconoce tu capturadora como webcam ya q esta en el enlace q ella necesita. :-)

$sudo ln -s /dev/video1 /dev/video

Perdona por no responder antes pero no suelo entrar mucho por mi diario solo cuelgo de vez en caundo recetas q me sirven y quiero compartir con la comunidad. Si quieres algo mas dejame comentarios en la receta de mi blog q eso me llega a mi correo y miro habitualmente. Saludos.
..................................................
Las mejores ideas son propiedad de todos.
Séneca.Epístolas, siglo I d.C.
Mi blog

Si reparas tu problema, añade(Solucionado)en el asunto de tu primer post, así es mas fácil para el que busca después.Mi Blog

Imagen de Anónimo

intento instalar el driver spca5xx como en https://wiki.ubuntu.com/Spca5xx

Me carga el driver, pero no me crea el /dev/video ni /dev/video0 ni /dev/video1. Intento crear yo el dispositivo haciendo:

mknod /dev/video0 c 81 0

Me lo crea, pero al ejecutar camorama o cualquier otro, sigue sin funcionar (aun haciendo el enlace desde /dev/video)

Imagen de arriero

Perdón por no contestar antes pero como puse por hay arriba suelo entrar poco aqui.
Bueno creo q la respuesta es algo simple en el caso de q no tengas tarjeta capturadora de video ya q /dev/video0 es un enlace de /dev/video con lo cual solo tendrias q enlazar video con video0 con un enlace duro leete man ls y vera q es lo q te digo.Saludos.

..................................................
Las mejores ideas son propiedad de todos.
Séneca.Epístolas, siglo I d.C.
Mi blog

Si reparas tu problema, añade(Solucionado)en el asunto de tu primer post, así es mas fácil para el que busca después.Mi Blog

Imagen de Anónimo

Por fin encuentro un procedimiento que me funcionó. Con el google había encontrado infinidad de métodos sin resultados satisfactorios, hasta que por fin vine a los foros de ubuntu-es (una vez más).

Muchas gracias.

Saludos.

Imagen de Anónimo

hola mi cam no presenta problema de instalacion

sino de coneccion me dice halgo sobre el USB

yo lo conecto y reinicio el equipo y nada

me pueden ayudar por favor

mil gracias

Imagen de Anónimo

muchas gracias por su atención

pero no es eso yo tenia conectada

la impresora la quite y coloque

mi camara, antes me daba pero hoy no

detodas formas gracias por

querer ayudarme