Problemas con los Gdesklets

No sé que pasa, pero a medida que he ido actualizando, los desklets me han ido a peor.
En Warty, tenia varios desklets, los que mas me gustaban de los que tenia eran unos lt que me decian lo que consumia de cpu, la ram que utilizaba y me quedaba, el tiempo que hacia el espacio ocupado en los discos duros y a parte una barra donde anclaba iconos de aplicaciones que cuando pasabas el raton por encima, estos cambiaban de tamaño. Esto último dejaba a mis amigos enamorados de mi "linux".
El primer problema que tuve, fue hace tiempo cuando migré a Hoary. Sin saber el motivo, dejaron de funcionarme todos los desklets que tenia para saber la cpu, la ram y esas cosas que he dicho antes. Vale, tenia un gestor para los desklets que tal vez hacia mas fácil el añadirlos (aunque anteriormente no lo veia complicado...) pero es que ya no me iban todos esos desklets...Al intentar colocarlos de nuevo, me salian errores, todos del mismo estilo, por ejemplo:

Traceback (most recent call last):
  File "/usr/lib/gdesklets/factory/SensorFactory.py", line 59, in create_sensor
    module = __import__(name)
  File "/usr/share/gdesklets/Sensors/LTVMemory/__init__.py", line 5, in ?
    from libdesklets import glibtop
ImportError: cannot import name glibtop

o este otro

Traceback (most recent call last):
  File "/usr/lib/gdesklets/factory/SensorFactory.py", line 86, in create_sensor
    sensor = module.new_sensor(args)
  File "./LTVCpu/__init__.py", line 71, in new_sensor
  File "./LTVCpu/__init__.py", line 19, in __init__
AttributeError: 'module' object has no attribute 'cpu'

entre otros desklets que me dan error.
Total, que al final me conformé y deje de intentar usarlos y estar contento ya que por lo menos ese desklet que a mis amigos les gustaba tanto (y a mi también) funcionaba.
Pero hace unos dias al volver a actualizar, ese desklet me hizo una cosa rara y es que ahora lo que aparece es como un pequeño cuadradito marron, pero no hay rastro de los iconos. He eliminado el desklet, he creado uno igual, he intentado añadir iconos como lo hacia antes, y nada, ese cuadradito marron chiquitin sigue saliendo y lo que debia salir no sale...No sé que hacer para dejar mi escritorio igual de chulo que antes. Ya sé que eso solo son pijadas, pero por esas pijadas conseguí que un colega se instalara Ubuntu para tener un escritorio casi tan bonito como el que tenia yo antes :P
A ver si alguien de por aquí sabría decirme como solucionar esto, ya que a mi se me escapa de las manos. Sospecho que hay algún error en el python, o que no me detecta los sensores que usa para mostrar los datos, no tengo ni idea, pero lo que me estraña es que otros si que me funcionan...
No sé, cosas de la informática.
Lo dicho, a ver si alguien me puede ayudar o que me digan si también les pasa lo mismo, a lo mejor es un bug o algo.
Hasta otra!

Imagen de Chabivi
+1
0
-1

Me pasa exactamente lo mismo que a ti, en Warty lo tenia todo perfecto y aqui nada.
Supongo que sera tema de sensores, yo ya los instale como lo hice en warty. La pega es que yo estoy en un portatil y lo de la temperatura y tal no me funcionaban tampoco en warty, pero si los de Espacio de disco restante, memoria utilizada, version del kernel etc.. y ahora no me chuta ninguno aqui. :(
Pero weno todo tiene solucion, a ver si alguien nos ayuda.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Bueno, he actualizado de nuevo el gdesklets y nada, sigue el mismo error...
Alguien que sepa de esto?

+1
0
-1
Imagen de arrizaba
+1
0
-1

Cuando instale Hoary en el ordenador de un amigo (yo todavia sigo con Warty), vi que los gdesklets que mencionas (los LT), no estaban en el directorio de Displays. De alguna forma, los han retirado de gdesklets-data. Y si estan, parecen diferentes, asi que sera otra version.
Como los de la anterior version funcionaban seguro, yo probaria a bajar estos gdekslets. Prueba con los de la 0.26

http://gdesklets.gnomedesktop.org/files.php?func=gd_downloadfile&gd_file...

+1
0
-1
Imagen de Anónimo
+1
0
-1

He desinstalado todo y lo he vuelto a instalar con la version que viene de hoary y no va bien, da problemas.
La starterBar sigue sin irme como dios manda y los lt me dan errores (se ve que en algunos tiene algo que ver al usar la libdesklets o algo así y en otros pues ni idea)
Probaré lo que me has comentado de instalar los desklets de la version 0.26 a ver que tal.
Ya contaré los resultados

+1
0
-1
Imagen de Anónimo
+1
0
-1

Algo un paste de errores que me salen:

exceptions.AttributeError:                                                           
'module' object has no attribute 'disk'                                              
>> could not load source code for hilighting <<                                      
exceptions.AttributeError:                                                           
'module' object has no attribute 'cpu'                                               
>> could not load source code for hilighting <<                                      

El único que me va es el del reloj. El del tiempo sale la forma pero no aparece ningún tipo de datos (le doy a configurar y no hace nada) y el de la memoria me dice que no lo encuentra que posiblemente no esté instalado (aunque si que lo está...)
Definitivamente, un desastre.

+1
0
-1
Imagen de Corso
+1
0
-1

luego elimina TODO rastro de desklets y gdesklets de tu pc...usa "locate desklets" y allí donde veas ficheros de configuración quítalos.
Luego reinstala en limpio.
Yo actualicé a hoary,actualicé gdesklets y no tengo ningún problema con ellos.

+1
0
-1

:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:

Un Rincon Mas

Hoary Hedgehog&Dapper Drake mandan!!

:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+: