Aceleracion 3D Ati, Ubuntu Edgy , Ubuntu Dapper

Imagen de Jersoncito
0 puntos

Esto lo extraje del wiki en ingles Instalacion Ubuntu Edgy/Dapper:

UBUNTU EDGY

Con Ubuntu Edgy viene incluido el driver 8.28.8 para las tarjetas Radeon 8500+ y las X-series hasta la X1900.
En Ubuntu Edgy la extension Composite ya viene habilitada, sin embargo, fglrx no soporta Composite con DRI. La solucion es desahibiltar la extension Composite en el Xorg.conf asi:

En una terminal:

sudo gedit /etc/X11/xorg.conf

Luego al final del todo el texto, agregar estas lineas:

Section "Extensions"
Option "Composite" "Disable"
EndSection

Despues guardar y cerrar.

Ahora hay que instalar el driver, pero asegurarse que los repositorios multiverse y universe estan habilitados. Asi que en la terminal (una linea a la vez):

sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r) #Okay if it is already installed
sudo apt-get install xorg-driver-fglrx
sudo depmod -a
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

Ahora ya pueden cerrar su terminal y reiniciar el sistema como lo hacen usualmente, o bien:

sudo shutdown -r now

Despues de reiniciar deberia de estar funcionando, para probarlo, abran terminal y escriban:

fglrxinfo

Luego les aparecera su driver correspondiente, en mi caso que use una laptop Acer Travelmate 2440 queda lo sig:

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON XPRESS Series Generic
OpenGL version string: 2.0.6011 (8.28.8 )

Otra manera de comprobar que han logrado la aceleracion grafica es con:

glxgears –iacknowledgethatthistoolisnotabenchmark

Vera una pequeña ventana con engranajes 3D girando constantemente (si se quedan pegados o andan muy lentos, entonces no todo esta resuelto. Aun problemas?

Una manera de solucionarlos, despues de haber realizado los pasos anteriores, es cambiar la configuracion inicial ati (aticonfig --initial command) esto se hace editando el archivo /etc/X11/xorg.conf asi:

sudo gedit /etc/X11/xorg.conf

cuando abran el archivo, buscar la "Device" section y reemplazan la palabra "ati" con "fglrx"
Luego guardan y cierran.
Reinician la maquina y todo deberia andar bien.

UBUNTU DAPPER

Para los amigos que estan con Dapper, es basicamente el mismo proceso, pero sin Deshabilitar Composite, ademas se les va instalar el driver 8.25.18
Asi que en una terminal:

sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r) #Okay if it is already installed
sudo apt-get install xorg-driver-fglrx
sudo depmod -a
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

Despues de reiniciar deberia de estar funcionando, para probarlo, abran terminal y escriban:

fglrxinfo

Luego les aparecera su driver correspondiente

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Su tarjeta
OpenGL version string: 2.0.6011 (8.25.18)

Otra manera de comprobar que han logrado la aceleracion grafica es con:

glxgears –iacknowledgethatthistoolisnotabenchmark

Vera una pequeña ventana con engranajes 3D girando constantemente (si se quedan pegados o andan muy lentos, entonces no todo esta resuelto. Aun problemas?

Una manera de solucionarlos, despues de haber realizado los pasos anteriores, es cambiar la configuracion inicial ati (aticonfig --initial command) esto se hace editando el archivo /etc/X11/xorg.conf asi:

sudo gedit /etc/X11/xorg.conf

cuando abran el archivo, buscar la "Device" section y reemplazan la palabra "ati" con "fglrx"
Luego guardan y cierran.
Reinician la maquina y todo deberia andar bien.

Los de Dapper, si esto no les ayudó, pueden ver este minitutorial:
http://www.ubuntu-es.org/index.php?q=node/19975

Saludes
Jerson Bejarano

Imagen de hackata
+1
0
-1

He seguido tus instrucciones para configurar 3d en mi ATI 9200SE con edgy pero no consigo na de na, cambio el driver desde ati a fglrx y al reiniciar el monitor se queda sin señal (DVI-I). he dedicado varios días pero no lo consigo, parece que hay error en xorg https://launchpad.net/distros/ubuntu/+source/xserver-xorg-video-ati/+bug...

A ver si se aclara el panorama.

Zenkius

+1
0
-1
Imagen de apetekan
+1
0
-1

creo que tu aportacion es valiosisima pero permiteme una critica

bajo mi punto de vista la solucion que tu aportas es perfectamente valida y sobretodo bastante sencilla, pero creo que enredando un poco, e instalando los ultimos drivers de ati, se consiguen mejores resultados que con estos metodos

en mi caso con edgy y una ati x300 en un portatil acer conseguia con el driver fglrx generico unos 250 fps en el bench de glxgears

ahora tengo instalado el driver 8.31.5 y consigo unos 2100 fps, creo que vale la pena enredar

yo segui el metodo 2 de este tutorial http://wiki.cchtml.com/index.php/Ubuntu_Edgy_Installation_Guide

Te pongo la salida de los tests de mi grafica para que compares.
Saludos.

************************************************************************************************************

usuario@powerpc:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON X300 Generic
OpenGL version string: 2.0.6174 (8.31.5)

*************************************************************************************************************

usuario@powerpc:~$ glxgears -printfps
10618 frames in 5.0 seconds = 2123.401 FPS
10585 frames in 5.0 seconds = 2116.934 FPS
10582 frames in 5.0 seconds = 2116.340 FPS
10586 frames in 5.0 seconds = 2117.010 FPS
10570 frames in 5.0 seconds = 2113.906 FPS

***********************************************************************************************************

usuario@powerpc:~$ glxinfo | grep render
direct rendering: Yes
GLX_ATI_pixel_format_float, GLX_ATI_render_texture
OpenGL renderer string: MOBILITY RADEON X300 Generic

+1
0
-1
Imagen de Anónimo
+1
0
-1

Pues yo tengo una ati 9550 en un PIV, y aunk siguiendo las guias he probado varias cosas, y tengo instalados los drivers 8.31.5, alcanzo solo 125 FPS a pesar del "direct rendering: Yes"
Se os ocurre alguna solución?
Un saludo

+1
0
-1
Imagen de Ishikawa
+1
0
-1

Hola!

voy a hacer mi pequeña aportacion...

Instalando el ultimo driver de ati, como bien dice apetekan se aumentan los FPS, (a mi a 3900 FPS) PERO los juegos no funcionan a la perfeccion. Yo juego a Regnum Online, y cuando instale el ultimo driver la gran mayoria de las texturas no las cargaba bien.

Entonces probe a instalar el driver generico del repositorio de ubuntu, y me funciono otra vez bien.

De nada sirven 3000 FPS de mas si luego no maneja bien los graficos.

un saludo!!

---------------MIS DATOS------------------------------
edgy eft

OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON X700 Generic
OpenGL version string: 2.0.6011 (8.28.8)

+1
0
-1
Imagen de everkor
+1
0
-1

pase 14 dias buscando un puto manual para la configuracion 3D de mi tarjeta ati

PERO GRACIAS A TI MI AMIGO NO MAS PROBLEMS

+1
0
-1
Imagen de Anónimo
+1
0
-1

gracias por tu exelente manual, pero en mi caso tengo una ati radion 9100 y en tratado de seguir los pasos tal y como dicen en http://wiki.cchtml.com/index.php/Ubuntu_Edgy_Installation_Guide que me imagino que tiene que ser lo mismo a lo que estas describiendo, y la berdad e tratado de mil formas hacerla funcionar y no e podido.

quisiera saber si hay alguien que tenga una ati como la mia que la aya echo funcionar y si me puede explicar como lo iso , pues ya me duele la cabeza de estar probando y probando barios tutoriales y no me funciona.

gracias.

+1
0
-1
Imagen de jorge407
+1
0
-1

Soy un poco distraido y me olvide de realizar los siguientes pasos:

En una terminal:

sudo gedit /etc/X11/xorg.conf

Luego al final del todo el texto, agregar estas lineas:

Section "Extensions"
Option "Composite" "Disable"
EndSection

 AHORA CUANDO ENTRO A UBUNTU(EDGY); NO ME APARECE LA VENTANA PARA VERIFICAR MI USUARIO Y CONTRASEÑA; SE PONE LA PANTALLA DE COLOR NEGRO; COMO PUEDO HAER PARA CORREGIR ESTO. 

DE ANTEMANO GRACIASS. 

 

+1
0
-1